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1) Getting Started

Welcome to the NetPoint® User Guide with NetRisk™ Risk Analysis. NetPoint® is a powerful and easy-to-use

project planning and scheduling application. NetRisk™ Risk Analysis is a state-of-the-art GPM-based risk

modeling and risk analysis module that runs within NetPoint®. Combined, NetPoint® with NetRisk™ offers

seamless scheduling and risk analysis using the same graphical and intuitive interface. NetRisk™ Risk

Analysis is available as a supplementary module to NetPoint®. If you’d like to add a NetRisk™ Risk

Analysis license to NetPoint, please contact NetPoint® sales at http://pmatechnologies.com/contact.

NetPoint® with NetRisk™ Risk Analysis makes use of the Graphical Path Method® to introduce a number of

innovative concepts to the practice of scheduling and risk analysis. To ensure that all capabilities are fully

understood and utilized, we encourage you to use this guide as a reference, to browse through online

resources, and to consider signing up for training services. For more information about training, please visit:

http://pmatechnologies.com/services.

Terms of Use

©2008-2015 PMA Technologies, LLC. All logos, trademarks, page headers, images, splash screens, and

graphics displayed in this document are service marks, and/or trade dress of PMA Technologies, LLC. Except

as explicitly permitted herein, any of the mark is not permitted to be circulated in any form or by any means by

any individual or any entity.

NetPoint, the NetPoint logo, GPM, Seeing is Planning, and Life’s a Project are registered marks of PMA

Consultants, LLC; PolyTime and Truth in Scheduling are registered marks of PMA Technologies, LLC;

Graphical Planning Method, Graphical Path Method, and NetRisk are trademarks of PMA Technologies, LLC.

U.S. Patents 8249906, 8400467, 8531459, 8751280. Patents Pending.

USE AND DISCLOSURE RESTRICTIONS: The NetPoint and NetRisk Software (“SOFTWARE”) described in

this document is the property of PMA Technologies, LLC (“LICENSOR”). It is furnished under a license

agreement and may be used and/or disclosed only in accordance with the terms of the agreement.

No part of this publication may be reproduced or transmitted in any form or by any means, electronic, manual,

photocopying, recording or otherwise, except as permitted by the author or LICENSOR. Neither the authors

nor LICENSOR accept any responsibility for any errors or omissions or for any consequences that may result

from any errors or omissions.
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About this Text

Within this guide, you’ll find steps and notes. Steps are numbered instructions at the beginning of each

chapter or section that indicate how to carry out a particular function. Notes serve to summarize the windows

and fields, and they contain screenshots and important notes that expand upon the steps.

Certain categories of words in this user guide are color-coded to distinguish them from the rest of the

text. Blue is used for the names of icons, commands, and buttons, such as OK. Green is used for menu

paths, like View > Toolbar > Dock to Top. Gray is used for the names of windows, tabs, and text labels, like

the Codes Manager or the Properties tab.

When additional or related information is available, a link will appear italicized and in blue. Clicking the link will

jump you directly to that section.

NOTE: The features covered in this manual correspond with version 4.2.2. Please check the version

and release date of your software by clicking Help > About NetPoint… from the menu bar, or

contact NetPoint support if you need additional help or have other questions.
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System Requirements

A successful collaborative planning session requires that participants remain engaged and focused. Using

NetPoint on a well-equipped computer to drive the planning session will help to avoid costly delays in

information processing, and will help maintain a smooth tempo of plan development and flow of information.

Installing/Updating

To install or upgrade NetPoint, administrator rights are required. Within 30 days of installation, license

activation is required to grant continued access to NetPoint. If you do not have administrator rights, please

contact your IT Department or system administrator. Once installed, administrator rights are NOT needed to

run the NetPoint software. For more info, see Installing/Upgrading NetPoint.

Operating System

NetPoint is compatible with Windows XP, Windows Vista, Windows 7, Windows 8, and Windows 8.1 including

64-bit versions.

Hard Disk

To install NetPoint, a minimum of 200MB of free storage space is recommended.

Virtual Memory

NetPoint requires a minimum of 1GB of RAM, but 4GB of RAM is suggested for better performance.

• Up to 250 objects: at least 1GB

• 250 to 500 objects: at least 2GB

• Over 500 objects: at least 4 GB

Supported Schedule Size

Supported schedule size depends on the number of objects (activities, links, milestones, etc.), the computer’s

processor/clock speed, and how much RAM it has. With a well-equipped machine, a delay of about 0.5

seconds can be expected for a schedule between 500-1,000 objects, which is considered to be a tolerable

upper limit. You can continue to work with a schedule until about 2,500 objects with a delay of 1 second.

Tip: When working with larger schedules, we recommended hiding the resource histogram, as displaying it

can add processing time.

Monitor & Projector Resolution

NetPoint requires a minimum screen resolution of 1024×768 and a 16-bit color setting. Higher resolution and

a 32-bit color setting result in a better graphic image.

NOTE: A lower resolution may result in the inability to reach the OK and Cancel buttons in some

dialog windows.

Concurrent License Monitoring

Concurrent license access is monitored by Sentinel HASP®, a third party product by SafeNet®, which is

installed on your server and runs a service that monitors HASP licensing on your Network. In addition, each
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NetPoint workstation must be configured to the license server as described in the NetPoint Workstation

Activation & Workstation Configuration to License Server document.

3rd Party Applications

For import/export, any necessary privileges will be set automatically upon installation.

Application Supported Versions

Primavera P6 6.0 and higher

Microsoft Project 2007, 2010

Microsoft Excel 2010, 2013

Microsoft Outlook 2007, 2010, 2013

NOTE: To benefit from Microsoft Outlook integration, NetPoint requires 32-bit installation. To check

in Outlook 2010, click “File > Help”, and then look for the bit number in the right-most sections

under “About Microsoft Outlook” after the “Version”. To check in Outlook 2013, click “File >

Account”, click the big “About Outlook” icon, and then look for the bit number on the first line at the

very end.

NOTE: To benefit from Microsoft Excel integration, NetPoint requires 2010 or higher.
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Installing/Upgrading NetPoint

To install or upgrade NetPoint, administrator rights are required. If you do not have administrator rights, either

an administrator must login to perform the installation or you must be granted administrator rights on your

local machine. If this is the case, please contact your IT department or system administrator.

Once installed, administrator rights are NOT needed to run the software. For import/export, any necessary

privileges will be set automatically upon installation. To check what version you’re running, go to Help >

About NetPoint… from the menu bar and check the release date at the top.

NOTE: For NetPoint to launch properly, Windows must have a “My Documents” folder defined

within the user directory, as this is where NetPoint will stores recovery files. Otherwise, NetPoint

will not be able to successfully initialize.

Steps

1.

Click or paste the download link

into your system’s web browser.

For installing or upgrading a

licensed version, enter the

credentials in the security

window and click Log On.

NOTE: The trial does not

require credentials and should

begin downloading

automatically.

2.
In the confirmation pop-up, click

Run.

3.
When the download finishes, click

Actions.
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4.
When the filter window opens,

click Run Anyway.

5.
If the User Account Control

window opens, click Yes.

6.

NetPoint setup will begin. A series

of notifications will appear.Click

OK for each one.

7.
In the NetPoint Setup window,

click Next.
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8.

Check the option next to I accept

the terms in the License

Agreement and click Next.

9.

Leave the location as default or

browse for a new one, and then

click Next.

10.
Configure the shortcuts or leave

them as default, then click Next.
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11.
Begin the installation by clicking

Install.

12.

During installation, NetPoint will

open momentarily for entering

some system defaults. Enter your

name and email and click OK.

14.
Check the option next to Launch

NetPoint and click Finish.

Notes

Choosing a Default Calendar

By default, all activities and milestones in NetPoint are assigned a calendar when they are created. Click the

down arrow button and choose a country to use as the basis for the workweek and holidays for the default
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calendar. From within NetPoint, custom calendars can be created with custom workweeks and holidays, and

any of these can be set as default for the schedule. See Project Calendars and Setting Default Properties for

more details.

Choosing a Default Time Unit

If your version of NetPoint includes PolyTime, you will also be able to set a default time unit for new

schedules. Click the down arrow button and choose a time unit to apply to all objects in the schedule.

Unlike calendars, the time unit cannot differ from activity to activity. From within NetPoint, a different time unit

may be chosen at any time during planning. See PolyTime for more details.

Entering Default User Information

NetPoint has the capability to send email notifications. Enter the name and email address that will be used to

identify the sender. From within NetPoint, a different name and/or email may be used each time an email

notification is generated. See Resource Notifications for more details.
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Project Folders

NetPoint® makes use of a project/folder-based structure, which organizes your schedule files (such as

reports, templates, simulation data, recovery files, and iObjects) automatically together. Instead of opening

and closing schedule files, you will be opening and closing project folders, which then load into NetPoint

whichever schedule file they contain.

All new schedules must have a project folder created for them. This is done automatically when saving a

schedule for the first time. All legacy schedules need to be imported and converted to projects before they

can be opened. Once converted, however, schedules are opened and saved just like before, with only minor

differences to the interface.

This section details instructions for the following:

1. Navigating in windows explorer

2. Converting files to folders

3. Opening and unzipping

4. Saving and renaming

5. Sharing and sending
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Navigating in Windows Explorer

When working with projects, keep in mind that the contents of a project folder are not locked. However, it is

not recommended to drag in or out any files that were placed there by NetPoint.

Project folders CAN be moved in and out of parent directories. However, we recommend keeping them all in a

single location, so that browsing in NetPoint is less cumbersome.

Steps

1. Open Windows Explorer.

2. Browse to the location where the project was saved.

3. Double-click the folder which contains the project name.

Notes

Folder Contents

File
type

Icon Example Definition

.np4 NetPointFile.np4
The schedule file for the project. NOTE: Do not remove

or rename.

.nzp [PROJECT_NAME].nzp

The project zip file. Only available once the project is

saved. This includes all contents inside the project folder,

and is updated each time the schedule is saved.

.npl NetPointLayout.npl

The layout file. Only available after saving a layout. For

more info, see the Layouts chapter. NOTE: Do not

remove or rename.

.Lock NetPointFile.Lock
The lock file. Only available when the schedule is

currently open.

.NREC [##########}.NREC

The recovery file. Only available when there exist 2 or

more unsaved changes. For more info, see

Understanding File Recovery.

.xml NetPointData.xml Only available after exporting to P6.

.S01

or

.B01

SimulationResults.S01

NetRisk simulation file. Only available after running

NetRisk. For more info, see Cost & Schedule Risk

Analysis. NOTE: Do not remove or rename.

.xls [PROJECT_NAME].xlsx
The linked excel file. Only available after exporting to

Excel. For more info, see Exporting Linked Reports.
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File
type

Icon Example Definition

Sub-

folder
Attachment

A folder containing any embedded iObjects. For more

info, see Info Objects/Attachments.
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Converting Files to Folders

All schedules created before version 4.1, release 22 Mar 13 must be converted to projects before they can be

opened. At this time, converting these schedules must be done one at a time. This can be done outside of

NetPoint by browsing for the file in Windows Explorer, or inside NetPoint through the file menu. Instructions

for both are provided.

Upon converting, a folder of the same name will be created, the file will be automatically moved inside it, and

the filename will be changed to “NetPointFile.np4.” In the event that you change your mind or something goes

wrong during the import, a back-up copy of the schedule will automatically be saved to the original location

with “-backUp” appended to the end. For a list of other changes, see the notes end of this section.

Steps

Outside of NetPoint

1. In an explorer window, browse for the desired file.

2. Double-click the .npt or .np4 file, or right-click and choose Open.

NOTE: If a message opens, see Troubleshooting Opening for more info.

From Within NetPoint

1. First, choose File > Convert and Open Legacy Schedules from the menu bar.

2. Browse for the desired file and click Open.

NOTE: If a message opens, see Troubleshooting Opening for more info.

Notes

Descriptions as Annotations

Descriptions that were being displayed as annotations in legacy schedules will be converted to conventional

annotations. We recommend re-displaying the descriptions for these objects and deleting the annotations to

avoid any unexpected behavior.

Lags on Non-FS Links

Lags on link types other than finish-to-start are no longer supported. Therefore, upon opening a schedule that

contains them, an error message will display, the lags will be automatically removed, and the affected links

will be spotlighted on the canvas.

Custom Positions of Data Elements

Data elements (durations, dates, descriptions, etc.) that have been positioned more than 3″ away from their

host objects will be reset, and their host objects will be spotlighted on the canvas.
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Opening and Unzipping

When working in NetPoint, projects are opened just like files, with only minor differences to the interface. On

the left, both project folders and non-project folders will show up in the tree. On the right, only projects will be

listed. Projects should always be chosen on the right, NOT on the left. The left is only for selecting the parent

directory in which the project resides.

If you’ve selected a parent directory on the left, but the project is not showing up on the right, its schedule file

may have been removed from it. To correct this, look for a file named “NetPointFile.np4” that no longer

resides in a folder named after a project and move it back in to the proper folder. Until this is done, you will be

unable to open the project from within NetPoint.

Likewise, if a folder which is certainly not a NetPoint project appears in the list on the right, such as

“MyDocuments,” it likely contains an orphaned NetPointFile.np4. To correct this, determine which project

folder is missing a schedule file, and return it to its proper location

NOTE: To open the schedule from Windows Explorer, search for the folder which contains the

project name, open it, and then double-click the file called NetPointFile.np4.

Steps

Opening Projects

1. Choose File > Open Project from the menu bar.

2. On the left, browse for the directory in which the project resides, without yet choosing the project itself.

3. On the right, choose the project itself and click Open. NOTE: At any time, a project may be deleted or

renamed by right-clicking on it in the list.

NOTE: If a message opens, see Troubleshooting Opening for more info.

Unzipping Projects (.nzp/.zip)

1. Choose File > Unzip and Open Project from the menu bar. The Open window will default to the folder

where the last project was zipped and saved.

2. If a different project is desired, browse for the directory in which it resides on the left.

3. On right right, select the zip file file from the list and click Open. NetPoint will automatically save the

project to the same folder where the zip file is.

NOTE: A .nzp can also be opened by simply double-clicking it in an Explorer window.

Opening Projects from Emails (.nzp Files)

1. Right-click on the file from your preferred email application.

2. To view the schedule immediately, choose Open. The Opening Mail Attachment window will open..

a. Click the Open button.

3. To save the .nzp file first, choose Save As.

a. Browse for the desired location and click Save. NOTE: If you make a change to the file name,

make sure that “nzp” still shows up next to Save as type. If it does not, make sure to append

“.nzp” at the end of the filename to avoid losing the file type.

b. To open the schedule, navigate to the location in an explorer window and double-click the .nzp file.
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NOTE: If a message opens after opening, see Troubleshooting Opening for more info.

Opening Projects from Emails (.zip Files)

1. Right-click on the file from your preferred email application..

2. Choose Save As (recommended).

a. Browse for the desired location and click Save. NOTE: If you make a change to the file name,

make sure that “nzp” still shows up next to Save as type. If it does not, make sure to append

“.nzp” at the end of the filename to avoid losing the file type.

b. To open the schedule, see Unzipping Projects.

3. To view the schedule without saving, choose Open (not recommended). The Opening Mail Attachment

window will open.

a. Click Open. An explorer window will open. NOTE: The .zip file will be temporarily saved to

“C:\Users\[your username]\AppData\Local\Microsoft\Windows\Temporary Internet Files\

Content.Outlook[alphanumeric string]”.

b. Navigate up one level by clicking the name of the temporary location. WARNING: If you just open

the folder and launch the NetPointFile project file without navigating up and unzipping, the

.zip file will not go through the proper extraction process and the project may be missing a

number of supporting files.

c. Right-click on the .nzp and choose Extract All.

d. If a Windows Security window opens, click OK.

e. To choose a new location, click Browse, select the desired location, and click OK.

f. Otherwise, just click Extract. A new explorer window will open.

g. Double-click the project folder.

h. Double-click the filed called “NetPointFile.np4″.

NOTE: If a message opens after opening, see Troubleshooting Opening for more info.

Notes

Troubleshooting Opening

Message

Printer

Unavailable

If the printer that was

used when the

schedule was last

saved is unavailable

or not installed, a

warning will open.

Click OK.
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Message

Choose a new printer

next

to Name andclick OK.

The schedule will

then open. For more

info on printers,

see Print Setup.

File

Already

Open

If the project is open

on another machine,

a lock may have been

placed to protect the

file. In this case, the

schedule can only be

opened in read-only

mode, and the File

Already Open!

warning will open.

Click View as Read-

only. The schedule

will then open.

File

Recovered

If an unexpected

crash occurred,

NetPoint® will

automatically recover

any schedules that

may have been open

and unsaved when

the application

terminated. For more

info see Recovering

Existing Projects.
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Message

Bad Data

Positions

If any data elements

are more than 3″

away from their host

objects, a warning will

open. Click Continue

to Canvas. No further

action is required.

Invalid

Lags

If a legacy schedule

is opened where a

non-finish-to-start link

had a lag, a warning

will open. Click

Continue to Canvas.

No further action is

required. For more

info on lags, see

Adding Lags to Links.

Duplicate

Code/Value

IDs

If a schedule is

opened where a code

or value is found to

have the same

system ID as another

code or value, a

warning will open and

any assignments will

be lost. Click OK. To

review code

assignments, see

step 1 of Exporting an

Existing

Template and choose

“Defaults – Codes &

Code Assignments”.

Incomplete

or Missing

Data

If a schedule is

opened which cannot

be read, a warning

will open. This may

be because

it’s missing data, it’s

been corrupted, or it

contains a bad
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Message

format. This is rare

and should not occur

under normal

circumstances. Click

OK and contact

NetPoint support.

Resolution

Violation

If a legacy schedule

is opened where one

unit of time is less

than the width of a

pixel on the screen,

the Resolution

Violation Alert will

open. Choose from

the available options

and click OK (we

recommend choosing

the second option to

avoid additional

steps). For more info

on resolution, see

Print Setup.

a.

If increasing the page

size, a printer window

will open. Click the

dropdown button next

to Size and choose a

page size that meets

the recommended

width from

the Resolution

Violation

Alert window.

b.
If increasing the

number of tiles, no
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Message

further action will be

required.

c.

If reducing the length

of the project,

the Schedule

Properties window

will open. Click

the Dates tab, and

under Calendar

Dates, choose a start

date that is later in

time or an end date

that is earlier in time.

This process may

have to be repeated

until satisfactory.

d.

If increasing the

resolution, open the

Control Panel from

the Windows Start

menu, choose Adjust

Screen Resolution,

and choose one that’s

higher. Go back to

NetPoint and click

OK. This process

may have to be

repeated until

satisfactory.
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Saving and Renaming

When saving a project, the schedule itself will be named NetPointFile.np4, a folder will be created using the

description you entered, and the schedule file will be automatically placed in it. The NetPointFile.np4 file

should never be renamed; instead, to rename a project, always edit the folder itself.

In addition, each time a project is saved, a file with a .nzp extension will be saved in the project folder for easy

emailing or uploading. For more info, see Sharing and Sending Projects.

NOTE: If you’re downloading a project from the web through a browser, always right-click to specify

where it will be saved, as some download locations may have limited access or permissions.

Steps

Saving

1. While viewing the desired schedule, choose File > Save Project or File > Save Project As from the

menu bar.

2. On the left, browse for the location in which you want the new project to be saved, and select it in the

list. NOTE: To create a new folder, click the New Folder button. To edit or delete a folder, right-click

and choose accordingly.

3. After selecting the folder, a list of existing NetPoint projects will show up on the right. Enter a description

next to Save Project As. This will be the name of the new project. NOTE: At any time, a project may

be deleted or renamed by right-clicking on it in the list.

4. After entering a description, click Save.

Renaming

1. While viewing the desired schedule, choose File > Save Project As from the menu bar. By default, the

Save window will default to the current project.

2. To choose a different project, browse on the left for the location in which the project resides.

3. On the right, right-click the project itself and choose Rename Project.

4. Begin typing and click Enter.

5. When finished, click Cancel.
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Sharing and Sending

To upload or email a schedule, it is recommended to use the .nzp file that can be found within the project

folder, as opposed to manually zipping the project or sending the NetPointFile.np4 file by itself. The .nzp file is

a compressed version of the project folder, which is updated each time the schedule is saved. It includes ALL

files placed in the project folder, regardless of whether or not they were generated by NetPoint or put there by

the user.

Alternatively, NetPoint provides an email utility from within the application. The email utility, however, will

ONLY include NetPoint-generated files, leaving out any files placed in the project folder by the user. For more

information, see the notes at the end of this section.

NOTE: To copy or move projects between hard drive locations, make sure to copy/move the entire

project folder and not just the NetPointFile.np4 file.

Steps

From within NetPoint

1. When viewing the desired schedule, choose File > Send as Email Attachment from the menu bar.

2. After a few seconds, the default email application will open, and a new message will be created with the

NetPoint .nzp file attached.

3. To finish, compose the message as desired and click Send.

NOTE: To open a project from an email, see Opening and Unzipping Projects.

Notes

Email Utility

When using File > Send as Email Attachment, the contents of the project will be slightly different, according

to the table below:

Permanent .nzp file File > Send as Email Attachment

Saved/

Unsaved

Changes

Only represents the last saved state. Any

changes, including iObjects that may have

been added, will not be reflected when

zipped unless the project has since been

saved.

Represents the latest state, regardless of

whether or not the project has been

saved.

Supporting

Files

Includes ALL files placed in the project

folder, whether generated by NetPoint or

added by the user.

Includes ONLY files generated by

NetPoint, including: simulation files,

layout files, exported Excel templates,

and iObjects that have been copied to the

project folder.
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About the Interface

The following aspects of the user interface are unique to NetPoint.

Autosave Windows

Many windows do not contain OK and Cancel buttons. Any changes made take effect when the window is

closed do not require confirmation. To close these windows, click the Exit icon and any changes will be

automatically saved. The only way to cancel any changes is to use the Undo feature.

Undo Unavailable Icon

Some actions found in menus or windows are excluded from being undone. This is because some actions

take place silently, and there would be no clear indication on the canvas if they were undone. To protect you

from undoing an action and not realizing it, the Undo feature will skip over these actions. Any menu or

window excluded from the Undo feature will be identified with the Undo Unavailable icon .
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Menu Bar

Click on a menu title to show the menu contents. Ellipses (…) at the end of a menu item indicate that another

interaction will follow that selection, such as a new window opening.
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File Menu

Click the File menu to access the following commands:

New Opens a blank NetPoint canvas. Shortcut: Ctrl+N.

Convert and

Open Legacy

Schedules…

Converts legacy NetPoint files into the folder-based structure and opens

the project. For detailed instructions, see Converting Legacy Schedule

Files.

Open Project…
Accesses saved project schedules. For detailed instructions, see Opening

and Unzipping Projects. Shortcut: Ctrl+O.

Close Closes the current schedule without exiting NetPoint.

Save Project Stores the latest changes to the file. Shortcut: Ctrl+S.

Save Project

As…

Saves a new schedule as a project or an existing schedule as a different

project or to a different location. For detailed instructions, see Saving New

Projects.

Send as Email

Attachment…

Zips the current project’s folder, opens the default email client, and

attaches the zip file. For detailed instructions, see Sending and Zipping

Projects.

Zip Project…
Zips a project’s folder and saves it to a specified location. For detailed

instructions, see Sending and Zipping Projects.

Unzip and Open

Project…

Unzips a project’s folder to a specified location and opens its schedule in

NetPoint. For detailed instructions, see Opening and Unzipping Projects.

Print
Opens options for selecting a printer and adjusting print properties.

Shortcut: Ctrl+P.

Print Preview
Adjusts zoom and stretch so the entire plan fits in the screen and turns

on page breaks. For detailed instructions, see Printing and Presenting.

Print Setup…
Opens options for changing the page size and orientation. For detailed

instructions, see Page Size.

Page Setup

(Tiling: a x b)

Opens options for tiling a schedule across multiple pages and hiding or

showing page breaks. For detailed instructions, see Page Size/Print Setup.
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Recent

Schedules

Lists the four most recently opened projects. Click on a specific plan name

to open that plan.

Import/Export
Contains options for interfacing with Primavera P6, Open Plan, MS Project,

XML, and Excel. For detailed instructions, see Inputs and Outputs.

Insert Image

File(s)…

Adds an image that will display on the canvas behind all objects except for

shades. For detailed instructions, see Image Files.

Take Snapshot
Opens options for generating an image from the schedule. For detailed

instructions, see Capturing Snapshots.

Exit Closes down the application and all open projects.
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Edit Menu

Click the Edit menu to access the following commands:

Undo

Reverses the last actions. Undo does not apply to zoom, stretch, page setup,

print setup, global text size, or calendar strip text size changes. Shortcut:

Ctrl+Z.

Redo

Reverses the previous undo actions. Redo does not apply to zoom, stretch,

page setup, print setup, global text size, or calendar strip text size changes.

Shortcut: Ctrl+Y.

Cut Removes selected item(s) from the canvas to the clipboard. Shortcut: Ctrl+X.

Copy
Places selected item(s) onto the clipboard without removing them from the

canvas. Shortcut: Ctrl+C.

Paste Inserts copied items from the clipboard. Shortcut: Ctrl+V.

Paste

Format

Applies only the display and formatting characteristics of copied items from the

clipboard to selected objects of the same type. For detailed instructions,

see Paste Format.

Delete
Erases selected item(s) from the canvas without saving to the clipboard.

Shortcut: Del.

Default

Format Copy

Options…

Opens options for choosing which data elements and formatting settings are

included in a given copy/paste format action. For detailed instructions,

see Paste Format.

Select All Selects all items on the canvas. Shortcut: Ctrl+A.

Find an

Activity…

Opens a window for locating a specific activity. For detailed instructions,

see Filters and Searching. Shortcut: Ctrl+F.

Search and

Filter

Objects…

Opens options for filtering the schedule. For detailed instructions, see Filters

and Searching. Shortcut: Ctrl+Shift+F.
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View Menu

Click the View menu to access the following commands:

Un-Hide All

Objects
Re-displays anything that was hidden on the canvas.

Horizontal

Split

Divides the window into two landscape canvases. For detailed instructions, see Split-

Screen/Multiple Canvases.

Vertical Split
Divides the window into two portrait canvases. For detailed instructions, see Split-

Screen/Multiple Canvases.

Resource

Key…

Displays or hides the resource key. For detailed instructions, see Reading the

Resource Graphs and Curves.

Toolbar Repositions, hides, or shows the toolbar.
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Schedule Menu

Click the Schedule menu to access the following:

Modify Schedule

Properties…

Opens a window for customizing and formatting the entire plan. For detailed

instructions, see Schedule Properties.

View Statistics…
Opens a window for viewing basic schedule metrics and statistics (like number of

activities, percentile floats, etc.). For detailed instructions, see Schedule Statistics.

Manage Schedule

Progress…

Opens a window for actualizing objects with respect to a data date. For detailed

instructions, see Actualizing Objects.

Set Password…
Opens options for settings a password to read or modify the schedule. For

detailed instructions, see Password Permissions.

Shade Non-

working Days

Adds vertical shading to all non-working days. For detailed instructions, see

Displaying Holidays.

Prompt for Grid

Numbers When

Pasting

Enables a prompt each time an object is pasted from the clipboard to determine

its vertical grid position. For detailed instructions, see Grid Options.

Open Layout

Manager

Opens a window for saving, viewing, and deleting layouts and running the

automated layout engine. For detailed instructions, see Layouts.

Animate When

Running
Redraws the network in real-time while an automated layout is ran.

Always Fine Tune

After Running

Applies a fine tune after running an automated layout. For detailed instructions,

see Running Automated Layouts.

Run Automated

Layout

Begins the layout processing. For detailed instructions, see Running Automated

Layouts.

Layout Manager

Settings

Contains options for resetting the Layout Manager settings. For detailed

instructions, see Running Automated Layouts.
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Objects Menu

Click the Objects menu to access the following commands:

Set Properties for

Selected Objects…

Opens a window for modifying the properties of multiple objects

simultaneously. For detailed instructions, see Bulk-Editing Objects.

Set Default

Properties for New

Objects…

Opens options for setting properties before objects are drawn on the canvas.

For detailed instructions, see Setting Defaults.

Set Duration Display

Format for Activities

Changes what time unit that durations are displayed in on the canvas. For

detailed instructions, see Setting Defaults.

Change Text Size Changes the text size for the entire schedule at once.

Restore Default

Positions of Data

Resets the position of any descriptions, IDs, dates, floats, drifts, buffers, gaps,

and total floats back to their default locations. For detailed instructions,

see Repositioning Fields (GEM).

Arrangement (Shades

and Images)

Rearranges the order of shades, shapes, or images on the canvas. For

detailed instructions, see Rearranging Shades.

Line up Activities

Places the selected activities on the same horizontal line on the canvas.

Whichever activity is selected first will become the target gridline. For detailed

instructions, see Grid Options.

Restore Faded Colors

for All Objects

Restores the color of all objects that have been spotlighted in a yellow box or

faded.

Highlight Driving Link

Chains

Highlights activities and links with the smallest gaps and fades the rest. For

detailed instructions, see Highlighting Link Chains.

Redundant Links
Controls the display of redundant links on the canvas. For detailed

instructions, see Treating Redundancies.

Display Float and

Drifts for Actualized

Objects

Enables floats and drifts to be displayed for actualized objects. For detailed

instructions, see Forensic Floats for Actualized Objects.

Use Outlines for

Critical Objects (non-

actualized only)

Outlines all objects in red while maintaining their designated color (when

critical). For detailed instructions, see Criticality.
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Tools Menu

Click the Tools menu to access the following commands:

Manage

Resources…

Opens a window for creating, modifying, deleting, assigning, and limiting

resources. For detailed instructions, see Defining Resources.

Assign

Resources…

Opens a window for assigning resources to multiple activities simultaneously. For

detailed instructions, see Assigning Resources.

Modify Resource

Display

Settings…

Opens a window for adjusting the histogram calculation and plot displays. For

detailed instructions, see Viewing the Resource Profile.

Open Codes

Manager…

Opens a window for creating, modifying, deleting, and assigning codes. For

detailed instructions, see The Codes Manager.

Manage

Calendars…

Opens a window for creating, modifying, deleting, and assigning calendars. For

detailed instructions, see Calendars.

Assign

Calendars…

Opens a window for assigning calendars to multiple objects simultaneously. For

detailed instructions, see Assigning Calendars.

Open Targets

Manager…

Opens a window for capturing and comparing targets. For detailed instructions,

see Managing Targets

Modify Visual

Target Filters …

Opens a window for adding, modifying, and deleting filters used in Visual Target

Mode. For detailed instructions, see Visual Target Mode.

Manage

Notification

Recipients….

Opens a window for creating, modifying, and deleting recipients and for assigning

them resources. For detailed instructions, see Noting Changes in Consumption.

Generate

Resource

Change emails…

Opens a window for notifying recipients of any changes in consumption of

assigned resources. For detailed instructions, see Noting Changes in

Consumption.
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Windows Menu

Click the Window menu to access the following commands:

Cascade Rearranges the current open files in a cascade view.

Tile Rearranges the current open files in a tiled view.

List of Open Plans Open NetPoint plans are listed here.
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Help Menu

Click the Help menu to access the following commands:

About NetPoint… Shows current release information and link to website.

Open User

Guide…
Opens a PDF of the NetPoint User Guide for help.

Contact

Support…
Opens the default email client and addresses a message to NetPoint support.

Collect

Information for

NetPoint

Support…

Generates an HTML file containing recent actions taken and conditions of the

software, which can then be emailed to NetPoint support. For detailed instructions,

see Generating Log Files.
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Toolbar

The toolbar contains icons that access commonly used commands and objects. It includes system icons,

object icons, and mode icons.
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System Icons

System icons perform basic application functions, and are familiar to most users.

New

Project
Creates a blank NetPoint canvas. Shortcut: Ctrl+N.

Open

Project

Accesses saved NetPoint projects. For detailed instructions, see Opening and

Unzipping Projects. Shortcut: Ctrl+O.

Save

Project
Stores the latest changes to the file. Shortcut: Ctrl+S.

Cut to

Clipboard
Removes selected item(s) from the canvas to the clipboard. Shortcut: Ctrl+X.

Copy to

Clipboard

Place selected item(s) onto the clipboard without removing them from the canvas.

Shortcut: Ctrl+C.

Paste

from

Clipboard

Inserts copied items from the clipboard. Shortcut: Ctrl+V. Click the down arrow to

apply only the display and formatting characteristics of copied items from the

clipboard to selected objects of the same type. For detailed instructions, see Paste

Format.

Print

Project

Opens options for selecting a printer and adjusting print properties. Shortcut:

Ctrl+P.

Undo
Reverses the last actions. Undo does not apply to zoom, stretch, page setup, or

print setup. Shortcut: Ctrl+Z.

Redo
Reverses the previous undo actions. Redo does not apply to zoom, stretch, page

setup, or print setup. Shortcut: Ctrl+Y.

Select

Tool
Grab, choose, select, or move activities and objects on the canvas.

Multi-

Object

Select

Tool

Grab, choose, or select multiple activities and objects without needing to use the

SHIFT key.
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Pan Tool Move around the canvas without needing to use the scroll bars.
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Object Icons

Objects are the building blocks of a plan.

Add Activity

Activities are the building blocks of a schedule and represent work being

done. They have a start date and a finish date, represented by end nodes,

and they span a certain period of time. For detailed instructions, see Adding/

Modifying Activities.

Add Delay/

Gain

Delay/gains are a type of activity but whose duration can reach zero. Delay/

gains are useful for showing positive or negative impacts to the schedule or

for atypical activities and do not support embedded nodes or resources. For

detailed instructions, see Adding/Modifying Activities.

Add Link

Links represent a relationship between objects, such as activities, milestones,

and benchmarks. From them, float attributes are calculated, including gap,

buffer, float and drift. Click the down arrow to choose a specific geometry. If

object dates overlap, embedded nodes must be used. For detailed

instructions, see Creating FS Links.

Link Multiple

Activities (FS)

An FS link represents a relationship where the successor cannot start before

the predecessor finishes. For detailed instructions, see Creating FS Links.

Add Start

Embed

A start embed is placed on a host activity to allow start-to-start (SS)

relationships. It may be placed to coincide with its host activity’s start or finish

nodes, or it may be offset (to have a lead or lag) between the two. In a SS

relationship, a successor cannot start before its predecessor starts. For

detailed instructions, see Using Embeds to Create SS and FF Links.

Add Finish

Embed

A finish embed is placed on a host activity to allow finish-to-finish (FF)

relationships. It may be placed to coincide with its host activity’s start or finish

nodes, or it may be offset (to have a lead or lag) between the two. In a FF

relationship, a successor cannot finish before its predecessor finishes. For

detailed instructions, see Using Embeds to Create SS and FF Links.

Add Start

Milestone

Milestones are zero duration events used to represent key dates or moments

in the schedule. Like activities, milestones will track along with the network

once they’ve been linked to any predecessors or successors. Start milestones

align to the beginning of the day or time unit (by default, 9:00 am), and should

be used for events which will precede an activity or represent an initiation. In
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addition, start milestones will snap to their earliest successor, always

maintaining a zero gap link. For detailed instructions, see Adding/Modifying

Milestones/Benchmarks.

Add Finish

Milestone

Milestones are zero duration events used to represent key dates or moments

in the schedule. Like activities, milestones will track along with the network

once they’ve been linked to any predecessors or successors. Finish

milestones align to the end of the day or time unit (by default, 5:00 pm), and

should be used for events which will succeed an activity or represent a

termination. In addition, finish milestones will snap to their earliest

predecessor, always maintaining a zero gap link. For detailed instructions,

see Adding/Modifying Milestones/Benchmarks.

Add Start

Benchmark

Benchmarks are zero duration events used to represent a key date or

moment in the schedule. Unlike activities and milestones, benchmarks will

remain fixed at whatever date they’re placed, regardless of whether or not

they’ve been linked to any predecessors or successors. Start benchmarks

align to the beginning of the day or time unit (by default, 9:00 am), and should

be used for events which will precede an activity or represent an initiation. For

detailed instructions, see Adding/Modifying Milestones/Benchmarks.

Add Finish

Benchmark

Benchmarks are zero duration events used to represent a key date or

moment in the schedule. Unlike activities and milestones, benchmarks will

remain fixed at whatever date they’re placed, regardless of whether or not

they’ve been linked to any predecessors or successors. Finish benchmarks

align to the end of the day or time unit (by default, 5:00 pm), and should be

used for events which will succeed an activity or represent an termination. For

detailed instructions, see Adding/Modifying Milestones/Benchmarks.

Add Hammock

Hammocks are a type of activity used to represent or summarize a group of

other activities, milestones, and/or benchmarks. Hammocks, however, have

no attributes of their own except for the descriptions/ID, and they don’t accept

resources, embedded nodes, or links. Click the down arrow for more options.

For detailed instructions, see Hammocks.

Add Data Date

A data date is an object on the canvas used to represent the date to which the

project has been statused. Data dates help provide a clear visual indicator of

the progress of the schedule. For detailed instructions, see Data Dates.

Add Info

Object

Info objects are external files or attachments. Placing an info object onto the

canvas is a way to embed a document within the schedule for viewing. For

detailed instructions, see Info Objects/Attachments.

Add Shape

Shades are blocks of color used to highlight or delineate sections of the

canvas. Click the down arrow to open a menu of other shapes. For detailed

instructions, see Shades.
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Add Notepad

Notepads are notes that do not show up on the canvas. Instead, they are

represented by an icon and viewed by double-clicking the icon. For detailed

instructions, see Text Boxes and Notepads.

Add Text Box
Text boxes are text objects that show up directly on the canvas. For detailed

instructions, see Text Boxes and Notepads.
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Mode Icons

Mode icons provide quick access from the canvas to important functions.

Open

Gestural

Interface

The gestural interface is a window for crashing, extending, or repositioning

activities and other objects without the need for the keyboard. For detailed

instructions, see Fine-Tuning/Gestural Controls.

Open

Zoom/

Stretch

Controls

Zooming and stretching will only temporarily enhance readability on screen. They

will have no effect on the printed page and they will reset when the project is

printed or saved and closed. For detailed instructions, see Adjusting Zoom and

Stretch. Shortcuts: CTRL + up/down (zoom) and SHIFT + up/down (stretch).

Open

Schedule

Properties

Schedule Properties is a window for customizing and formatting the entire

plan. For detailed instructions, see Schedule Properties.

Run

Automated

Layout

Automated layouts enhance the organization of the schedule by assisting with, or

completely taking control of, the placement and layout of objects in the

network. Underneath the hood, dozens of factors are taken into account, including

relationships between activities, link geometries, text and description lengths and

positions, and grid and canvas dimensions. Click the down arrow for more

options. For detailed instructions, see Running the Engine.

Enable/

Disable

Logic

Logic is a mode whereby object relationships are enforced. When turned on,

NetPoint will heal a negative-gap link as it forms to preserve the logic of the

original relationship. For detailed instructions, see Overriding Logic.

Change

Planning

Mode

In GPM Planning Mode, activities can be scheduled anywhere between their early

and late dates without the need for setting a constraint and reducing total float. In

Early Dates Mode, all connected activities are pulled back to their traditional CPM

early-start dates. In Late Dates Mode, all connected activities are pushed forward

to their traditional CPM late-start dates. Click the down arrow to jump to a specific

mode. For detailed instructions, see GPM, Early, and Late Dates Modes.

Enter/Exit

Visual

Target

Mode

In Visual Target Mode, activities that are ahead of or behind schedule can be

made either smaller, larger, or lighter or darker, resulting in a visual comparison.

This formatting will have NO effect on colors or sizes specified outside of Visual

Target Mode and the two will be stored separately. Visual Target Mode requires at

least one target to have been captured by the user and a base and alternate

designated. For detailed instructions, see Visual Target Mode.
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Hide/Show

Resource

Profiles

The resource profile displays total and cumulative resource consumption in a

chart at the bottom of the canvas. For detailed instructions, see Viewing the

Resource Profile.

Hide/Show

Resource

Limits

A limit is an object that restricts how much of a resource may be used at any

given time. It is drawn on the canvas, like an activity, with a certain height and

“duration”. The height at which the limit is drawn corresponds to the maximum

value activities can consume of that resource when overlapping with the limit. For

detailed instructions, see Limiting Resource Consumption.

Change

Display

Mode

The Global Edit Mode (GEM) allows you to reposition object fields (e.g.

descriptions, dates, durations, etc.) for multiple objects at a time. Upon

entering GEM, all dates become fixed, and no object property boxes are

accessible. However, object descriptions can still be modified by double-clicking

them on the canvas. Date Lock mode prevents any changes to horizontal

positions of objects on the canvas; however, activity dates can still be changed via

their property boxes, and all objects can still be moved to different grids. For

detailed instructions, see Repositioning Fields and Locking Relative Positions.
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Right-Click Menus

Right-clicking on the canvas or on an object will bring up a menu with additional options, some of which may

only be found in the menu itself.
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Canvas Menu

Right-click on the canvas to see the following menu:

Insert Grid at [x]
Inserts a grid above the one designated. For detailed instructions, see Grid

Options.

Remove Grid [x] Removes the designated grid. For detailed instructions, see Grid Options.

Properties
Opens a window for customizing and formatting the entire plan. For detailed

instructions, see Schedule Properties.

Cut Removes selected item(s) from the canvas to the clipboard. Shortcut: Ctrl+X.

Copy
Places selected item(s) onto the clipboard without removing them from the

canvas. Shortcut: Ctrl+C.

Paste Object(s) Inserts copied items from the clipboard. Shortcut: Ctrl+V.

Paste Format

Applies only the display and formatting characteristics of copied items from

the clipboard to selected objects of the same type. For detailed instructions,

see Paste Format.
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MAIN MENU Contains the options from the main menu bar.

Insert Image File(s)
Adds an image that will display on the canvas behind all objects except for

shades. For detailed instructions, see Image Files.

Set This Date as
Changes the date of the project start or project completion. For detailed

instructions, see Dates Tab.

Show Resource Limit

Overage Information

at Cursor

Display current and maximum resource consumption levels when the mouse

cursor moves over the canvas. For detailed instructions, see Limiting

Resource Consumption.

Display Schedule

Statistics…

Opens a window for viewing basic schedule metrics and statistics (like

number of activities, percentile floats, etc.). For detailed instructions,

see Schedule Statistics.

Manage Schedule

Progress…

Opens a window for actualizing objects with respect to a data date. For

detailed instructions, see Actualizing Objects.

Restore Default

Position of Data

Resets the position of any descriptions, IDs, dates, floats, drifts, buffers, gaps,

and total floats back to their default locations. For more info,

see Repositioning Fields (GEM).

Show Project End Hides/shows the yellow project completion box.

Show Project Start Hides/shows the yellow project start box.
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2) Setting up a Schedule

Before drawing activities and building a schedule, it can be helpful to configure the plan appropriately.

Whether you’re starting with a blank canvas or importing activities from another application, the page size,

time unit, and project dates should all be optimized beforehand. Once set, they can be modified at any time

during planning.
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PolyTime/Variable Time Units

Time units are the intervals on which activities and other objects are based. For example, an activity’s

duration may span one day or any whole unit increment thereof. The schedule time unit may be set to a unit

as small as minutes or as large as years. The time unit may not differ from activity to activity—once set, it

applies to all objects within the schedule. Durations, dates, and float values are all calculated according to the

schedule’s time unit.

Small time units—like minutes and hours—are useful for projects with short durations or for showing an

extremely high level of detail. Large time units—like months and years—are useful for projects with long

durations or for showing an extremely broad level of detail. If the schedule is blank (i.e. no activities or other

objects have been drawn), the time unit can be changed to a higher or smaller unit. The calendar dates and

project dates will automatically update to a reasonable range. However, once an object has been placed on

the canvas, the time unit may be changed only to a smaller unit. The calendar dates and project dates

will remain fixed. This restriction is enforced because converting to a larger time unit would involve either

rounding or truncation and would potentially result in changes to dates and durations (which would result in

altered gaps, floats, drifts, etc.).

NOTE: Small time units can only be used if the duration of the project is reasonably short or if the

size of the canvas is sufficiently large. Otherwise, the width of a time unit would be less than the

width of a pixel on screen, and input from the mouse would no longer translate accurately on the

canvas.

Steps

Changing the Default Time Unit for NetPoint

1. See step 12 of Installing/Upgrading NetPoint.

Changing a Schedule’s Time Unit

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Dates tab.

2. Click the down arrow next to Time Unit and choose accordingly.

3. When finished, click OK.

NOTE: When converting to time units smaller than days, some dates may appear to change;

however, they are only realigning – all float calculations and values will remain constant. This is

because with days, weeks, half-months, months, quarters, or years, dates are aligned to the end of

the prior unit, whereas with hours, quarter hours, and minutes, dates are aligned to the start of the

next unit. For example, a three-day activity that starts on May 1st will end on May 3rd at 11:59 pm. If

converted to hours, however, the same three-day activity will now end on May 4th at 12:00 am. This

is done to align with other applications as well as user expectations.

Notes

Resource Considerations

When converting plans from a higher time unit to a lower time unit, or when exporting a plan that is in any

time unit other than days, resource assignments may not be accurate. For example if 48 widgets are assigned

per day and the time unit is changed to hours, then 48 widgets would be assigned per hour instead of 2

widgets being assigned per hour. The following approaches may be taken to correct the outcome: 1) wait to
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resource load the schedule until the file is converted or exported; 2) reassign every resource to every activity

after converting or exporting to correct the values; or 3) delete the resource assignments prior to converting or

exporting and start with a clean resource-assignment slate, but with resources defined.

Calendar Considerations

When working with time units of hours or smaller, NetPoint does not support “daily calendars” or “shifts”. For

example, if a schedule in days is converted to hours, a working day is converted to 24 working hours.

Similarly, a 1-day gap is converted to a 24 hour gap. As a result, hours, quarter-hours, and minutes are only

recommended for schedules without non-work periods.
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Changing Date Formats

NetPoint will display dates according to whichever format has been set for the “short date” in Windows. As a

result, a schedule created on a computer in, for example, the U.S., will automatically be updated when

opened on a computer in the U.K. and vice versa, assuming each user’s computer has been configured to

their country.

Dates will be updated for objects on the canvas, in the calendar strips at the top, at the cursor, and in all lists

and date controls. In addition, the names of days and months will also be updated to the correct language at

the cursor and in the calendar strips. However, no matter what format is chosen, the year will never be

displayed for an object’s start and finish dates on the canvas. To change the format of dates that you’re

seeing, you must change the format of the “short date” chosen for Windows.

NOTE: Displaying days and months with letters can only be done for latin-based languages. If a

non-latin based language is chosen (e.g. Armenian (Armenia)), and the short date includes months

with letters (i.e. more than two ‘M’s’), question marks will appear for an object start and finish dates

on the canvas. Question marks will also appear for the names of months in the calendar strip and

days at the cursor.

Steps

1. Open the Windows Control Panel. Depending on your version of Windows, this can be done by clicking

the Start button and selecting Control Panel, or by typing “control panel” in the search bar in the upper

right-hand corner.

2. Click Region. The Region window will open.

3. First choose the desired language/country under the Format dropdown.

4. Next, choose the desired format next to Short date.

5. When finished, click OK.

6. Click the Close icon to close the control panel.
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Page Size/Print Setup

The page size should always be set specifically after a new document is created but before the network is

drawn. This is because the page size will determine not just how the schedule prints, but also how it displays

on-screen. Choosing a new page size will increase or decrease the horizontal width of the canvas by

stretching it, and it will increase or decrease the vertical height of the canvas by adding or removing

gridlines. It is recommended to choose the page size anticipated for printing, and if the schedule appears too

small or too large, to use the zoom and stretch controls to enhance readability on-screen.

For some schedules, increasing the page size may help enhance readability; however, others may be too

complex to view on a single page. In these cases, the plan may be tiled across multiple pages, horizontally

and/or vertically. When printed, a letter and number will print on the lower left of each tile to convey tile

sequence. The letter indicates the horizontal sequence; the number indicates the vertical sequence. These

can be previewed, and the plan can be adjusted to automatically fit the screen using the print preview.

When opening a schedule that was created on another computer or network, the same page size may not be

available, since page sizes are specific to printers. In this case, a warning will appear and the user will be

prompted the change the page size automatically. If the printer is available but the driver doesn’t match (likely

with “software only” print drivers, e.g. Microsoft XPS Document Writer or Adobe PDF), a similar warning will

open. In either case, the schedule will only open once a new printer and page size have been chosen. To

assist the user, the warning lists both the printer and page size dimensions in which the schedule was last

saved.

NOTE: A large page size can only be used if the time unit is reasonably high or if the duration of the

project is sufficiently short. Otherwise, the width of a time unit would be less than the width of a

pixel on screen, and input from the mouse would no longer translate accurately on the canvas.

Similarly, horizontal tiles can only be removed if the same requirements are met.

Steps

Choosing a Printer/Page Size

1. Click File > Print Setup from the menu bar.

2. Next to Name, first choose the desired printer.

3. Next, in the Paper section, choose the desired Size.

4. If desired, change the Orientation.

5. When finished, click OK.

Adding/Removing Page Tiles

1. Click File > Page Setup (Tiling: a x b) from the menu bar.

2. Increase or decrease the numbers next to Across and Down as desired.

3. When finished, click OK.

NOTE: If the number of vertical tiles is reduced, any areas of the network falling below the new

boundary will be cropped. Content can be restored, however, by returning to the original number of

vertical tiles.

Viewing Page Breaks

1. Click File > Page Setup (Tiling: a x b) from the menu bar.
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2. Under Page Breaks, check the box next to Display on Canvas.

3. When finished, click OK.

Print Preview

1. Click File > Print Preview from the menu bar.

2. To revert, click the Reset button next to Zoom Factor.

3. To continue in the preview, click the red X in the upper-right corner of the Schedule Zoom & Stretch

window.

NOTE: Print preview can be cancelled at any time by clicking the Zoom/Stretch icon from the

toolbar and following step 2.

Notes

Resources

If resource histogram colors are not printing faithfully, first try printing to another printer. Depending on the

printer, this may or may not resolve the issue. In the case that it doesn’t, it is recommended to remove the

histogram patterns entirely until a further solution is implemented.

Text

When text is too close to the margins, a warning will pop when printing and the text will be highlighted. The

print operation will continue, but we recommend adjusting any text near page or tile borders to provide a

buffer for the future.

Text strings may appear shorter on screen than when printed, depending on the monitor and resolution of

your screen.

Images

If your schedule contains images that appear mirrored when printed, try printing to PDF first or printing to a

different printer.
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Schedule Properties

The schedule properties include settings and formatting options for the entire plan, including dates, colors,

and timeline configuration. Instructions for a subset of functionality are provided below.

NOTE: At this time, pasting objects from one schedule to another such that one or more of the

object’s dates falls outside the calendar range of destination schedule is unsupported. The calendar

range of the destination must be adjusted. Otherwise, an error message will appear and the paste

will be cancelled.

Steps

Changing the Criticality Threshold

1. Click Schedule > Modify Schedule Properties in the menu bar.

2. Increase or decrease the number next to Criticality Threshold.

3. If desired, click the dropdown next to Criticality Factor and choose accordingly.

4. When finished, click OK to save and close the window.

NOTE: By default, critical activities are automatically turned red, but their original color may be

preserved by choosing Objects > Use Outlines for Critical Objects (non-actualized only).

Changing the Grid Spacing

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Formatting tab.

2. Next to Grid Spacing, click the up or down arrows to increase or decrease the value accordingly.

3. When finished, click OK to save and close the window.

NOTE: The maximum allowed value is determined by the current size of the page and the positions

of existing objects within the canvas. The grid spacing can only be increased if the bottom grid is

unoccupied. If objects already reside on the bottom grid, they must be moved higher in order to

increase grid spacing.

Adjusting the Calendar Start/End Dates

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Dates tab.

2. Next to Start Date, click the down arrow to open the visual calendar picker, or type in a desired date

manually.

3. Repeat step 2 for End Date.

4. Double check that the Project Dates are still within the new Calendar Dates. If no objects have yet been

added to the canvas, ths may be done automatically by clicking Autofill next to Use Calendar Dates.

5. When finished, click OK to save and close the window.

NOTE: The dates may also be modified graphically by moving objects on the canvas until the

calendar warning is triggered. However, NetPoint will always enforce a minimum of at least 2 time

units between the start of the network and the start of the calendar and a minimum of at least 4 time

units between the end of the network and the end of the calendar. If there is a zero-gap link between

the project start and any activities or milestones, pulling the project start earlier will also trigger the

automatic calendar adjustment. The calendar will not adjust automatically, however, if moving it
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earlier would place a zero-gap successor on a non-working day according to its calendar. These

effects will become particularly noticeable with larger time units such a months and years.

Using an Ordinal Calendar

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Dates tab.

2. Check the box next to Ordinal Start.

3. Click the down arrow to open the visual calendar picker, or type in a desired date manually.

4. When finished, click OK to save and close the window.

Notes

Properties Tab

The Properties tab is where the general settings are changed.

Field Definition

Project

Title

A text object for describing the project. By default, it is positioned at the top center of the

canvas (when displayed) but can be subsequently repositioned.

Project

Start
A field for customizing the text of the project start box on the canvas.

Project

Completion
A field for customizing the text of the project completion box on the canvas.

Project

Completion

Type

Determines the behavior of the project completion box. If Fixed, the project completion

will remain at whichever date it is entered or placed graphically. If Calculated, it will track

automatically with the last activity in the network; it will not track along with milestones or

benchmarks.
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Field Definition

Criticality

Threshold

Determines at what point (e.g. days) an activity will be displayed as critical. For more info,

see Criticality.

Criticality

Factor

Determines how criticality will be calculated. Float is defined as the amount of time an

activity can be delayed before delaying the completion of the project. Drift is defined as

the amount of time an activity can gain before advancing the start of the project. Total

Float is defined as float + drift and is equal to the CPM value of Total Float. For more info,

see Criticality.

Dates Tab

The Dates tab contains all date related fields.

Field Definition

Time Unit

Intervals on which activities and other objects are based. If PolyTime is enabled, the user

will have the option of scheduling in time units other than days. Changing the time unit

may have a significant impact on the schedule. See PolyTime/Variable Time Units for

more details.

Start Date

(Calendar)

The date that corresponds with the left edge of the canvas. By default, this will be set to 6

months prior to the current date and cannot be earlier than 1/1/1971 (if activities are near

the project start, the recommended limit is 1/1/1974). Together with the End Date, this

determines the maximum possible range in which the project itself may take place.

Changing the calendar dates can affect the resolution of the schedule.
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Field Definition

End Date

(Calendar)

The date that corresponds with the right edge of the canvas. By default, this will be set to

12 months after the current date and cannot be any later than 12/31/2100 (if activities are

near the project completion, the recommended limit is 12/31/2096). Together with the

Start Date, this determines the maximum possible range in which the project itself may

take place. Changing the calendar dates can affect the resolution of the schedule.

Ordinal

Start

An option for displaying the timeline, or calendar strips, by sequence instead of by time.

The date chosen becomes 0; to the right, increments of 1, and to the left, negative

decrements of 1.

Use

Calendar

Dates

A shortcut for aligning the project dates 1 time unit within the calendar dates. This button

will be disabled once any objects have been added to the canvas to prevent unintentional

modification to the network.

Start Date

(Project)

The actual start of the project. Displays as a yellow box on the canvas. To view the entire

box, set the calendar’s start well outside the project’s start.

Completion

Date

(Project)

The actual finish of the project. Displays as a yellow box on the canvas. To view the entire

box, set the calendar’s end well outside the project’s completion.

Displays Tab

The Displays tab contains checkboxes for hiding or showing different fields or elements on the canvas.
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Field Definition

Project

Title

A text object for describing the project. By default, it is positioned at the top center of the

canvas (when displayed) but can be subsequently repositioned.

Holiday

Line

A line at the top of the canvas for displaying non-working days. Holidays, weekends, and

non-working periods will be displayed as red notches or rectangles; weather days will

show up as blue notches or rectangles. The name of the holiday is also displayed, in

blue, by hovering over it with the mouse cursor. The holiday line is based on whatever

calendar is set as the default calendar for new activities. The holiday line cannot be

displayed when working with time units larger than days and will be disabled

accordingly. For more info, see Displaying Holidays.

Grid

Numbers
Faded numbers for identifying gridlines. For more info, see Grid Options.

Project

Completion

The actual finish of the project. Displays as a yellow box on the canvas. Can also be

shown/hidden by right-clicking on the canvas, or on the yellow box itself.

Project

Start

The actual beginning of the project. Displays as a yellow box on the canvas. Can also be

shown/hidden by right-clicking on the canvas, or on the yellow box itself.

Current

Data Date

An object on the canvas used to represent the date to which the project has been

statused. For more info, see Data Date.

Old Data

Dates

An object on the canvas used to represent the date to which the project has been

statused. For more info, see Data Date.

Calendar

Strips
Horizontal rows at the top of the canvas for displaying the timeline or time units.

Calendar

Sightlines
Vertical lines corresponding to the calendar strips for lining up dates on the canvas.

Formatting Tab

The Formatting tab contains controls for changing the look of the canvas.
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Field Definition

Canvas

Color
The background color of the plan.

Calendar

Strip

Color

The color of the timelines at the top of the canvas.

Strip

Text

Color

The color of the timeline text at the top of the canvas.

Strip

Text Size
The size of the timeline text at the top of the canvas.

Grid

Spacing

Determines how much vertical space there is between adjacent horizontal grid lines. For

more info, see Grid Options.

Layout

Spacing

The number of inactive (empty) grids between active grids. An active grid is one that

contains an object. An inactive grid is a grid that does NOT contain an object.

Choosing Single will result in only active grids with no inactive grids; choosing Double will

result in one inactive grid placed between every active grid; and choosing Triple will result in

two inactive grids placed between every active grid. After choosing, click Apply for the

changes to take effect.
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Grid Options

In NetPoint, a horizontal grid system guides the placement of all activities, delays, milestones, benchmarks,

and hammocks. Although they can be temporarily positioned between grids while selected, they will always

snap to the nearest grid as soon as they’re deselected. Info objects, shades and shapes, notepads, and text

boxes, however, are free to be positioned anywhere on the canvas.

Grids provide an important reference point for objects on the canvas. In addition, they can be strategically

used for improving the look and layout of the network. For example, the amount of space between grids can

be adjusted, and grids can be added or removed.

Grid spacing determines how much vertical space there is between adjacent horizontal grid lines, but it will

not actually stretch the canvas (increase or decrease its height). The maximum allowed value is determined

by the current size of the page and the positions of existing objects within the canvas. The grid spacing can

only be increased if the bottom grid is unoccupied. If objects already reside on the bottom grid, they must be

moved higher in order to increase grid spacing.

NOTE: The default grid spacing of 0.500 inches allows activities with single line descriptions to be

displayed with both the duration and the float block, without the chance of any text overlapping

(using a small global text size). A grid spacing of 0.350 inches allows activities with single line

descriptions to be displayed with either the duration or the float block (but not both), without the

chance of any text overlapping (using a small global text size). Values smaller than 0.350 should

only be used to customize advanced schedule layouts, because they may cause numerous text

collisions unless activities are placed more than 1 grid apart.

Steps

Changing the Grid Spacing

1. With the Select Tool chosen in the toolbar, click the small grey box at either the far right or left edge

of the canvas of any grid.

2. Drag the cursor up (to decrease spacing) or down (to increase spacing) until it changes to a double-sided

arrow and a decimal value appears.

3. When satisfied, let go of the mouse.

or,

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Formatting tab.

2. Next to Grid Spacing, click the up or down arrows to increase or decrease the value accordingly.

3. When finished, click OK to save and close the window.

Adding/Removing Grids

1. With the Select Tool chosen in the toolbar, right-click immediately above the desired grid.

2. Choose Insert Grid at # or Remove Grid # accordingly.

NOTE: Grids that contain objects cannot be removed.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 61 of 344



Lining Up Activities

1. With the Select Tool chosen in the toolbar, click the activity that you want subsequently selected

activities to align to.

2. Press and hold the SHIFT key on the keyboard and select additional activities. Alternatively, you can click

on a blank portion of the canvas and drag a rectangular marquee box around all the activities, so long as

they are next to each other.

3. Click Objects > Line Up Activities in the menu bar.

NOTE: If no activity is selected first (e.g.. a group is only selected by drawing a box around them),

then the activities will align to the grid of whichever activity was added to the canvas first.

Hiding/Showing Grid Numbers

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Displays tab.

2. Next to Grid Numbers, check or uncheck the box to show or hide grid numbers respectively.

3. When finished, click OK to save and close the window.

Changing Layout Spacing

1. Click Schedule > Modify Schedule Properties from the menu bar and choose the Formatting tab.

2. Next to Intermediate Grids, choose Single for no intermediate grids between active grids, Double for

one intermediate grid between active grids, and Triple for two intermediate grids between active grids.

3. Click Apply.

4. When finished, click OK to save and close the window.
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Calendars

Calendars are a way for specifying which periods an activity, milestone, or benchmark may or may not be

taking place due to national holidays, weekends, scheduled days off, and/or weather (blocked weather days).

If desired, a specific calendar may be chosen as the default calendar, but it will only apply within the active

schedule. The only way to reset the default calendar permanently is to reinstall NetPoint, at which point a

different country may be selected. For more info on changing the default calendar or reinstalling, see Default

Properties and Installing/Upgrading NetPoint respectively.

NOTE: If a milestone is assigned a calendar that’s different from that of its predecessors or

successors, and the network is pulled backwards, gaps may open up as the chain crosses a

weekend or non-working days. As such, it is recommended to always keep milestones on the same

calendar as their predecessors/successors.

NOTE: When moving 1 or more objects with different calendars, the behavior will be different

depending on whether using the mouse or using the keyboard/gestural controls. For more info, see

Fine Tuning/Gestural Controls.

This chapter includes details for the following:

1. Adding/modifying calendars

2. Configuring holidays

3. Assigning calendars

4. Displaying holidays

5. Shared calendars (global)
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Adding/Modifying Calendars

NetPoint comes preloaded with two calendars for the user to start with. The first one is set upon installation of

NetPoint. The second one called the Calendar Day calendar has every day as a working day. Additional

calendars may be created, modified, and deleted through the Project Calendars window.

NOTE: If an object is copied from one schedule and pasted into another where its calendar is not

defined, a warning will appear. By clicking OK, the object will be pasted, but its calendar will be

reassigned to whichever calendar has been set as default for the schedule. To check or change the

default calendar, see Default Properties for more details.

Steps

Defining

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Click the New button. The Calendar Properties window will open.

3. Enter a name.

4. To add a list of pre-defined holidays and/or non-working days, choose a country or pre-existing calendar

from the dropdown next to Templates and click Add to List.

5. Check or uncheck any additional days and non-working.

6. Enter any weather days.

7. Click Add. The new calendar will be added to the Project Calendars window and the Calendar

Properties window will reset.

8. To add additional calendars, repeat steps 3-7.

9. When finished, click the Exit icon.

10. Click OK to save the changes and close.

Modifying

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Select a calendar in the list and click Modify. The Calendar Properties window will open.

3. Make desired changes.

4. Click Update. The Calendar Properties window will reset.

5. To modify additional calendars, repeat steps 2-4.

6. When finished, click the Exit icon.

7. Click OK to save the changes and close.

NOTE: The Calendar Days calendar, or any shared/global calendars, cannot be modified (for the

Calendar Days calendar, the button will be disabled). If a calendar is modified which is assigned to

an activity, then the start date and duration are held constant while the finish date is recalculated.

However, if the activity has any constraints, then user input will be needed to resolve any

violations. A calendar may never be modified if any of the objects it has been assigned to have been

actualized. First de-actualize any objects before modifying the calendar. For more info, see

Actualizing Objects.

Deleting

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Select a calendar in the list and click Delete.
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3. In the confirmation, click Yes.

4. To delete another calendar, repeat steps 2-3.

5. When finished, click OK to save and close.

NOTE: A calendar cannot be deleted if it has been assigned to any objects, or if it has been set as

the default calendar for the schedule.

Notes

Calendar Properties Window

Field Definition

Name A text field for describing the calendar.

Share to

all

Projects

A shared calendar will be copied to all new and existing schedules on the machine. For

more info, see Shared Calendars (Global).

Templates

A list of 23 countries (including 2 for the United States), complete with their national

holidays and workweek, are provided as templates for creating a new calendar. Any user-

defined calendars as well as the default calendars are also provided. This makes it
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Field Definition

possible to start with an existing calendar and make changes rather than redefine all the

holidays from scratch.

Holidays Specific non-working periods.

Non-

working

Days

Non-working days that repeat every week.

Weather

Days

A way to randomly assign non-working days due to external factors on a monthly basis. To

prevent all the weather days from falling on pre-existing non-working days (such as

holidays or weekends), the number entered is first multiplied by a conversion factor and

then randomly distributed over working days only. For example, if 7 weather days are

entered for February (assuming a traditional US workweek and standard holidays),

5 working days will be assigned as weather days.
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Configuring Holidays

In NetPoint, the term holiday is used to represent national holidays as well as any user-defined non-working

days and non-working periods. The latter can be useful for projects that require a non-working day more

specific than weekends or weather days. When creating a holiday, you can choose between an annual, fixed-

date, floating-date, or easter-relative. Instructions for adding, modifying, and deleting are provided below.

NOTE: If a holiday falls on a weekend (e.g. Christmas is on a Saturday), the following Monday

will NOT be marked a holiday.

Steps

Adding

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Click New, or select a calendar and click Modify. The Calendar Properties window will open.

3. Click the New button under the list of Holidays. The Holiday Properties window will open.

4. Enter a name.

5. Choose the desired type.

6. When finished, click the Add button. The holiday will be added to the Calendar Properties window and

the Holiday Properties window will reset.

7. To add another holiday, repeat steps 4-6.

8. When finished, click the Exit icon to close the Holiday Properties window.

9. Click the Add or Update button, respectively.

10. Click the Exit icon to close the Calendar Properties window.

11. Click OK to save and close the Project Calendars window.

Modifying

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Select a calendar and click Modify. The Calendar Properties window will open.

3. Select a holiday and click Modify. The Holiday Properties window will open.

4. Make the desired changed.

5. When finished, click the Update button. The Holiday Properties window will reset.

6. To modify another holiday, repeat steps 3-5.

7. When finished, click the Exit icon to close the Holiday Properties window.

8. Click the Update button and then click the Exit icon to close the Calendar Properties window.

9. Click OK to save and close the Project Calendars window.

Deleting

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Select a calendar and click Modify. The Calendar Properties window will open.

3. Select the holiday and click Delete.

4. Repeat step 3 as desired.

5. When finished, click the Update button and then click the Exit icon to close the Calendar

Properties window.

6. Click OK to save and close the Project Calendars window.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 67 of 344



Notes

Holiday Properties

Type

Field Definition

Fixed-

Date

A fixed-date holiday occurs on a fixed date and/or time and can be either repeating or non-

repeating. A fixed-date holiday is also known as a non-working period, as the duration may

be less than a day. If a fixed-date holiday is repeating, it must repeat every year. Other time

options will be disabled. To make a holiday non-repeating, leave the Repeat Every field

blank or set it to zero. Fixed-date holidays, if repeating, will not take place over the entire

duration of the schedule’s calendar dates, but from the start date and on. NOTE: If the

duration is set to less than a day but the time unit for the schedule is larger, the entire

time unit will be considered a holiday. For example, if a holiday is created on

December 20th with a duration of 1 hour but the time unit for the schedule is set to

days, all of December 20th will be considered a holiday, even though the holiday line

and shading will depict 1 hour.

Annual

An annual holiday is a type a fixed-date holiday but which must repeat every year (though

not necessarily on the same day of the week) and must last for at least a day or more. Many

national holidays, like New Years Eve and Independence Day in the USA are annual

holidays. Annual holidays will take place over the entire duration of the schedule’s calendar

dates. Annual holidays have the additional feature where, if they fall on a day that is already

a non-working day, they can be moved or not moved, according to the option selected.

Floating-

Date

A floating-date holiday occurs on a fixed day of the week, though not necessarily on the

same date, and must repeat every year. Many national holidays, like Thanksgiving and

Labor Day in the USA are floating-date holidays. Floating-date holidays will take place over

the entire duration of the schedule’s calendar dates.

Easter-

Relative

An Easter-relative holiday occurs a certain number of days before or after Easter. It must

repeat every year and it must last for at least one day or more. Good Friday, for example,

occurs on the Friday before Easter every year. Easter-relative holidays will take place over

the entire range of the schedule’s calendar dates.
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Assigning Calendars

By default, all new activities, milestones, and benchmarks inherit a calendar derived from whichever country

is chosen upon installation. An object’s calendar may be changed, however, at any time. There are three

ways to do so. The first method described is best for assigning a calendar to a single object. The second

method is best for assigning the same calendar to more than one object. The last method is best for

assigning more than one calendar to more than one object.

NOTE: If an activity’s calendar is changed right after it’s drawn (before pressing OK), then the start

and finish dates are held constant while the duration is recalculated. If an activity’s calendar is

changed at any other point, then the start date and duration are held constant while the finish date

is recalculated. If an activity has been limited by constraints, however, then user input will be

needed to resolve any violations.

Steps

A Single Object

1. With the Select Tool chosen in the toolbar, double-click the object or right-click and choose

Properties.

2. For activities, click the Dates tab. For milestones or benchmarks, located the Calendar field on the main

tab.

3. Click the dropdown to the right of Calendar and choose accordingly.

4. When finished, click OK.

Selected Objects

1. With the Multi-Object Select Tool icon chosen in the toolbar, select the desired activities on-by-one

on the canvas. Alternatively, you can click on a blank portion of the canvas and drag a rectangular

marquee box around all the desired activities

2. Click Objects > Set Properties for Selected Objects from the menu bar.

3. Click the dropdown next to Apply Calendar and choose accordingly.

4. Repeat in the Milestone and/or Benchmark tabs as needed.

5. When finished, click OK.

NOTE: For more info, see the Bulk-Editing chapter.

Multiple Objects

1. Click Tools > Assign Calendars from the menu bar. The Global Calendar Assignment window will

open.

2. Select the desired object in the list.

3. Once selected, click the dropdown under the Calendar Assigned column.

4. Choose a new calendar.

5. Repeat steps 2-4 as needed.

6. When finished, click OK.

NOTE: To filter this list, first selected the desired objects on the canvas.
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Displaying Holidays

Holidays, weekends, and any user-defined non-workday days can be displayed tabularly in a list or

graphically on the canvas using either vertical shading or a horizontal line. On the line, holidays, weekends,

and non-working periods will be displayed as red notches or rectangles; weather days will show up as blue

notches or rectangles. On the canvas, holidays and weekend will be displayed in light gray; weather days will

be displayed in dark gray. Either way, all holidays will always be based on the default calendar for the

schedule. For more info, see Default Properties.

Steps

In a List

1. Click Tools > Manage Calendars from the menu bar.

2. Select the desired calendar and click the Details button.

3. When finished, click the Exit icon.

4. Click OK to save and close the Project Calendars window.

NOTE: The list of non-working days will include non-working days for the entire year, even if they

fall outside of the calendar start and end.

On the Canvas

1. Click Schedule > Modify Schedule Properties from the menu bar. The Schedule Properties window

will open.

2. Click the Displays tab.

3. Check or uncheck the box next to Holiday Line.

4. Click OK.

Using Shading

1. Click Schedule > Shade Non-working Days from the menu bar.
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Notes
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Shared Calendars (Global)

NetPoint allows a calendar to be made available to all schedules, new and existing, on a given workstation.

Once shared, a global calendar cannot be edited. If deleted, and the calendar had been assigned to any

objects in a given project, a copy of the calendar will be retained in that schedule, and the entire calendar

name will become italicized. When a deleted global calendar has no object assignments, it will be

automatically removed.

If a schedule with a global calendar is opened on another workstation, the calendar will be inherited, but it will

not be global. To edit an inherited global calendar, or to make it global on the new workstation, a new calendar

must be created using the inherited calendar as a template.

If a schedule with a global calendar is opened on another workstation, but the same global calendar already

exists, NetPoint will automatically recognize the existing calendar and re-assign it accordingly.

If a schedule with a global calendar is opened on another workstation and the same global calendar already

exists but with different properties, the inherited one will be used and the existing one will be made

unavailable for that schedule. Instructions for sharing are provided below.

Steps

Sharing an Existing Calendar

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Select the calendar from the list and click Modify. The Calendar Properties window will open.

3. Check the box next to Share to all Projects.

4. Click the Update button. A confirmation will open.

5. Choose Share, Disable Editing.

6. To share another calendar, repeat steps 2-5.

7. When finished, click the Exit icon to close the Calendar Properties window.

8. Click OK to save and close the Project Calendars window.

Retaining an Inherited Global Calendar

1. Click Tools > Manage Calendars from the menu bar. The Project Calendars window will open.

2. Click the New button. The Calendar Properties window will open.

3. Enter a name.

4. Click the dropdown next to Templates.

5. Under User Defined, choose the desired global calendar.

6. Click the Add to List button.

7. Make any desired changes.

8. To save the calendar, click the Add button.

a. Click the Exit icon to close the Calendar Properties window.

b. Click OK to save and close the Project Calendars window.

9. To make the new calendar global, see step 5 above under Sharing an Existing Calendar.

Notes

For more info on calendars and their fields, see the notes of Adding/Modifying Calendars.
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Configuring/Using a Template

NetPoint does not offer any pre-defined templates; however, any schedule can be configrued and then saved

for future use.

Steps

Configuring a Template

1. Choose landscape or portrait, page size, and print tiling, if any. For more info, see Page Size/Print Setup.

2. Configure settings like the background color of the canvas, what calendar strips and sightlines to display,

and grid spacing. For more info, see Schedule Properties.

3. Define any holidays or non-working days unique to your projects or company. For more info, see

Calendars.

4. Add cost, labor, material, or equipment requirements which are used across multiple projects. For more

info, see Resources.

5. Customize how all new activities will look when they’re drawn on the canvas, including what data will be

displayed (e.g. dates, float attributes, ID’s, etc.) and how they’re formatted (e.g. colors). For more info,

see Activity Defaults.

6. When ready, click File > Save Project As from the menu bar.

7. On the left, browse for the location in which you want the new project to be saved, and select it in the list.

8. After selecting the folder, a list of existing NetPoint projects will show up on the right. Enter a description

next to Save Project As. This will be the name of the new template.

9. After entering a description, click Save.

Creating from Template

1. Click File > Open Project from the menu bar.

2. Browse for the location of the template on the left, select the template in the list on the right, and click

the Open button.

3. Click File > Save Project As from the menu bar so as to not modify the template.

4. On the left, browse for the location in which you want the new project to be saved, and select it in the list.

5. After selecting the folder, a list of existing NetPoint projects will show up on the right. Enter a description

next to Save Project As. This will be the name of the new project.

6. After entering a description, click Save.
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Password Permissions

NetPoint provides two options for securing a schedule with a password. The first option (Password required

for READ) will prevent the schedule from even being opened unless the password is entered. The second

option (Password required for Modify) will allow the schedule to be opened without a password, but it will

be in read-only mode. To gain full access, the password must be entered. If you have received a schedule but

do not know the password, contact the creator of the schedule. If the password is lost or forgotten, please

contact support@pmatechnologies.com.

Steps

Setting a Password

1. Click Schedule > Set Password from the menu bar.

2. Choose the type of security from the dropdown.

3. Enter the password text.

4. Re-enter the password text.

5. Click OK.

6. Click File > Save.

Opening a Password Secured Schedule

1. Click File > Open Project from the menu bar.

2. Browse for the location of the project on the left, select the project in the list on the right, and click

the Open button.

3. If the schedule was secured with a password for reading, you must enter the password in the text field.

a. When finished, click OK.

4. If the schedule was secured with a password for modyifing, click Use Password.

a. Enter the password and click OK.

b. If you do not know the password, click Read-Only to open the schedule without editing permissions.

NOTE: In Read-Only mode, saving, and cut, copy, and paste will all be disabled.

Removing a Password

1. Open the schedule using steps 1-4 above.

2. Click Schedule > Set Password from the menu bar.

3. Click the dropdown and choose No Password Required.

4. Click OK.

5. Click File > Save.
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GPM, Early, and Late Dates-Modes

NetPoint is based on the Graphical Path Method (GPM®), an innovative scheduling algorithm that governs

the behavior of activities and events in a network-based schedule. However, activities, and their resource

histograms and curves, can also be viewed on their CPM early or late dates. This gives NetPoint the ability to

schedule forward from the project start or backward from the project completion.

In GPM Planning Mode, activities can be scheduled anywhere between their early and late dates (on what

are called “planned dates”) without needing to constrain them (in CPM, constrained dates reduce total float).

In CPM Early Dates Mode, all connected activities are pulled back to their traditional CPM early-start dates

(activities without any predecessors will remain on their GPM planned-dates). This mode is helpful for drawing

and linking activities rapidly or push-planning from the project start. Effectively, activities can be drawn on the

canvas as late as desired, without needing to think about exact dates or fine-tuning their positions.

In CPM Late Dates Mode, all connected activities are pushed forward to their traditional CPM late-start dates

(activities without any predecessors will remain on their GPM planned-dates). This mode is helpful for pull-

planning from the project completion.

In addition to switching between modes for the entire schedule, activities can be snapped to their early or late

dates on an individual basis. Instructions are provided below.

NOTE: In CPM early and late dates modes, all link gaps and drifts equal zero, and all floats equal

total floats.

Steps

Changing Modes

1. Click the down arrow next to the GPM/Early Dates/Late Dates icon in the toolbar.

2. Select the desired mode from the list.

Snapping to Predecessors/Successors

1. With the Select Tool chosen in the toolbar, right-click on a desired activity.

2. Choose Snap to Predecessors or Snap to Successors accordingly.

Notes

Working in Early or Late Dates Modes

It is recommended that modifications to the network always be done in GPM Planning mode. If you modify the

positions of activities in early or late-dates modes, negative gaps will temporarily form until the canvas has

been clicked and activities return to their calculated positions.

Additionally, when switching between modes, you may observe unexpected results. For example, when

switching between early-dates and GPM modes, the later of the two dates will be kept for all activities. When

switching between late-dates and GPM modes, the earlier of the two dates will be kept for all activities. In

both cases, if any activity has zero total float, it will be maintained. Original dates and gaps will be restored

only for those relationships that have gone unmodified. If the project start is modified, it will not revert.
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Updating in Early or Late Dates Modes

During schedule updates in CPM early or late dates mode, all activities to the left of the data date (or crossing

through it) must have start and finish constraints applied before a data date is placed. Otherwise,

all connected activities and milestones will jump to the data date and be unable to be actualized. For

instructions, see Constraining Activities and Bulk-Editing Objects.
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3) Building a Schedule

In NetPoint, a schedule is created by drawing or placing objects—such as activities, milestones, and

benchmarks—on a time-scaled calendar called the canvas. Each object represents a real-world task or event.

These objects can be related to one another by placing logic ties between them, which are represented by

links.

Objects are scheduled wherever they are placed on the canvas, which can be anywhere within their total float

range (at the time). When an activity is first added to the plan, it may be positioned on the early dates that a

CPM forward pass would yield. However, once linked to predecessors and successors, stakeholders can re-

position the activity to achieve a more desirable scenario. This is because GPM permits activities to be

scheduled on an “as-planned” basis. This flexibility allows for a more realistic schedule.

In general, it is recommended that every GPM schedule have an uncorrupted critical path, defined as a

continuous sequence of logically-connected activities terminating at, and carrying the least total float or

negative total float relative to, a contractual benchmark or constrained milestone symbolizing a contract time.
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Interacting with the Canvas

The NetPoint timescale is both interactive and instantaneous. When the mouse is moved over the canvas, the

date and day of the week display above the cursor. As the cursor moves, the date changes to reflect the exact

calendar date that the cursor is set at. If the date is a non-working period or holiday (according to the default

calendar), the date text appears red.

When placing objects, the cursor will change to a cross-hairs as long as it is over the canvas. After placing an

object, it will switch back to the select tool, except for with activities, delays, or shades.

When an object is selected, its dates and durations will enlarge, other fields will be hidden, and black boxes

will appear at the ends and at the center. Instructions for selecting and modifying objects can be found below.

NOTE: Moving objects rapidly or suddenly with the mouse may cause negative gaps in rare

instances. If this happens, click Undo and use the Gestural Interface or arrows on the keyboard

instead. For more info, see Fine-Tuning/Gestural Controls.

Steps

Selecting Multiple Objects

1. Click the Select Tool icon from the toolbar.

2. Click the first object on the canvas.

3. Press the SHIFT key on the keyboard.

4. Without letting go, click the next object on the canvas.

or

1. Click the Multi-Object Select Tool icon from the toolbar.

2. Click the first object on the canvas.

3. Click the second object on the canvas.

or

1. With either the Select Tool or Multi-Object Select Tool chosen in the toolbar, click on an empty

portion of the canvas.

2. Without letting go, drag the cursor until a box is formed around the desired objects.

3. When finished, let go.

Selecting Overlapping Objects

1. With the Select Tool chosen in the toolbar, right-click on the object you want to select.

2. Choose the desired object(s) until a checkmark appears to the left.

a. To select, choose Select checked items.

b. To open the right-click menu for a single item, choose Context menu for selected item.

c. To cancel, left-click outside of the menu.
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Modifying Positions/Durations

1. With the Select Tool chosen in the toolbar, click the desired object on the canvas, without releasing

the mouse.

2. To change the grid position, move the mouse up or down.

a. When finished, release the mouse.

3. To change the start or finish, move the mouse left or right.

a. When finished, release the mouse.

4. To change the duration of an activity or width of a shade, release the mouse.

a. Move the cursor over the start or finish node or over the left or right edge respectively until a double-

arrow appears

b. Click the mouse, and without letting go, drag the cursor to the left or right

c. When finished, release the mouse.

5. Click anywhere on the canvas to deselect the object.

NOTE: For other methods of modifying positions/duration, see Fine-Tuning/Gestural Controls.
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Setting Defaults

Default properties can be modified before objects are placed on the canvas to avoid having to modify them

afterwards. For example, if you want all milestones to have a certain shape, the desired shape can be chosen

ahead of time.

In addition, the duration display format can be changed from days (the default) to any other time unit larger

than the schedule’s time unit (for more info, see PolyTime/Variable Time Units).

Finally, NetPoint makes use of a scoring system for determining optimal link geometries. For a given link,

each possible geometry is given point penalties based on how many grids it passes, and if it crosses over

other objects or overlaps with other links. The more intersections and overlaps, the more point penalties and

the higher the score. The geometry that receives the lowest possible score will be chosen when creating a

link or running an automated layout. The default point penalties are intended to discourage intersection and

overlap and favor shorter links. For instructions on optimizing links one-at-a-time, see Optimizing Link

Geometries.

Steps

For New Objects

1. Click Objects > Set Default Properties for New Objects from the menu bar.

2. Choose the desired tab. For embeds, links, shades, and text objects, click the More tab.

3. To return to defaults, click Reset.

4. When finished, click OK.

Duration Display Format

1. Click Objects > Set Duration Display Format for Activities from the menu bar.

2. In the sub-menu, choose the desired time unit.

NOTE: Only Days will calculate based on the calendar of the object. Any other time unit will

calculate based on total calendar days.

Link Scoring

1. Click Schedule > Open Layout Manager from the menu bar, click the arrow to the right of the Links tab,

and choose Penalties.

2. Use the number controls to make any changes as desired.

3. Click Save to save the settings and close the manager.

Notes

Activities

For info on individual fields, see Adding/Modifying Activities.
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Milestones

For info on individual fields, see Adding/Modifying Milestones/Benchmarks.
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Benchmarks

For info on individual fields, see Adding/Modifying Milestones/Benchmarks.
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More

In the Embeds section, each property can be set separately for start and finish embeds. To apply one set of

selections to both types, click Copy to Other Type. For info on individual fields, see Using Embeds to Create

SS and FF Links, Creating FS Links, and Annotations/Markup Tools.
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Link Scoring

Penalties
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Crosses an activity If a link crosses an activity. Default is equal to 25 points.

Crosses another link If a link crosses another link. Default is equal to 5 points.

Contains a H leg >

50% of gap

If the horizontal segment of a link has a gap greater than 50% of its duration.

Default is equal to 5 points.

Contains a D leg >

50% of gap

If the diagonal segment of a link has a gap greater than 50% of its duration.

Default is equal to 5 points.

V or D leg crosses a

grid, excluding

intermediate grids

If the vertical or diagonal segment of a link crosses a gridline, excluding

“intermediate” grids (empty grids with no objects that are added to increase

spacing). Default is equal to 2 points.

Opposing H, V, or D

legs overlap

If any segment of a link overlaps with any segment of another link that’s going

in the opposite direction. Default is equal to 10 points.

Coinciding H, V, or D

legs overlap

If any segment of a link overlaps with any segment of another link that’s going

in the same direction. Default is equal to 2 points.

Scores

Link

Score

The link score for a given geometry is equal to the sum of all its penalties. For example, if a

link crosses one activity and two other links, its default score would be equal to 35 (25 penalty

points for crossing the activity and 5 penalty points for crossing each link).

Sum

Link

Score

The sum link score is equal to the sum of the link scores for all links in the network.

Net

Sum

Link

Score

The net sum link score is equal to the sum of the link scores for all links in the network

excluding links between swim lanes if present

Mean

Link

Score

The mean link score is equal to the sum of the link scores for all links divided by the number

of links in the network.

Activity

Score

The activity score is equal to the sum of the link scores for every valid (not redundant) link

connected to that activity divided by the number of links connected to that activity

Mean

Activity

Score

The mean activity score is equal to the sum of the activity scores for all activities in the

network divided by the number of activities in the network.
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Layout

Score

The layout score is a measure of layout optimization. The lower the score, the tidier the layout

relative to link/activity crossings, link overlays, and link length in terms of number of grid

crossings. The layout score is equal to the sum link score plus additional point penalties for

any of the following:

Activity/activity overlap: 50 points

Activity/link overlap (H leg): 25 points

Activity/milestone/benchmark overlap: 25 point
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Activities and Delays

Activities are the building blocks of a schedule. They have a start date and a finish date, represented by end

nodes, and they span a certain period of time. In addition to a regular activity, there is also a delay/gain

object, which is unique in that it can have a duration of zero. If the duration is zero, both the start and end

nodes align to the start of the day (or whichever time unit has been selected). Delays are useful for showing

positive or negative impacts to the schedule or for atypical activities. Unlike regular activities, delays cannot

have an embedded node or any resources assigned. Delays can be distinguished from regular activities by

their bar, which includes vertical gaps from the top to the bottom.

This chapter includes details for the following:

1. Adding/modifying

2. Constraining activities

3. Text annotations

4. Splitting

5. Dissolving

6. Info objects/attachments
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Adding/Modifying

Due to the visual nature of NetPoint, adding and modifying activities is best done graphically on the

canvas. When the cursor is moved over the canvas, the date and day-of-the-week display above the

crosshairs. As the cursor moves around the canvas, the date changes to reflect the exact calendar date that

the cursor is at. If the date is a non-working period or holiday (according to the default calendar for the

schedule), the text will appear red. If the default calendar were the Calendar Day calendar, the date will

appear black.

Steps

Adding to the Canvas

1. Click the Activity or Delay/Gain icon in the toolbar.

2. Move the cursor to the desired date, indicated by the text above the crosshairs.

3. Left-click with the mouse.

4. Without releasing, drag the cursor to stretch the duration (displayed in blue) until the intended finish date.

5. Release the mouse. The Activity Object window will open.

6. Enter a Description.

7. Click OK.

Modifying Dates/Durations

1. Click the Select Tool icon in the toolbar.

2. Select the desired activity on the canvas.

3. To change both the start and finish date simultaneously, left-click with the mouse and drag it to the right

or left.

a. Release the mouse.

4. To change the duration, hover the mouse over the start or finish node until a double-arrow appears.

a. Click and drag the node earlier or later until it lands on the desired date.

b. Release the mouse.

NOTE: Dates and durations can also be modified in the Dates tab. To do so, double-click the desired

object, or right-click and choose Properties.

Converting Between Activities to Delays

1. With the Select Tool chosen in the toolbar, right-click on the desired activity or delay.

2. Choose Convert to Delay or Convert to Activity, respectively.

NOTE: If an activity has an embedded node or resources have been assigned to it, the option to

convert to a delay will be disabled.

Editing the Description

1. With the Select Tool chosen in the toolbar, double-click the description directly on the canvas. A text

box will open.

2. Edit as desired.

3. When finished, click anywhere outside the text box on the canvas.
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Positioning Fields on the Canvas

1. Begin at step 1 of Through GEM Mode.

Notes

Properties Tab

The Properties tab is where general settings are changed.

Field Definition

Description

A text field for describing the activity. To stack, use the ENTER key. Descriptions must be

less than 120 characters for P6 and less than 100 for Open Plan. Otherwise, they’ll be

truncated upon export.

Abbr.

Description

A text field limited to 48 characters to be displayed on the canvas if the description is too

long.

ID

A user-entered unique identifier. By default, the ID is not displayed, but it will display

before the description, surrounded by brackets, if it is turned on. NetPoint internal ID

displayed below.

Codes A window for adding or modifying code assignments.

Resources A window for adding or modifying resource assignments.
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Field Definition

Progress
Whether or not the activity has been started. An activity can only be actualized if a Data

Date has been set. For more info, see Data Dates.

Calculated

Complete

The amount of progressed duration divided by total duration. Only available for actualized

activities.

Estimated

Complete
A user-entered estimate of work completed.

Dates Tab

The Dates tab contains all date related fields, such as the start and finish, duration, calendars, and

constraints

Field Definition

Calendar
The schedule that work on the activity can take place. For more info, see Project

Calendars.

Duration The amount of time the activity takes to complete.

Start The date and/or time the activity begins.
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Field Definition

Finish The date and/or time the activity will be finished.

Start

Constraint

An optional boundary preventing the activity from starting any earlier than the date

selected. For more details, see step 1 of Constraining Activities.

Finish

Constraint

An optional boundary preventing the activity from finishing any later than the date

selected. For more details, see step 1 of Constraining Activities.

Displays Tab

The Displays tab contains checkboxes for hiding or showing different fields on the canvas.

Field Definition

Description
The description of the activity. Only one of the description fields can be displayed at any

given time.

Abbr.

Description
A shorter description for viewing on the canvas if the description is too long.

ID
A user-entered unique identifier. If no description field is displayed but the ID is, then the

ID will inherit the formatting of the abbreviated description.
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Field Definition

Calc.

Complete

The amount of progressed duration divided by total duration. Only available for actualized

activities.

Est.

Complete
A user-entered estimate of work completed.

Duration
The amount of time the activity takes to complete. When actualized, Duration is replaced

by Progressed and Remaining durations.

Start Date The date the activity begins.

Start Time The time the activity begins; only enabled if the schedule time unit is smaller than days.

Finish Date The date the activity will be completed.

Finish

Time

The time the activity will be completed; only enabled if the schedule time unit is smaller

than days.

Drift Buffer
The amount of time an activity can gain before advancing the finish of its nearest

predecessor.

Drift The amount of time an activity can gain before advancing the start of the project.

Float
The amount of time an activity can be delayed before delaying the completion of the

project.

Buffer
The amount of time an activity can be delayed before delaying the start of its nearest

successor.

Total Float Drift + Float.

NOTE: Drift, float, buffer, and total float are displayed in that order below the activity bar on the

same line. They may be distinguished from one another by the shape of their bounding boxes: drift

points to the left, or project start; float and buffer point to the right, or project completion; and total

float points in both directions. Either buffer or total float may be displayed, but not both at the same

time. If too many fields are being displayed for the duration of the activity, the data may stack under

and perpendicular to the bar. To customize the position of the fields on the canvas, see

Repositioning Fields (GEM)
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Format Tab

The Format tab contains controls for changing the look of the object on the canvas.

Bar & Nodes

Field Definition

Size The size of the bar.

Pattern

The pattern of the bar. NOTE: Patterns display best when printed. Depending on your

screen resolution, page size, zoom factor, and activity sizes, patterns may show up

inconsistently on screen. For best results on screen, use the large bar size.

Color
The color of the bar. NOTE: Avoid red, since red is used to signal criticality. For more

info, see Criticality.

Node The color of the start and end nodes.

Descriptions

The description and the abbreviated description can be styled/formatted differently or the same. To make

them different, choose Description from the dropdown, customize the options, and then choose Abbr.

Description from the dropdown, and customize the options for it. The settings will be saved, and you can

switch between the two to confirm.

To make them the same, choose Both from the dropdown, and then customize the options. Note that

choosing both will only overwrite the options that receive a change. For example, imagine the description’s

font has been formatted to Arial and the abbreviated description’s font has been formatted to Tahoma.
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If Both is chosen from the dropdown and the font is set to Calibri, then the font for both the description and

the abbreviated description will be set to Calibri, but the color, alignment, style, and size will be unaffected,

since they didn’t receive any change. This can be confirmed by switching between the description and the

abbreviated description and reviewing them without losing any of the changes.

Field Definition

Font The font for the description, abbreviated description, or both.

Color The color of the description, abbreviated description, or both.

Alignment The alignment of the description, abbreviated description, or both.

Style The style of the description, abbreviated description, or both.

Size The size of the description, abbreviated description, or both.
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Constraining Activities

A constraint is a way to restrict the range that an object may move in time. If an object has been constrained,

any attempt to move it beyond its constraint date will be prevented. Constraints are represented by

exclamation marks to the left or the right of the date they’re constraining.

NetPoint supports two types of constraints: a no-earlier-than (NET) constraint, also called a start-no-earlier

than (SNE) constraint, which defines the earliest date an object may backslide in time; and a no-later-than

(NLT) constraint, also called a finish-no-later than (FNL) constraint, which defines the latest date an object

may slide forward in time. In the case of activities, no-earlier-than constraints are applied to start dates and

no-later-than constraints are applied to finish dates. To set constraints for more than one activity or milestone

at the same time, see Bulk-Editing Objects.

NOTE: Once set for the first time, if the constraint is subsequently turned off, NetPoint continues to

remember the date for future use.

Steps

1. With the Select Tool chosen in the toolbar, double-click the desired activity, or right-click it and

choose Properties. The Activity Object window will open.

2. Click the Dates tab.

3. To apply a NET constraint, check the box next to Start no earlier than. The constraint will default to the

current start date.

4. To apply a NLT constraint, check the box next to Finish no later than. The constraint will default to the

current finish date.

5. To change the constraint date, enter a new value or click the down arrow button. Selecting a date on the

calendar closes the graphic calendar picker.

6. When finished, click OK to exit the window and apply the constraint. An exclamation mark will show up

where the constraint was applied.
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Text Annotations

Annotations can be used to add text directly to a specific object. Text can include a note, a comment, or a

custom data field. When you add an annotation to an object, NetPoint is actually just creating a text box that

is permanently tied to its host. As the object is moved, the annotation moves too, along with other object data,

like dates. Only one annotation may be added to an object at a time. Because annotations can be re-

positioned on the canvas without having to enter Global Edit Mode, it may be desirable to use them instead

of descriptions.

NOTE: Annotations will also fade with their host objects.

Steps

Adding

1. With the Select Tool chosen in the toolbar, right-click on the desired activity.

2. Choose Add Annotation at and then Start, Center, or Finish. The cursor will change to the

crosshairs, and the Text Object icon in the toolbar will become pressed.

3. Left-click with the mouse at the desired date, indicated by the text above the crosshairs. (Dragging the

crosshairs will have no consequence on the shape of the text box).

4. Release the mouse. The edit text window will open.

5. Begin typing.

6. When finished, click anywhere outside the text box on the canvas.

NOTE: Once an annotation is added, Add Annotation at will go disabled, as only one annotation

may be added to an object, and the anchor point may never be changed.

Modifying Annotation Text

1. With the Select Tool chosen in the toolbar, right-click on the text and choose Edit Text.

2. Edit as desired.

3. When finished, click anywhere outside the text box on the canvas.

Modifying Annotation Font

1. With the Select Tool chosen in the toolbar, double-click the text or right-click and choose

Properties. The Text Object window will open.

2. When finished making changes, click OK.

Hiding Annotations

1. With the Select Tool chosen in the toolbar, right-click on the activity and choose Hide Annotation.

2. Click on the canvas to deselect the activity.

Deleting

1. With the Select Tool chosen in the toolbar, select the text on the canvas and press the Delete key,

or right-click on the host activity and choose Delete Annotation.

2. Click on the canvas to deselect the activity.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 97 of 344

http://pmatechnologies.com/user_guide/getting-started/menu-bar/file-menu/textobject/
http://pmatechnologies.com/user_guide/getting-started/menu-bar/file-menu/textobject/


Splitting

Sometimes, it might be helpful divide activity into two separate activities. For example, an in-progress activity

could be split at the data date, separating the finished portion from the remaining portion as two distinct

activities. Any un-actualized activity, or un-actualized portion of an activity, can be split.

After splitting, NetPoint will automatically maintain any links directly into and out of the original activity, while

creating a new finish-to-start link between the new activities. if the original activity had an embedded node

before the split date, it will be part of the first activity. If the embed falls after the split date, it will be part of the

second activity. Either way, the embed’s date will always be maintained. The lag may or may not be

recalculated, depending on its type and behavior. Any unlinked embeds will be deleted. Both activities will

maintain the original bar color and node color, display settings, any code assignments, and any parent

hammock. However, annotations and target information will only remain with the first activity. Any fields that

were re-positioned will be reset for both.

Steps

1. With the Select Tool chosen in the toolbar, move the cursor over a given activity, stopping at the

date desired for the split.

2. Right-click and choose Split Activity. The Split and Link Activity window will open.

3. When finished, click OK.

Notes

Split and Link Activity Window
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First Activity

Field Definition

Description The original activity’s description, prefixed with “Start”.

Abbr. Desc. The original activity’s abbeviated description, appended with “S”.

Activity ID The original activity’s ID prefixed with “S”.

Second Activity

Field Definition

Description The original activity’s description, prefixed with “Comp”

Abbr. Desc. The original activity’s abbreviated description, appended with “C”.

Activity ID The original activity’s ID prefixed with “C”.

“Per Duration “Resource Assignment

Field Definition

Assign to

first activity

When chosen, any resources assigned “per duration” are assigned to the first activity.

Resources assigner “per day” are maintained on both.

Assign to last

activity

When chosen, any resources assigned “per duration” are assigned to the

second activity. Resources assigner “per day” are maintained on both.

Assign

proportionally

When chosen, any resources assigned “per duration” are assigned to both activities.

For example, if 10 carpenters were assigned per duration and it were split in 1/3, 4

would be assigned per duration to the first activity and 6 would be assigned to the

second activity (if decimals arise, the first activity’s quantity will be rounded-up and the

second activity’s will be rounded-down). Resources assigner “per day” are maintained

on both.
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Dissolving

If the need arises to delete an activity without deleting its logic relationships, dissolving can be useful.

Dissolving an activity or delay will completely remove it from the network, while maintaining links to and from

its predecessors and successors. Any resources or codes assigned to the dissolved activity, and any lags on

links to or from the dissolved activity will be ignored. Any links to or from embedded nodes will be treated as

FS links to or from the containing activity. If dissolving an activity results in an embedded node in either a

predecessor or successor having no remaining links, that embed will be removed.

NOTE: No attempt will be made to correct any negative gaps resulting from the dissolve operation.

Steps

1. With the Select Tool chosen in the toolbar, right-click on an activity or delay and select Dissolve

Activity or Dissolve Delay, respectively.

Notes

Once dissolved, a new FS link will be created from each predecessor to each successor. None of these new

links will have lags. The link geometry is chosen automatically to minimize link overlays on the display:

• For one-to-many relationships, VH links are used.

• For one-to-one and many-to-one relationships, HV links are used.

• For many-to-many relationships, VDV links are used.
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Info Objects/Attachments

Info objects are external files or attachments. Adding an info object to an activity is a way to embed a

document on the activity for viewing. An activity with one or more info objects will have an “i” icon placed over

the bar to indicate a file has been attached. However, if the duration is reduced sufficiently to where the end

nodes begin to overlap, the icon will be hidden. Info objects can be added, viewed, and deleted from the Info

Objects tab of the Activity Object window.

Steps

Adding

1. With the Select Tool chosen in the toolbar, double-click an activity, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Click the New button. The Info Object Properties window will open.

4. Click the Browse button. (If you’d like to attach another schedule, first select NetPoint project).

5. Choose a file and click Open.

6. If desired, enter a new Description.

7. Click OK to save and close the Info Object Properties window.

8. To add another, repeat steps 3-7.

9. When finished, click OK.

NOTE: If the iObject is copied and linked to the project folder, the filepath shown will still display the

original location, so that you can always remember where the original file was located.

Modifying

1. With the Select Tool chosen in the toolbar, double-click an activity, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Select the file in the list click the Modify button. The Info Object Properties window will open.

4. Modify as desired.

5. Click OK to save and close the Info Object Properties window.

6. To modify another, repeat steps 3-5.

7. When finished, click OK.

Deleting

1. With the Select Tool chosen in the toolbar, double-click an activity, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Select the file in the list and click the Delete button.

4. In the confirmation, click Yes.

5. To delete another, repeat steps 3-4.

6. When finished, click OK.
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Opening/Viewing

1. With the Select Tool chosen in the toolbar, double-click an activity, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Select the file in the list and click the View button. The file will open outside of NetPoint.

4. To view another, repeat step 3.

5. When finished, click OK.

NOTE: If the info object is a NetPoint schedule, the current schedule will be saved automatically. If

you don’t wish to save the schedule, click Cancel in the confirmation that opens.

Notes

Properties

The Properties window is where the general settings are changed.

Field Definition

Source Determines the type of file to attach.

Filepath
Displays the filepath of the original file, regardless of whether or not it’s copied to to the

project folder.

Description A short description for displaying on the canvas. By default, the same as the filename.

Options
Provides the option to copy the file to the project folder so it’s still viewable after zipping

and sending the project.
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Hammocks

Hammocks are a type of activity used to represent or summarize a group of other activities, milestones, and/

or benchmarks. They are different from regular activities in that they have no attributes of their own (like dates

or info objects), except for the descriptions/ID, and they don’t accept resources or embedded nodes. If an

embed is added, it will display as red. Furthermore, hammocks cannot to be linked to other objects, and

member objects can only belong to one hammock at a time. When exported to P6, any unconnected

milestones or benchmarks will be connected to the LOE with a start-to-start or finish-to-finish relationship

accordingly.

Hammocks are depicted on the canvas by a thick, diagonally hashed bar, beginning at the earliest start date

and ending at the latest finish date of their member objects. The object itself will automatically reflect in real-

time any changes in dates and durations to any of their member objects, and they will also display critical if

any member objects are critical. Once created, hammocks can also be hidden on the canvas, and member

objects can be added and removed. Instructions for all are provided below.

NOTE: If a hammock includes only delay/gain objects with total duration of zero, the hammock still

displays the duration as one, because hammocks cannot have zero duration.

Steps

Creating Hammocks

1. With the Select Tool chosen in the toolbar, select the first activity, milestone, or benchmark on the

canvas.

2. To add more objects, press and hold the Shift key and select a second activity, milestone, or benchmark

on the canvas to include. Alternatively, you can click on a blank portion of the canvas and drag a

rectangular marquee box around all the objects to include in the hammock.

3. With all the objects still selected, click the Hammock icon in the toolbar.

4. Use the up and down arrow buttons or enter the grid number to place the hammock at and

click OK. NOTE: A new gridline will be inserted for the hammock and all objects below it moved

down.

5. Enter a description and any other details.

6. When finished, click OK to close the window and finish creating the hammock.

Adding Objects to Hammocks

1. With the Select Tool chosen in the toolbar, select the hammock on the canvas.

2. Press and hold the Shift key and select each activity, milestone, or benchmark to add to the hammock.

Alternatively, you can click on a blank portion of the canvas and drag a rectangular marquee box around

all the objects you want to add to the hammock.

3. Click the Hammock icon in the toolbar. If one or more objects to be added already belong to a

different hammock, a prompt will open. See 3a.

a. Choose Add to Hammock and click Apply for all objects you wish to remove and add. Otherwise,

choose Leave in Existing Hammock.

NOTE: If multiple hammocks were selected when pressing the hammock icon in the

toolbar, deselect all but one and retry the operation.
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Removing Objects from Hammocks

1. With the Select Tool chosen in the toolbar, select the first activity, milestone, or benchmark on the

canvas to remove.

2. To remove more than one object, press and hold the Shift key and select each additional activity,

milestone, or benchmark on the canvas. Alternatively, you can click on a blank portion of the canvas and

drag a rectangular marquee box around all the objects you want to remove from the hammock.

3. Click the down arrow to the right of the Hammock icon in the toolbar.

4. Click Remove Object(s) from Hammock(s). A confirmation will open.

5. Press Remove to confirm. Hammock lengths will adjust accordingly

Hiding Hammocks

1. With the Select Tool chosen in the toolbar, select the hammock you want to hide.

2. To hide multiple hammocks, press and hold the Shift key and select each additional hammock on the

canvas. Alternatively, you can click on a blank portion of the canvas and drag a rectangular marquee box

around all the hammocks you want to hide.

3. Click the down arrow to the right of the Hammock icon in the toolbar.

4. Choose Hide Hammock(s).

NOTE: If no member objects or hammocks have been selected, choosing this menu option will

hide all hammocks in the schedule.

Showing Hammocks

1. With the Select Tool chosen in the toolbar, select a member activity from the hammock you want to

show.

2. To show more than one hidden hammock, press and hold the Shift key and select additional member

objects on the canvas. Alternatively, you can click on a blank portion of the canvas and drag a

rectangular marquee box around all the member objects of the hammocks you want to show.

3. Click the down arrow to the right of the Hammock icon in the toolbar.

4. Choose Show Hidden Hammock(s).

NOTE: To show all hidden hammocks, including hammocks which you may not remember the

member objects of, choose this menu option without any objects selected on the canvas.

Including/Excluding from Resource Display

1. With the Select Tool chosen in the toolbar, right-click the hammock.

2. Choose Show Resources for Hammock ONLY or Hide Resources for Hammock ONLY.
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Notes

Properties Tab

The Properties tab is where general settings are changed.

Field Definition

Description

A text field for describing the hammock. To stack, use the ENTER key. Descriptions must

be less than 120 characters for P6 and less than 100 for Open Plan. Otherwise, they’ll be

truncated upon export.

Abbr.

Description

A text field limited to 48 characters to be displayed on the canvas if the description is too

long.

ID

A user-entered unique identifier. By default, the ID is not displayed, but it will display

before the description, surrounded by brackets, if it is turned on. NetPoint internal ID

displayed below.

Codes A window for adding or modifying code assignments.

Resources Hammocks can not be assigned resources.

Progress A hammock cannot be actualized.
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Field Definition

Calculated

Complete

The amount of progressed duration divided by total duration. Only available once any of

its member objects are actualized. A warning will be shown if some member objects are

not yet actualized as they will throw off the calculations.

Estimated

Complete
A user-entered estimate of work completed.

Displays Tab

The Displays tab contains checkboxes for hiding or showing different fields on the canvas.

Field Definition

Description
The description of the hammock. Only one of the description fields can be displayed at

any given time.

Abbr.

Description
A shorter description for viewing on the canvas if the description is too long.

ID
A user-entered unique identifier. If no description field is displayed but the ID is, then the

ID will inherit the formatting of the abbreviated description.
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Field Definition

Calc.

Complete

The amount of progressed duration divided by total duration. Only available if at least one

member has been actualized.

Est.

Complete
A user-entered estimate of work completed.

Duration
The amount of time the hammock takes to complete. When actualized, Duration is

replaced by Progressed and Remaining durations.

Start Date The date the earliest member object begins.

Start Time
The time the earliest member object begins; only enabled if the schedule time unit is

smaller than days.

Finish Date The date the latest member object will be completed.

Finish

Time

The time the latest member object will be completed; only enabled if the schedule time

unit is smaller than days.

Drift Buffer
The amount of time the hammock can gain before advancing the finish of its nearest

predecessor. Equal to the lowest of all member objects’ drift buffers.

Drift
The amount of time the hammock can gain before advancing the start of the

project. Equal to the lowest of all member objects’ drifts.

Float
The amount of time the hammock can be delayed before delaying the completion of the

project. Equal to the lowest of all member objects’ floats.

Buffer
The amount of time the hammock can be delayed before delaying the start of its nearest

successor. Equal to the lowest of all member objects’ buffers.

Total Float Drift + Float. Equal to the lowest of all member objects’ total floats.

NOTE: Drift, float, buffer, and total float are displayed in that order below the hammock bar on the

same line. They may be distinguished from one another by the shape of their bounding boxes: drift

points to the left, or project start; float and buffer point to the right, or project completion; and total

float points in both directions. Either buffer or total float may be displayed, but not both at the same

time. If too many fields are being displayed for the duration of the activity, the data may stack under

and perpendicular to the bar. To customize the position of the fields on the canvas,

see Repositioning Fields.
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Format Tab

The Format tab contains controls for changing the look of the object on the canvas.

Bar and Nodes

Field Definition

Pattern

The pattern of the bar. NOTE: Patterns display best when printed. Depending on your

screen resolution, page size, zoom factor, and activity sizes, patterns may show up

inconsistently on screen. For best results on screen, use the large bar size.

Color The color of the bar.

Node The color of the start and end nodes.

Descriptions

The description and the abbreviated description can be styled/formatted differently or the same. To make

them different, choose Description from the dropdown, customize the options, and then choose Abbr.

Description from the dropdown, and customize the options for it. The settings will be saved, and you can

switch between the two to confirm.

To make them the same, choose Both from the dropdown, and then customize the options. Note that

choosing both will only overwrite the options that receive a change. For example, imagine the description’s

font has been formatted to Arial and the abbreviated description’s font has been formatted to Tahoma.

If Both is chosen from the dropdown and the font is set to Calibri, then the font for both the description and

the abbreviated description will be set to Calibri, but the color, alignment, style, and size will be unaffected,
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since they didn’t receive any change. This can be confirmed by switching between the description and the

abbreviated description and reviewing them without losing any of the changes.

Field Definition

Font The font for the description, abbreviated description, or both.

Color The color of the description, abbreviated description, or both.

Alignment The ailgnment of the description, abbreviated description, or both.

Style The style of the description, abbreviated description, or both.

Size The size of the description, abbreviated description, or both.

Copy/Paste

Format options can be copied and pasted between hammocks and activities/delays, and hammocks can be

used as sources for target data element positioning in Global Edit Mode (and vice versa). For more info,

seeRepositioning Fields.
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Milestones and Benchmarks

Milestones and benchmarks are zero duration events that are used to represent key dates or moments in the

schedule. Two types are available: a start milestone/benchmark, and a finish milestone/benchmark. The start

type aligns to the beginning of the day or time unit (by default, 9:00 am), and should be used for events which

will precede an activity or represent an initiation; the finish type aligns to the end of the day or time unit (by

default, 5:00 pm), and should be used for events which will succeed an activity or represent a termination. In

addition, both milestones and benchmarks can be represented by a variety of shapes; however, each one has

its own set of behaviors.

Milestones, like activities, will track along with the network, once they’ve been linked to any predecessors or

successors. In addition, a start milestone will snap to its earliest successor and a finish milestone will snap to

its latest predecessor, always maintaining a zero gap link. If a start milestone has no successors (for example,

if it’s been linked to an activity that precedes it in time), it will not snap and erase any gap, but it will continue

to track. If a finish milestone has no predecessors, it will also not snap but continue to track. While such

relationships are discouraged and illogical, they may serve as a workaround snapping, where desired.

Benchmarks, unlike activities and milestones, will remain fixed at whatever date they are placed, regardless

of whether or not they’ve been linked to any predecessor or successors. This means that even as an activity

is pushed earlier or later than it, a negative gap link will open up as it passes. Although by default,

benchmarks show up red, they are not and cannot be critical. This is because they do not have any float or

drift themselves. In fact, any activities connected to the benchmark will have their float and drift calculated to

the benchmark rather than to the project start and completion. This allows benchmarks to be used to divide

up float and allocate it to different stages instead of having it accumulate undisturbed from schedule

completion.

NOTE: If you’re planning on running a GPM risk analysis, benchmarks should be converted to

milestones for best practice. For more info, see Converting Between Milestones and Benchmarks.

This chapter includes details for the following:

1. Adding/modifying

2. Constraining milestones

3. Text annotations

4. Info objects/attachments
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Adding/Modifying

Due to the visual nature of NetPoint, adding and modifying milestones and benchmarks is best done

graphically on the canvas. When the cursor is moved over the canvas, the date and day-of-the-week display

above the crosshairs. As the cursor moves around the canvas, the date changes to reflect the exact calendar

date that the cursor is at. If the date is a non-working period or holiday (according to the default calendar for

the schedule), the text will appear red. If the default calendar were the Calendar Day calendar, the date will

appear black.

Steps

Adding to the Canvas

1. Click either the Start Milestone , Finish Milestone , Start Benchmark , or Finish

Benchmark icon in the toolbar.

2. Move the cursor to the desired date, indicated by the text above the crosshairs.

3. Left-click with the mouse. The Milestone Object or Benchmark Object window will open.

4. Enter a Description.

5. Click OK.

Modifying Dates

1. Click the Select Tool icon in the toolbar.

2. Select the desired event on the canvas.

3. Left-click with the mouse, and without releasing, drag it to the right or left until it lands on the desired

date.

4. Release the mouse.

NOTE: Dates can also be modified using the arrow keys on the keyboard or in the Dates tab. To do

so, double-click the desired object, or right-click and choose Properties.

Converting Between Milestones and Benchmarks

1. Click the Select Tool icon in the toolbar.

2. Select the desired event on the canvas.

3. To convert between start and finish events, choose Convert to Start or Convert to Finish accordingly.

4. To convert between milestones and benchmarks, choose Convert to Milestone or Convert to

Benchmark accordingly.

NOTE: Any existing constraints will be removed before converting. Once converted, the date is

adjusted to maintain the current position of the object. For example, when a start milestone at 3/30/

2010 is converted to a finish milestone, the date is adjusted to 3/29/2010, as the start of 3/30 and the

end of 3/29 are at the same position on the schedule. This also allows the type of a benchmark to be

changed without affecting float or drift calculations.

Editing the Description

1. With the Select Tool chosen in the toolbar, double-click the description directly on the canvas. A text

box will open.
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2. Edit as desired.

3. When finished, click anywhere outside the text box on the canvas.

Positioning Fields on the Canvas

1. Begin at step 1 of Through GEM Mode.

Notes

Properties Tab

The Properties tab is where general settings are changed.
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Field Definition

Description

A text field for describing the milestone/benchmark. To stack, use the ENTER

key. Descriptions must be less than 120 characters for P6 and less than 100 for Open

Plan. Otherwise, they’ll be truncated upon export.

Abbr.

Description

A text field limited to 48 characters to be displayed on the canvas if the description is

too long.

ID

A user-entered unique identifier. By default, the ID is not displayed, but it will display

before the description, surrounded by brackets, if it is turned on. NetPoint internal ID

displayed below.

Calendar
The schedule that work on the event can take place. For more info, see Project

Calendars.

Date/Time

The date and/or time the event starts or finishes (depending on the type). The date

can be made actual by clicking Actualize, but only if a Data Date has been set. For

more info, see see Data Dates.

Estimated

Complete
A user-entered estimate of work completed.

Codes A window for adding or modifying code assignments.
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Field Definition

Start no earlier

than/Finish no

earlier than*

*Only available for milestones. An optional boundary preventing the event from

starting/finish any earlier than the date selected. For more details, see step 1

of Constraining Milestones.

Start no later

than/Finish no

later than*

*Only available for milestones. An optional boundary preventing the event from

starting/finish any later than the date selected. For more details, see step 1 of

Constraining Milestones.

Displays Tab

The Displays tab contains checkboxes for hiding or showing different fields on the canvas.
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Field Definition

Description
The description of the milestone/benchmark. Only one of the description fields can be

displayed at any given time.

Abbr.

Description
A shorter description for viewing on the canvas if the description is too long.

ID
A user-entered unique identifier. If no description field is displayed but the ID is, then the

ID will inherit the formatting of the abbreviated description.

Est.

Complete
A user-entered estimate of work completed.

Date The date the event starts or finishes

Time
The time the event starts or finishes; only enabled if the schedule time unit is smaller than

days.

Drift

Buffer*

*Only available for milestones. The amount of time a milestone can gain before

advancing the finish of its nearest predecessor.

Drift*
*Only available for milestones. The amount of time a milestone can gain before

advancing the start of the project.
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Field Definition

Float*
*Only available for milestones. The amount of time a milestone can be delayed before

delaying the completion of the project.

Buffer*
*Only available for milestones. The amount of time a milestone can be delayed before

delaying the start of its nearest successor.

Total Float* *Only available for milestones. Drift + Float.

NOTE: Drift, float, buffer, and total float are displayed in that order below the milestone on the same

line. They may be distinguished from one another by the shape of their bounding boxes: drift points

to the left, or project start; float and buffer point to the right, or project completion; and total float

points in both directions. Either buffer or total float may be displayed, but not both at the same time.

To customize the position of the fields on the canvas, see Repositioning Fields (GEM).

Format Tab

The Format tab contains controls for changing the look of the object on the canvas.
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Icon

Field Definition

Size The size of the event on the canvas.

Shape

The shape of the event. A start event will be filled in on the left (or point to the left if it’s a

flag); a finish event will be filled in on the right (or point to the right if it’s a flag). NOTE: Any

pattern in-use by a milestone will be unavailable for use by a benchmark, and vice-

versa.

Color
The color of the event. NOTE: Avoid red for milestones, since red is used to signal

criticality. For more info, see Criticality.

Text

Location
The default position for the ID, description, and date/time

Tail

Length

(0-1)*

*Only available for milestones. An optional line extending from the bottom of the milestone

down the canvas, with 0 being no line and 1 being to the bottom of the canvas.

Shape

Hourglass

Vertical Diamond
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Shape

Horizontal Diamond

5-point Star

4-point Star

Flag

Triangle

Descriptions

The description and the abbreviated description can be styled/formatted differently or the same. To make

them different, choose Description from the dropdown, customize the options, and then choose Abbr.

Description from the dropdown, and customize the options for it. The settings will be saved, and you can

switch between the two to confirm.

To make them the same, choose Both from the dropdown, and then customize the options. Note that

choosing both will only overwrite the options that receive a change. For example, imagine the description’s

font has been formatted to Arial and the abbreviated description’s font has been formatted to Tahoma.

If Both is chosen from the dropdown and the font is set to Calibri, then the font for both the description and

the abbreviated description will be set to Calibri, but the color, alignment, style, and size will be unaffected,

since they didn’t receive any change. This can be confirmed by switching between the description and the

abbreviated description and reviewing them without losing any of the changes.

Field Definition

Font The font for the description, abbreviated description, or both.

Color The color of the description, abbreviated description, or both.

Alignment The alignment of the description, abbreviated description, or both.

Style The style of the description, abbreviated description, or both.

Size The size of the description, abbreviated description, or both.
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Constraining Milestones

A constraint is a way to restrict the range that an object may move in time. If an object has been constrained,

any attempt to move it beyond its constraint date will be prevented. Constraints are represented by

exclamation marks to the left or the right of the date they’re constraining.

NetPoint supports two types of constraints: a no-earlier-than (NET) constraint, also called a start-no-earlier

than (SNE) constraint, which defines the earliest date an object may backslide in time; and a no-later-than

(NLT) constraint, also called a finish-no-later than (FNL) constraint, which defines the latest date an object

may slide forward in time. In the case of milestones and benchmarks, no-earlier-than constraints are applied

to start types and no-later-than constraints are applied to finish types. To set constraints for more than one

activity or milestone at the same time, see Bulk-Editing Objects.

Tip: Instead of constraining a milestone, consider using a benchmark. Benchmarks are constrained to the

date that they’re set at and allow negative-gap to measure movement beyond the set date.

NOTE: If a milestone is constrained to a non-working day based on its calendar, it may be subject to

having extra float or drift that can never be zeroed out. For example, a start milestone whose

earliest successor starts on Monday but whose no-later-than constraint is set to Saturday will be

forced to start on Friday and have one day of float even though it’s snapped.

Steps

1. With the Select Tool chosen in the toolbar, double-click the desired milestone, or right-click it and

choose Properties.

2. To apply a NET constraint, check the box next to Finish no earlier than (or Start no earlier than for a

start milestone). The constraint will default to the current date.

3. To apply a NLT constraint, check the box next to Finish no later than (or Start no later than for a start

milestone). The constraint will default to the current date.

4. To change the constraint date, enter a new value or click the down arrow button. Selecting a date on the

calendar closes the graphic calendar picker.

5. When finished, click OK to exit the window and apply the constraint. An exclamation mark will show up

where the constraint was applied.
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Text Annotations

Annotations can be used to add text directly to a specific object. Text can include a note, a comment, or a

custom data field. When you add an annotation to an object, NetPoint is actually just creating a text box that

is permanently tied to its host. As the object is moved, the annotation moves too, along with other object data,

like dates. Only one annotation may be added to an object at a time. Because annotations can be re-

positioned on the canvas without having to enter Global Edit Mode, it may be desirable to use them instead

of descriptions.

NOTE: Annotations will also fade with their host objects.

Steps

Adding

1. With the Select Tool chosen in the toolbar, right-click on the desired event.

2. Choose Add Annotation at and then Start, Center, or Finish. The cursor will change to the

crosshairs, and the Text Object icon in the toolbar will become pressed.

3. Left-click with the mouse at the desired date, indicated by the text above the crosshairs. (Dragging the

crosshairs will have no consequence on the shape of the text box).

4. Release the mouse. The edit text window will open.

5. Begin typing.

6. When finished, click anywhere outside the text box on the canvas.

NOTE: Once an annotation is added, Add Annotation will go disabled, as only one annotation may

be added to an object, and the anchor point may never be changed.

Modifying Annotation Text

1. With the Select Tool chosen in the toolbar, right-click on the text and choose Edit Text.

2. Edit as desired.

3. When finished, click anywhere outside the text box on the canvas.

Modifying Annotation Font

1. With the Select Tool chosen in the toolbar, double-click the text or right-click and choose

Properties. The Text Object window will open.

2. When finished making changes, click OK.

Hiding Annotations

1. With the Select Tool chosen in the toolbar, right-click on the event and choose Hide Annotation.

2. Click on the canvas to deselect the event.

Deleting

1. With the Select Tool chosen in the toolbar, select the text on the canvas and press the Delete key,

or right-click on the host event and choose Delete Annotation.

2. Click on the canvas to deselect the event.
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Info Objects/Attachments

Info objects are external files or attachments. Adding an info object to a milestone or benchmark is a way to

embed a document on the event for viewing. An event with one or more info objects will have an “i” icon

placed over the bar to indicate a file has been attached. However, if the duration is reduced sufficiently to

where the end nodes begin to overlap, the icon will be hidden. Info objects can be added, viewed, and deleted

from the Info Objects tab of the event’s Object window.

Steps

Adding

1. With the Select Tool chosen in the toolbar, double-click an event, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Click the New button. The Info Object Properties window will open.

4. Click the Browse button. (If you’d like to attach another schedule, first select NetPoint project).

5. Choose a file and click Open.

6. If desired, enter a new Description.

7. Click OK to save and close the Info Object Properties window.

8. To add another, repeat steps 3-7.

9. When finished, click OK.

NOTE: If the iObject is copied and linked to the project folder, the filepath shown will still display the

original location, so that you can always remember where the original file was located.

Modifying

1. With the Select Tool chosen in the toolbar, double-click an event, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Select the file in the list click the Modify button. The Info Object Properties window will open.

4. Modify as desired.

5. Click OK to save and close the Info Object Properties window.

6. To modify another, repeat steps 3-5.

7. When finished, click OK.

Deleting

1. With the Select Tool chosen in the toolbar, double-click an event, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Select the file in the list and click the Delete button.

4. In the confirmation, click Yes.

5. To delete another, repeat steps 3-4.

6. When finished, click OK.
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Opening/Viewing

1. With the Select Tool chosen in the toolbar, double-click an event, or right-click and choose

Properties.

2. Click the Info Objects tab.

3. Select the file in the list and click the View button. The file will open outside of NetPoint.

4. To view another, repeat step 3.

5. When finished, click OK.

NOTE: If the info object is a NetPoint schedule, the current schedule will be saved automatically. If

you don’t wish to save the schedule, click Cancel in the confirmation that opens.

Notes

Properties

The Properties window is where the general settings are changed.

Field Definition

Source Determines the type of file to attach.

Filepath
Displays the filepath of the original file, regardless of whether or not it’s copied to to the

project folder.

Description A short description for displaying on the canvas. By default, the same as the filename.

Options
Provides the option to copy the file to the project folder so it’s still viewable after zipping

and sending the project.
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Links, Embeds, and Logic

Different objects, such as activities, milestones, and benchmarks, may be related or unrelated to one another.

In NetPoint, these relationships are represented by links, and they form the backbone of a GPM schedule.

From them, float attributes are calculated, including gap, buffer, float and drift. A link is represented as a

yellow line with red arrows pointing from the first object to the second object.

In a relationship, the first object is called the predecessor; the second object the – successor. If an object is

moved earlier than its predecessor or later than its successor, it creates a negative-gap link, which corrupts

the logic of the original relationship. As long as Logic Mode is turned on, however, NetPoint will heal

negative-gap links as they form, moving the predecessor or successor along as it’s modified in real-time. This

automatic correction is known as self-healing.

This section details instructions for the following:

1. Creating FS links

2. Using embeds to create SS and FF links

3. Link geometries

4. Adding link lags

5. Text annotations

6. Spotlighting/highlighting link chains

7. Treating redundancies

8. Overriding logic
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Creating FS Links

The simplest kind of link, the finish-to-start (FS), represents a relationship where the successor cannot start

before the predecessor finishes. If the predecessor and successor overlap on the timescale, an embedded

node must be placed first. For more information, see Using Embeds to Create SS & FF Links.

FS links can be created between activities, milestones, and benchmarks, either in pairs or for multiple

activities. However, the regular Link icon can only link two objects at a time. If more than two objects are

selected for linking, an error message will open. When linking multiple activities, the FS Link Chain icon must

be used. Instructions for both are provided.

NOTE: For diagonal links, only the vertical or horizontal portions may be selected.

Steps

Two Activities

1. With the Select Tool chosen in the toolbar, select the first activity, milestone, or benchmark on the

canvas

2. Press and hold the Shift key and select the second activity, milestone, or benchmark on the canvas.

Alternatively, you can click on a blank portion of the canvas and drag a rectangular marquee box around

both objects, so long as it includes only the two desired objects for linking.

3. With both objects still selected, click the Link icon in the toolbar.

4. Once linked, both objects remain selected. To de-select, click an empty portion of the canvas.

Multiple Activities

1. With the Multi-Object Select Tool chosen in the toolbar, select the first activity, milestone, or

benchmark on the canvas.

2. Select the second activity, milestone, or benchmark on the canvas. Alternatively, you can click on a blank

portion of the canvas and drag a rectangular marquee box around all objects, so long as none of them

overlap on the timescale.

3. Repeat step 2 for each object, as needed.

4. With all the objects still selected, click the FS Link Chain icon in the toolbar.

5. Once linked, all the objects remain selected. To de-select, click an empty portion of the canvas.
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Notes

Properties

Field Definition

Logic
A label for categorizing links. The designation is for supplemental information; it has no

bearing on actual schedule logic or calculations. For a breakdown, see below.

Geometry

The physical shape of the link. A link can bend vertically, horizontally, and diagonally, in

eight different combinations. NetPoint makes use of a scoring system to identify the best

possible geometry for a link. For more information, see Link Geometries.

Lag A way to enforce a minimum gap. For more info, see Adding Link Lags.

Logic Types

Type Definition

Hard A relationship that is inherent to the nature of the work being done.

Soft A relationship that is a preferred choice.

Resource-

Flow
A relationship that is based on resource usage.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 125 of 344

http://pmatechnologies.com/user_guide/building-a-schedule/links-embeds-logic-2/optimizing-link-geometries/#scoring
http://pmatechnologies.com/user_guide/building-a-schedule/links-embeds-logic-2/adding-lags-to-links/#link-offset


Type Definition

External
A relationship that is mandated or dictate by an external source, such as a

governmental agency.

Contractual A relationship that is mandated or dictated by a contract.

Special A relationship that is unique to the schedule.

Displays

Field Definition

Gap The duration of the link.

Lag

Notation

The value of the lag. If the gap is equal to zero, it will automatically turn off, even if the box

is checked for display.

Attributes

Field Definition

Predecessor The object the link is emanating from. This field is just an indicator and cannot be edited.

Successor The object the link is merging into. This field is just an indicator and cannot be edited.

Relationship The type of link. This field is just an indicator and cannot be edited.

Score

A point value based on how many grids the link passes through, or if it crosses over

other objects or overlaps with other links, for example. For more information on scoring,

see Link Geometries.

Validity
An indicator of whether or not the link is valid or redundant. For more information, see

Treating Redundancies.
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Using Embeds to Create SS and FF Links

An embedded node (or embed), represented by single yellow circle, is placed on a host activity to allow finish-

to-finish (FF) and start-to-start (SS) relationships. It may be placed to coincide with its host activity’s start or

finish nodes, or it may be offset (to have a lead or lag) between the two. In a FF relationship, a successor

cannot finish before its predecessor finishes. In a SS relationship, a successor cannot start before its

predecessor starts.

If an embed is placed outside of an activity, it will be displayed in red until it is moved onto an activity. Any

such orphan embed not associated with an activity cannot be linked and will not be stored when the schedule

is saved or closed.

Steps

Start-to-Start

1. Click the Start Embed icon in the toolbar.

2. Move the cursor over the desired activity to be the predecessor in the relationship.

3. Click the mouse, and while keeping it depressed, slide the cursor along the bar of the activity to adjust

the offset (or lag) noted in blue.

4. Release the mouse to place the embed. Once an embed has been successfully placed on an activity,

the Embed Object window opens automatically.

5. Make any desired changes and click OK.

6. Click the Select Tool icon in the toolbar.

7. Press and hold the Shift key and select a valid successor. For a list of valid successors, see Rules for

Placing Embeds

8. Select the embed on the canvas.

9. With both objects still selected, click the Link icon in the toolbar.

10. Once linked, both objects remain selected. To de-select, click an empty portion of the canvas

Finish-to-Finish

1. Click the Finish Embed icon in the toolbar.

2. Move the cursor over the desired activity to be the successor in the relationship.

3. Click the mouse, and while keeping it depressed, slide the cursor along the bar of the activity to adjust

the offset (or lag) noted in blue.

4. Release the mouse to place the embed. Once an embed has been successfully placed on an activity,

the Embed Object window opens automatically.

5. Make any desired changes and click OK.

6. Click the Select Tool icon in the toolbar.

7. Press and hold the Shift key and select a valid predecessor. For a list of valid predecessors, see Rules

for Placing Embeds

8. Select the embed on the canvas.

9. With both objects still selected, click the Link icon in the toolbar.

10. Once linked, both objects remain selected. To de-select, click an empty portion of the canvas
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Notes

Properties

The Properties section is where general settings are changed.

Field Definition

Date/Time The date and/or time the event starts or finishes (depending on the type).

Lag The offset from the start or finish date.

Behavior One of four different types. For more info, see the table below.

Lag Display Position The location for displaying the lag on the canvas.

Behavior

Start Finish

Constant

Fixed to Start. The lag of this embed will

remain constant to the start date of its

host activity. In effect, the embed’s date

will change along with the start date but

not if the finish date changes.

Fixed to Finish. The lag of this embed

will remain constant to the finish date of

its host activity. In effect, the embed’s

date will change along with the finish date

but not if the start date changes.

Reverse

Fixed to Finish. The lag of this embed

will remain constant to the finish date of

its host activity. In effect, the embed’s

date will change along with the finish date

but not if the start date changes.

Fixed to Start. The lag of this embed will

remain constant to the start date of its

host activity. In effect, the embed’s date

will change along with the start date but

not if the finish date changes.

Proportionate

Proportional to Start. The lag of this

embed will remain proportional to

the start date of its host activity. In effect,

the embed’s date will always be changing

to maintain its percentage from the start.

If the duration of the host activity is

Proportional to Finish. The lag of this

embed will remain proportional to

the finish date of its host activity. In effect,

the embed’s date will always be changing

to maintain its percentage from the finish.

If the duration of the host activity is
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Start Finish

changed, the proportion may not be

perfectly maintained because the number

of days available may no longer allow the

embed to fall on a day at exactly the

same proportion away from the start as

before; i.e., a rounding error because of

the number of days available.

changed, the proportion may not be

perfectly maintained because the number

of days available no longer allows the

embed to fall on a day at exactly the

same proportion away from the finish as

before; i.e., a rounding error because of

the number of days available.

Variable

Fixed Symmetrically. The lag of this

embed will remain constant to

the whichever date is changed–if the start

date is changed, it will remain constant to

the start; if the finish date is changed, it

will remain constant to the finish. In

effect, the embed’s date will change

along with both the start date and the

finish date.

Fixed Inversely. The lag of this embed

will remain constant to the opposite of

whichever date is changed–if the start

date is changed, it will remain constant to

the finish; if the finish date is changed, it

will remain constant to the start. In effect,

the embed’s date will never change with

either the start date or the finish date.

Displays

The Displays section contains checkboxes for hiding or showing different fields on the canvas

Field Definition

Date The date the event starts or finishes (depending on the type).

Time The time the event starts or finishes (depending on the type).

Lag from Start The number of days (or time units) offset from the start.

Lag to Finish The number of days (or time units) offset from the finish.

Formatting
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The Formatting section contains controls for changing the look of the object on the canvas

Field Definition

Color The color of the embed.

Rules for Placing Embeds

The rules for placing embeds are as follows: for activities and embeds, a start embed may only be placed on

a predecessor activity and linked to the start of a successor activity or a finish embed on a successor activity.

For milestones and benchmarks, a start embed can be placed on a predecessor activity or successor activity

and linked to either start or finish milestones and benchmarks. But in the case where the start embed is on a

predecessor activity and linked to a start milestone, the milestone will not snap. If the start embed is on a

successor activity and linked to a finish milestone, the milestone will not snap.

A finish embed may only be placed on a successor activity and linked to the start of a predecessor activity or

a start embed on a predecessor activity. For milestones and benchmarks, a finish embed can be placed on a

successor activity or successor activity and linked to either start or finish milestones and benchmarks. But in

the case where the finish embed is on a successor activity and linked to a finish embed, the milestone will not

snap. If the finish embed is on a predecessor activity and linked to a start milestone, the milestone will not

snap.
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Link Geometries

When creating a link for the first time, each possible geometry is ranked by a scoring system based on how

many grids it passes through, or if it crosses over other objects or overlaps with other links, for example. The

more intersections and overlaps, the higher the score. Whichever geometry receives the lowest possible

score will be chosen. The default scoring system is intended to discourage intersection and overlap and favor

shorter links. To modify the default scoring penalties, see Link Scoring. To disallow diagonal geometries, see

the Placement Tab section of Running the Engine.

As more objects or relationships are added, once-optimized links may soon become convoluted. In these

cases, the user can choose to optimize a link based on its link score. Alternatively, a geometry can be chosen

manually without considering link score. Instructions for both are provided. To optimize geometries across the

entire network at once, see Running The Engine.

Steps

Choosing Manually

1. With the Select Tool chosen in the toolbar, right-click on the desired link.

2. Click Change Link to from the menu and choose a new geometry accordingly.

3. The menu will close and the link will update automatically.

Optimizing Automatically

1. With the Select Tool chosen in the toolbar, right-click on the desired link.

2. Choose Optimize Link Shape from the menu.

3. The menu will close and the link will update automatically.

Notes

Geometries

V Vertical

H Horizontal

VH Vertical-Horizontal

HV Horizontal-Vertical

VHV Vertical-Horizontal-Vertical

HVH Horizontal-Vertical-Horizontal

VDV Vertical-Diagonal-Vertical

HDH Horizontla-Diagonal-Horizontal
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HDV Horizontal-Diagonal-Vertical

VDH Vertical-Diagonal-Horizontal
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Adding Link Lags

A lag, also known as a link offset, is a way to prevent a link from collapsing to zero gap; or, in other words, to

enforce an absolute minimum gap. Lags may be used, for example, to more accurately model the curing time

for concrete, where using an activity may incorrectly suggest that there is work taking place.

The value of the lag equals the number of days from the predecessor’s finish node and adopts the calendar of

the predecessor activity. If a link had a lag of 7 days, and its successor were pulled back as far as it could go,

the link would cease collapsing once the gap equaled 7. If a negative value is entered, this allows the start of

the successor to push before the finish of the predecessor activity even when logic is on.

A lag displays as a red dot on top of the link, but it is not visible if the lag is too close to an activity node. You

can also tell when a link has a lag in place by a red dot placed next to its gap value. This gives a cue that a

lag is affecting the link gap value. Both the gap, and the dot next to the gap, however, will automatically be

hidden if the gap reaches zero.

NOTE: Negative lags can only be applied to finish-to-start relationships. Upon opening a legacy

schedule with negative lags on relationships other than finish-to-start, they will be removed

automatically, a message will display, and the links with lags removed will become highlighted on

the canvas.

Steps

1. With the Select Tool chosen in the toolbar, double-click on a desired link, or right-click and choose

Properties.

2. Under Properties, enter a number other than 0 next to Lag.

3. To display a red dot next to the gap value, check the box next to Lag Notation.

4. Click OK to close the window and apply the lag.

Notes

Lag Gap Calculation

Once a lag is defined, it affects the gap calculation. The gap of a link with a lag is calculated as the gap of the

predecessor to the successor minus the lag value. In the following example, the original gap between the

predecessor and successor is 5 calendar days.

Below, a lag of 3 calendar days is placed.
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As you can see, the new gap of 2 days is equal to the original gap of 5 days minus the lag of 3 days.
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Text Annotations

Annotations can be used to add text directly to a specific object. Text can include a note, a comment, or a

custom data field. When you add an annotation to an object, NetPoint is actually just creating a text box that

is permanently tied to its host. As the object is moved, the annotation moves too, along with other object data,

like dates. Only one annotation may be added to an object at a time.

NOTE: Annotations will also fade with their host objects.

Steps

Adding

1. With the Select Tool chosen in the toolbar, right-click on the desired link.

2. Choose Add Annotation. The cursor will change to the crosshairs, and the Text Object icon in the

toolbar will become pressed.

3. Left-click with the mouse at the desired date, indicated by the text above the crosshairs. (Dragging the

crosshairs will have no consequence on the shape of the text box).

4. Release the mouse. The edit text window will open.

5. Begin typing.

6. When finished, click anywhere outside the text box on the canvas.

NOTE: Once an annotation is added, Add Annotation will go disabled, as only one annotation may

be added to an object, and the anchor point may never be changed.

Modifying Annotation Text

1. With the Select Tool chosen in the toolbar, right-click on the text and choose Edit Text.

2. Edit as desired.

3. When finished, click anywhere outside the text box on the canvas.

Modifying Annotation Font

1. With the Select Tool chosen in the toolbar, double-click the text, or right-click and choose

Properties. The Text Object window will open.

2. When finished making changes, click OK.

Hiding Annotations

1. With the Select Tool chosen in the toolbar, right-click on the link and choose Hide Annotation.

2. Click on the canvas to deselect the link.

Deleting

1. With the Select Tool chosen in the toolbar, select the text on the canvas and press the Delete key,

or right-click on the host link and choose Delete Annotation.

2. Click on the canvas to deselect the link.
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Spotlighting/Highlighting Link Chains

As more and more relationships are added to the canvas, link geometries will continue to be optimized to

minimize crossing and overlapping. Nevertheless, it can sometimes become difficult to discern exactly which

two objects a given link is connecting and to do so quickly.

Similarly, a user may wish to fade all links that don’t have a driving relationship in order to clarify the canvas.

To accomplish these tasks, NetPoint provides a feature for identifying the pre and post objects of a link and

for highlighting driving link chains. Instructions for both are provided.

Steps

Spotlighting Pre/Post Objects

1. With the Select Tool chosen in the toolbar, right-click on the desired link.

2. Choose Spotlight Pre-Object or Spotlight Post-Object.

3. The menu will close and the object will be highlighted accordingly.

4. To restore the canvas, choose Objects > Restore Faded Colors for All Objects from the menu bar.

Highlighting Driving Link Chains

1. Click Objects > Highlight Driving Link Chains from the menu bar.

2. Any links with positive gap (and the objects they connect) will be faded on the canvas.

3. To restore the canvas, choose Objects > Restore Faded Colors for All Objects from the menu bar.
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Treating Redundancies

The simplest case of a redundant link is a start-to-start (SS) or finish-to-finish (FF) link between two activities

that are already finish-to-start (FS) connected. The more complex case of a redundant link is an SS link, FF

link, or no-lag FS link connecting an activity to a successor, which, topology constant, cannot acquire a zero

gap under any combination of durations and lags, because the successor is inevitably driven by a successor

to the activity. The reverse of a redundant link is a valid link.

Redundant links can be hidden, displayed, faded, or shown. You can also tell if a link is redundant by opening

its object property window. In the bottom left, it will display if it’s redundant or valid.

NOTE: Redundancy options through the menu bar are continually checked; rather, these are one-

time operations, which must be done periodically as the schedule evolves.

Steps

All at once

1. Click Objects > Redundant Links from the menu bar.

a. To hide all redundant links on the canvas, click Hide.

b. To show all redundant links on the canvas, click Show.

c. To fade all redundant links on the canvas, click Fade.

d. To highlight all redundant links (i.e. fade all non-redundant links) on the canvas, click Highlight.

One-by-one

1. Click Schedule > Open Layout Manager… from the menu bar.

2. Click the down arrow next to the Statistics icon and choose Links.

a. To spotlight a link on the canvas, select it in the list.

b. To hide a redundant link on the canvas, check the box under the Hide column next to the link.

c. To fade a redundant link on the canvas, check the box under the Fade column next to the link.

d. To delete a redundant link on the canvas, select it in the list and click Delete.

3. Click Save or Close to close the manager. The list will be saved automatically regardless.
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Overriding Logic

Logic is a mode whereby object relationships are enforced. When turned on, NetPoint will heal a negative-gap

link as it forms to preserve the logic of the original relationship. For example, if an activity is moved earlier in

time, NetPoint will move any zero-gap predecessors along with the activity in real-time (until reaching an

actualized object or constraint). Additionally, if the activity has any zero-gap successors, they will be moved

earlier to maintain the zero-gap link (unless they were actualized or constrained).

Likewise, if an activity is moved later than in time, NetPoint will move any zero-gap successors later along

with the activity (until reaching an actualized object or constraint). In this case, however, all predecessors will

remain fixed, even if connected by a zero-gap link, allowing the activities to break open. The same rules also

apply when crashing or extending an activity’s duration. In short, logic mode will propagate a change

throughout a network. Without logic mode on, a change will be localized to the affected object itself.

This process by which predecessors and successors are moved automatically is known as self-healing. By

default, logic mode is turned on but can be turned off if desired. It is helpful to save the plan before using this

option.

NOTE: If a milestone is assigned a calendar that’s different from that of its predecessors or

successors, and the network is pulled backwards, gaps may open up as the chain crosses a

weekend or non-working days, despite logic being on. As such, it is recommended to always keep

milestones on the same calendar as their predecessors/successors.

Steps

1. Click the Logic Mode icon in the toolbar.

2. Adjust the network as desired.

3. When finished, turn Logic Mode back on.

NOTE: Negative-gap links will not be corrected by the system until Logic Mode is turned back

on and one or more of the activities impacting these links are moved (either the predecessor or

successor of the link with negative-gap or an activity which falls on the same path as the link with

negative-gap).

Notes

Logic Loops

NetPoint does not allow an activity to have the same activity as a predecessor and successor (or in the

predecessor and successor chains (for example, activity A linked to activity B, linked to activity A). This is

known as a logic loop. However, it is still possible to open a schedule that was created before loops were

prohibited. In this case, a window will open, the links in the logic loop will be highlighted, and one of the links

must be deleted before proceeding. If multiple loops are present, the window will open for each loop.
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Markup Tools

NetPoint provides a number of non-planning objects for adding extra information to the canvas. Such objects

do not contribute to the logic of the network but are used merely for providing supplemental information.
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Shades

Shades are custom-drawn rectangles of color. They are more flexible than the basic shapes and can be re-

sized more naturally. Shades can be used to create a key or legend, show horizontal lanes, show vertical

windows, or even spotlight an activity or area of the network. Both shapes and shades are added through the

same toolbar icon.

Steps

Adding a Shade

1. Click the Shapes icon on the toolbar.

2. Move the cursor to the desired location.

3. Left-click with the mouse.

4. Without releasing, drag the cursor to create the desired shape.

5. Release the mouse. The Shade Object window will open.

6. To make the shade entirely horizontal or vertical, click the dropdown next to Orientation and choose

accordingly.

7. When finished, click OK.

Locking/Unlocking a Shade

1. Click the Select Tool icon in the toolbar.

2. Double-click the shade or right-click and choose Properties.

3. Click the dropdown next to Behavior and choose Canvas Background to lock or Regular Object to

unlock.

4. When finished, click OK.

NOTE: Even when unlocked, a shade will never be included when dragging to select other objects.

To include one or more shades, first select the other objects, and the press the SHIFT key on the

keyboard, clicking each shade individually.

Rearranging a Shade

1. Click the Select Tool icon in the toolbar.

2. Left-click with the mouse on the desired shade.

3. Click Objects > Arrangement (Shades and Images) from the menu bar.

4. Choose Bring to Front or Send to Back accordingly.

NOTE: Shades can only be moved in front of/behind one another, but not in front of/behind other

shapes or images.

Moving/Resizing a Shade

1. Click the Select Tool icon in the toolbar.

2. Left-click with the mouse on the desired shade.

3. To move, drag the shade without letting go to the new desired location.

4. To resize, move the cursor over any of the black boxes until a double-arrow appears.

a. Left-click with the mouse.

b. Without letting go, drag the box until the new desired size is achieved.
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c. Release the mouse.

NOTE: If a horizontal or vertical shade is resized so that one of the edges no longer spans the entire

width or length of the canvas, the shade’s orientation will automatically adjust to be Variable.

Notes

Shades

Properties

The Properties tab is where general settings are changed.

Field Definition

Orientation

Determines the overall shape of the shade. Variable shades take the exact shape that is

drawn on the canvas. Horizontal shades span the entire width of the canvas, maintaining

their upper and lower edges that are drawn. Vertical shades span the entire height of the

canvas, maintaining the left and right edges that are drawn.

Edge Type

Determines what the edges of the shade correspond to. Snap to Period will align the left

edge and the right edge with the beginning and end of each day (or time unit, when using

PolyTime). Absolute will allow the left edge and right edge to fall in between the

beginning and end of each day (or time unit).

Behavior

Determines whether or not a shade can be selected via left-click on the canvas. Regular

Object enables selection via left-click on the canvas. Canvas background will lock it,

and thus prevent selection.

Formatting

The Formatting section contains controls for changing the look of the object on the canvas.
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Field Definition

Color The color of the shade.
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Text Annotations

Annotations can be used to add text directly to a specific shade. Text can include a note, a comment, or a

custom data field. When you add an annotation to an object, NetPoint is actually just creating a text box that

is permanently tied to its host at the user-selected reference point. As the shade is moved, the annotation

moves too. Only one annotation may be added to a shade at a time. Because annotations can be re-

positioned on the canvas without having to enter Global Edit Mode, it may be desirable to use them as

descriptions.

NOTE: Annotations will also fade with their host shade.

Steps

Adding

1. With the Select Tool chosen in the toolbar, right-click on the desired shade.

2. Choose Add Annotation and then choose a reference point. The cursor will change to the

crosshairs, and the Text Object icon in the toolbar will become pressed.

3. Left-click with the mouse at the desired date, indicated by the text above the crosshairs. (Dragging the

crosshairs will have no consequence on the shape of the text box).

4. Release the mouse. The edit text window will open.

5. Begin typing.

6. When finished, click anywhere outside the text box on the canvas.

NOTE: Once an annotation is added, the chosen anchor point is indicated by a check mark, and it

can be changed at any time by right-clicking and choosing another option.

Modifying Annotation Text

1. With the Select Tool chosen in the toolbar, right-click on the text and choose Edit Text.

2. Edit as desired.

3. When finished, click anywhere outside the text box on the canvas.

Modifying Annotation Font

1. With the Select Tool chosen in the toolbar, double-click the text or right-click and choose

Properties. The Text Object window will open.

2. When finished making changes, click OK.

Hiding Annotations

1. With the Select Tool chosen in the toolbar, right-click on the shade and choose Hide Annotation.

2. Click on the canvas to deselect the shade.

Deleting

1. With the Select Tool chosen in the toolbar, select the text on the canvas and press the Delete key,

or right-click on the host shade and choose Delete Annotation.

2. Click on the canvas to deselect the shade.
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Shapes

Shapes are low-fidelity, black and white symbols for annotating the canvas. These include arrows, brackets,

lines, rectangles, and a circle, for example. Both shapes and shades are added through the same toolbar

icon.

Steps

Adding Shapes

1. Click the down arrow to the right of the Shapes icon and choose the desired shape.

2. Move the cursor to the desired location.

3. Left-click with the mouse.

Locking/Unlocking Shapes

1. Click the Select Tool icon in the toolbar.

2. Right-click on the desired shape.

3. Choose Set as canvas background to lock or unlock accordingly.

NOTE: Even when unlocked, a shape will never be included when dragging to select other objects.

To include one or more shades, first select the other objects, and the press the SHIFT key on the

keyboard, clicking each shade individually.

Rearranging Shapes

1. Click the Select Tool icon in the toolbar.

2. Left-click with the mouse on the desired shape.

3. Click Objects > Arrangement (Shades and Images) from the menu bar.

4. Choose Bring to Front or Send to Back accordingly.

NOTE: Shapes and images can be moved in front of or behind other shapes or images, but not in

front of or behind shades.

Moving/Resizing Shapes

1. Click the Select Tool icon in the toolbar.

2. Left-click with the mouse on the desired shape.

3. To move, drag the shape without letting go to the new desired location.

4. To resize, move the cursor over any of the black boxes until a double-arrow appears.

a. Left-click with the mouse.

b. Without letting go, drag the box until the new desired size is achieved.

c. Release the mouse.

NOTE: To resize a shape asymmetrically, right-click on the shape and uncheck the option Preserve

Aspect Ratio While Resizing before attempting to resize.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 145 of 344



Text Boxes and Notepads

Text boxes are notes that show up directly on the canvas. Notepads are notes that do not show up on the

canvas. Instead, they are represented by an icon and viewed by double-clicking the icon. Text boxes and

notepads are unique in that they can exist on the canvas irrespective of dates. This is useful for creating a

header, footer, or watermark—the text box will not move with the network when the page size is changed or

the canvas is stretched. Only text boxes and notepads possess this capability.

Steps

Adding

1. Click the Text Box icon or Notepad icon from the toolbar.

2. Move the cursor to the desired location or date on the canvas.

3. Left-click with the mouse at the desired location or date, indicated by the text above the crosshairs.

(Dragging the crosshairs will have no consequence on the shape of the text box or notepad).

4. Release the mouse. The edit text window will open.

5. Begin typing.

6. When finished, click anywhere on the canvas outside the text box or notepad.

Modifying Text

1. With the Select Tool chosen in the toolbar, right-click on the text box or notepad and choose Edit

Text.

2. Edit as desired.

3. When finished, click anywhere on the canvas outside the text box or notepad.

Modifying Font

1. With the Select Tool chosen in the toolbar, double-click the text box or notepad or right-click and

choose Properties. The Text Object window will open.

2. When finished making changes, click OK.

Notes

Properties and Formatting

The Properties and Formatting section is where general settings as well as controls for changing the look

are changed.
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Field Definition

Description A text that will show up on the canvas or in the notepad.

Color The color of the text.

Font The font for the text.

Font Style The style of the text.

Font Size The size of the text.

Alignment The alignment of the text.

Positioning
Determines how the text box or notepad will behave when the page size is changed or

the canvas is stretched.

Effects Options for striking or underlining the text.

Positioning

Positioning options determine how the text box or notepad will behave when the page size is changed or the

canvas is stretched. This is useful for creating a header, footer, or watermark.
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Field Definition

Fix

Position

to

Determines whether or not the text object or notepad is tied to dates (like all NetPoint objects), or not. To

create a header, footer, or watermark, choose Canvas Border. The Canvas Border Reference

Point section will become enabled. See below.

Text Box

Reference

Point

Determines which corner of the text box is anchored to a date (or the canvas border, if chosen above). Options

include Top Left, Middle Left, Bottom Left, Top Center, Middle Center, Bottom Center, Top Right, Middle Right,

or Bottom Right. For example, if Dates and TR was chosen for a text box and the page size was changed or

the canvas was stretched, the top right corner would move along to maintain the same date. Likewise, if

additional text was added, the text box would increase down and to the left.

Canvas

Border

Reference

Point

Determines which corner of the canvas the text box is anchored to (only when Canvas border is chosen

above). Options

include Top Left, Middle Left, Bottom Left, Top Center, Middle Center, Bottom Center, Top Right, Middle Right,

or Bottom Right. For example, if Canvas Border and TR was chosen for a text box and the page size was

changed or the canvas was stretched, the distance between the text box and the top right corner of the

schedule would remain fixed. To create a header, set the Text Box Reference Point and the Canvas

Border Reference Point to TC. To create a footer, set the Text Box Reference Point and the Canvas

Border Reference Point to BC. To create a watermark, set the Text Box Reference Point and the Canvas

Border Reference Point to MC.
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Info Objects/Attachments

Info objects are external files or attachments. Adding an info object to the canvas is a way to embed a

document for viewing. The toolbar icon is only for placing info objects onto the canvas. To attach info objects

to activities, milestones, and benchmarks, open their object windows and choose the Info Objects tab.

Steps

Adding iObjects

1. Click the Info Object icon from the toolbar.

2. Move the cursor over the canvas to the desired location.

3. Left-click with the mouse. The Info Object Properties window will open.

4. Click the Browse button. (If you’d like to attach another schedule, first select NetPoint project).

5. Choose a file and click Open.

6. If desired, enter a new Description.

7. Click OK to save and close the Info Object Properties window.

NOTE: If the iObject is copied and linked to the project folder, the filepath shown will still display the

original location, so that you can always remember where the original file was located.

Modifying iObjects

1. With the Select Tool chosen in the toolbar, double-click the desired iObject, or right-click and choose

Properties.

2. Modify as desired.

3. Click OK to save and close the Info Object Properties window.

Opening/Viewing iObjects

1. With the Select Tool chosen in the toolbar, double-click the desired iObject, or right-click and choose

Properties.

2. Click the View button. The file will open outside of NetPoint.

3. When finished, click OK.

NOTE: If the info object is a NetPoint schedule, the current schedule will be saved automatically. If

you don’t wish to save the schedule, click Cancel in the confirmation that opens.

Notes

Properties

Info Objects

The Properties window is where the general settings are changed.
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Field Definition

Source Determines the type of file to attach.

Filepath
Displays the filepath of the original file, regardless of whether or not it’s copied to to the

project folder.

Description A short description for displaying on the canvas. By default, the same as the filename.

Options
Provides the option to copy the file to the project folder so it’s still viewable after zipping

and sending the project.
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Images

Images may be inserted onto the canvas from Windows Explorer or other applications that are an OLE

compatible drag source. The following formats are supported: JPEG (.jpg), PNG, TIFF (.tif), GIF, EMF, and

BMP.

Steps

Adding Images

1. Click File > Insert Image Files from the menu bar (or drag and drop an image into NetPoint directly from

an open Windows Explorer window).

2. Browse for the file and click Open.

Rearranging Images

1. Click the Select Tool icon in the toolbar.

2. Left-click with the mouse on the desired image.

3. Click Objects > Arrangement (Shades and Images) from the menu bar.

4. Choose Bring to Front or Send to Back accordingly.

NOTE: Images can only be moved in front of/behind one another, but not in front of/behind shades

or other shapes.

Moving/Resizing an Image

1. Click the Select Tool icon in the toolbar.

2. Left-click with the mouse on the desired image.

3. To move, drag the image without letting go to the new desired location.

4. To resize, move the cursor over any of the black boxes until a double-arrow appears.

a. Left-click with the mouse.

b. Without letting go, drag the box until the new desired size is achieved.

c. Release the mouse.
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Codes

Codes are for classifying, organizing, or sorting activities, milestones, and benchmarks. A code is made up of

one or more values, or sub-categories, which are associated to objects via assignments. For example, a

project could have a code called “Area” with the values “North,” “South,” “East,” and “West”. An activity could

then be assigned to “North” but not to “Area” itself. (If desired, an activity could be assigned to “North” AND

“South” by choosing the assignment behavior Multiple). Codes are different from a work breakdown structure

since only one level of subcategories is allowed.

Codes can be used as a basis for swimlanes to lay out the network, and they can be exported or imported

from Excel. This chapter includes details for the following:

1. The codes manager

2. Assigning codes

3. Creating swimlanes from codes

4. Exporting/importing codes from Excel
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The Codes Manager

The Codes Manager is a hub for codes functionality, such as defining codes and making assignments. The

window itself is non-modal, meaning that you can navigate to other menus or make modifications on the

canvas without having to close it. Instructions for adding, modifying, and deleting codes are provided below.

Steps

Adding Codes

1. Click Tools > Manage Codes… from the menu bar. The Codes Manager will open.

2. Click the New Code button.

3. Begin typing to rename the code and press ENTER.

4. Double-click the default value and begin typing to rename it.

5. Repeat steps 2-4 as desired.

6. When finished, click Close. Any changes will be automatically saved.

Adding Values

1. With the Codes Manager open, select the desired code (or one of its values).

2. Click the New Value button.

3. Begin typing to rename the code and press ENTER.

4. Repeat steps 2-3 as desired.

5. When finished, click Close. Any changes will be automatically saved.

Modifying Codes/Values

1. Click Tools > Manage Codes… from the menu bar. The Codes Manager will open.

2. To rename a code or value, double-click its name in the list.

3. To modify a code’s assignment behavior, select it in the list and click the Behavior button. The

Advanced Code Properties window will open.

a. Choose accordingly and click Save.

4. When finished, click Close. Any changes will be automatically saved.

NOTE: Once an assignment has been made, the Advanced Code Properties window will still open

but the assignment behavior will not be able to be modified.

Deleting Codes/Values

1. With the Codes Manager open, select the desired code or value in the list.

2. Click the Delete button.

3. When finished, click Close. Any changes will be automatically saved.

NOTE: If an attempt is made to delete a code or value that has already been assigned, the system

will prompt you first.

Sorting, Adding, and Removing Columns

1. Click Tools > Manage Codes… from the menu bar. The Codes Manager will open.

2. To add a column to the list on bottom, right-click on any column.

a. Choose the desired field. The menu will close.

3. Repeat step 2 as desired.
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4. To remove a column from the list on bottom, left-click on the desired column.

a. Without releasing the mouse, drag it up or down until a black “X” appears.

b. Release the mouse.

5. Repeat step 4 as desired.

6. To rearrange a column, left-click on the desired column

a. Without releasing the mouse, drag it left or right until two red arrows appear to indicate where it will

be placed.

b. Release the mouse

7. When finished, click Close. Any changes will be automatically saved.

NOTE: Columns can not be added to or removed from the list on top. Any customization is tied to

the computer (not to the schedule) and will be reset upon re-installation of NetPoint.

Enabling/Disabling Canvas Scroll

1. Click Tools > Open Codes Manager from the menu bar. The Codes Manager will open.

2. Click the List icon in the upper-right corner

3. Click Scroll Canvas with Manager Selections. A checkmark will appear or disappear accordingly.

Notes

Codes Tab

The Codes tab contains two list boxes. The main list on top displays all codes and values; the secondary list

on bottom displays all activities, milestones, and benchmarks. As you click through the list on top, the bottom

list refreshes and shows which objects are assigned to which values. If the item in the list on top is a code,

then the bottom list will aggregate all objects assigned to ALL of its values.

Upper List
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Column Definition

Description The text field for describing the codes and values.

Behavior

Whether or not more than one value of a code can be assigned to the same activity

(Multiple). Default as Single. For more info, see the Advanced Code Properties at the

end of this section.

Lower List

By default, the list on bottom will be automatically ordered with any objects that have been assigned on top.

This can be changed by clicking any of the columns. As you click through the list, the canvas will be scrolled

and the item spotlighted. For more info on how to turn off scrolling, see the steps above.

Column Definition

Assign
Controls whether or not the object is assigned to the value from above. NOTE: This

column will be disabled if the item selected in the list at the top is not a value.

Icon An image representing the type of object.

Description The text field for describing the object.

Abbr.

Description

The text field limited to 48 characters to be displayed on the canvas if the description is

too long

ID The user-entered unique identifier.
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Column Definition

Start Date The date and/or time the object begins.

Finish Date The date and/or time the object will be finished.

Duration The amount of time the activity takes to complete.

Drift The amount of time the object can gain before advancing the start of the project.

Float
The amount of time the object can be delayed before delaying the completion of the

project.

Total Float Drift + Float.

Grid # The gridline or row number that the object is drawn on.

Advanced Code Properties

Assignment Behavior

By default, all codes have an assignment behavior of Single, meaning that only one value of the same code

can be assigned to the same activity. This is required for exporting to P6 or using for swimlanes in the Layout

Manager. If desired, a code can have an assignment behavior of Multiple, meaning that more than one value

of the same code can be assigned to the same activity.

NOTE: Behavior cannot be changed unless all assignments are removed.
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Assigning Codes

A code itself cannot be assigned to an object; only its values, or subcategories can. NetPoint provides a few

different ways to view and make assignments. For example, property windows allow you to see which values

have been assigned to a specific object, and to assign or unassign at the object level. The Codes Manager

allows you to see which objects have been assigned to a different values, and to assign or unassign at the

value level. And finally, the Set Global Properties window allows you to edit assignments in-bulk for multiple

objects. Instructions for each are provided below.

Steps

Values to Objects

1. With the Select Tool chosen in the toolbar, double-click the desired object, or right-click and choose

Properties.

2. Click the Assign button next to Codes. The Assign Codes window opens.

3. Check or uncheck the desired values in the list.

4. When finished, click Save.

5. Click OK.

NOTE: Single-assignment codes are highlighted in green. Multiple-assignment codes are

highlighted in orange. Codes may be clicked to hide or show their values.

Objects to Values

1. Click Tools > Manage Codes from the menu bar.

2. In the list on top, select the desired value.

3. In the list on bottom, check or uncheck the desired objects.

4. When finished, click Close. Any changes will be saved automatically.

NOTE: If an attempt is made to assign an object to another value of the same single-assignment

code, the system will prompt you first.

Selected Objects

1. With the Multi-Object Select Tool chosen in the toolbar, select the desired activities on-by-one on

the canvas. Alternatively, you can click on a blank portion of the canvas and drag a rectangular marquee

box around all the desired activities.

2. Click Objects > Set Properties for Selected Objects from the menu bar.

3. Click the dropdown next to Change Codes and choose a desired code.

4. Click the next dropdown to the right.

a. To assign a value, click twice until a black check appears.

b. To unassign a value, click once until blank.

c. To leave unchanged, click until the minus sign appears. For more info, see Setting Properties with

Check boxes in the Bulk-Editing chapter.

5. Repeat steps 3-4 as desired in either the Activity, Milestone, or Benchmark tabs.

6. When finished, click OK.
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NOTE: When a value of a single-assignment code is checked, all other values of the same code will

be automatically unchecked.
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Creating Swimlanes from Codes

Once assignments have been made, a code can be used to organize a schedule into lanes, with one lane

being created for each of the code’s values. A lane is represented by a horizontal shade extending the entire

width of the canvas, and a name (which may or may not be displayed). The height of the lane is determined

by the number of activities in the lane and if and how they overlap.

Steps

1. See Setting up Swimlanes in the Automated Layouts chapter.
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Exporting/Importing Codes from Excel

Codes can be exported as part of a linked Excel report or as a single standalone spreadsheet. Instructions for

both are provided below

Steps

Exporting the Linked Excel Report

1. Click Tools > Open Codes Manager from the menu bar. The Codes Manager will open.

2. Click the List icon in the upper-right corner of the Codes Manager.

3. Choose Export Default Report to Excel.

NOTE: For a detailed explanation of this report, see Object Data and Tables in the section Exporting

Linked Reports.

Exporting a Standalone Spreadsheet

1. Click Tools > Open Codes Manager from the menu bar. The Codes Manager will open.

2. Right-click on the columns at the top of either list.

3. Choose either Export Visible Rows & Columns or Export All Rows & Columns.
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Costs and Resources

NetPoint allows users to define the resources needed to execute the planned project. A resource can take the

form of a skilled human resource (individuals, groups, or crews), equipment, capital/costs, or material. Cost-

loading a schedule is done through the resource feature. Follow the steps below for instructions.

Any NetPoint plan may be resource-loaded to calculate resource usage, to level resource overages, and to

visually illustrate how resources are used throughout a project. Resources are displayed as a set of

histograms and curves at the bottom of the schedule.

There are four steps related to adding resources: defining the project resources, assigning resources to

activities, adjusting resource display settings, and applying resource limits.
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Defining Resources

To define project resources, click Tools > Manage Resources… from the menu bar. The Project Resources

window opens. To define resources via Excel, see Adding and Modifying Resources via Excel.

Click the New… button.

The Resource Properties window opens, offering several resource fields.

Properties

The Properties section is where basic settings are changed.

Name

The name is a description of the resource. If cost-loading the schedule, enter a name like Budget or Cost.

This field is required.

Category

The category describes the type of resource. All categories have the same functionality in NetPoint, but they

export to external software with different functionality. To choose a category, click the down arrow button to

display a dropdown menu. If cost-loading the schedule, choose Cost.
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Cost/Unit

Cost/unit is the cost of the resource per unit of resource. This field is not currently used in NetPoint, but can

be used when exporting to Excel. If cost-loading the schedule, enter the cost as 1. This field is required.

Displays

The Displays section contains aesthetic properties that can be turned on or off. Control is achieved via the

dropdown.

Plot

Plot refers to whether or not the resource will be displayed in the profile at the bottom of the schedule. This

setting may also be changed directly from the Project Resources window under the plot column by checking

or un-checking the boxes next to the desired resources.

Formatting

The Formatting tab contains aesthetic properties that are not strictly on/off controls, like colors.

Histogram Pattern

A pattern can be added to differentiate between resources. By default, resources display as solid colors. Click

the down arrow button next to Histogram Pattern to display a dropdown menu and then click to select the

desired pattern. This is very effective for distinguishing between different resources.

Color

This field represents the color of the resource in the histogram. By default, it will be gray, but choosing a

unique color is recommended.

To change a color, click the down arrow button anywhere the Color field shows up and choose from the list.

Any colors already used in the schedule will appear. To choose from a palette or define a custom color, select

More.

After clicking More, the custom color palette window will open.

To create a custom color, click in the rainbow color area; the selected color displays below in the Color/Solid

box.
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To select a darker or lighter tone, move the arrow up and down along the vertical slider bar to the right.

Click the Add to Custom Colors button. The new color displays in the Custom Colors area and is ready to

be selected just the same as the basic colors above.

Click OK to apply the color and exit the function.

Once chosen for the first time, any basic or custom color will be displayed in the dropdown list for future

selections.

Color Intensity

This number represents the darkness of the histogram bars. Click the down arrow button to display a

dropdown menu of percentages.

Finalizing Resources

After entering the fields, click the Add button. The new resource will be added to the Project Resources

window and the Resource Properties window will reset.

Additional resources may be defined consecutively by repeating the steps above. When finished, click the

Exit icon to close the Resource Properties window.

NOTE: The Add button must be clicked each time to define a resource before clicking the Exit icon

. Otherwise, the resource will not be saved to the list of Project Resources.
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Modifying an Existing Resource

To modify a resource that has already been defined, click Tools > Manage Resources… from the menu bar.

The Project Resources window opens.

Select the resource from the list of Existing Resources. At this point, the Modify… and Delete buttons

become enabled.

Click the Modify… button.

The Resource Properties window opens, showing the several resource fields filled in according to the

current properties of the resource.

After making any changes, click the Update button and the Resource Properties window will reset.

Click the Exit icon to close the Resource Properties window.

NOTE: The Update button must be clicked before clicking the Exit icon . Otherwise, the change

will not be saved.
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Deleting an Existing Resource

To delete any resource, open the Project Resources window, select a resource from the list of Project

Resources, and click the Delete button. Click the Exit icon to close the Project Resources window.
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Assigning Resources to Activities

Once resources have been defined for the project, the next step is to assign them to specific activities. Each

resource assignment approach requires the activity to be selected and the rate and distribution for the activity

to be entered.

There are two ways to assign resources. The first method described is best for assigning multiple resources

to a single activity. The second method is best for assigning a single resource to multiple activities.

A Single Activity

To assign one or more resources to an activity, double-click on the activity or right-click on the activity and

select Properties….

The Activity Object window opens. Click the Assign… button next to Resources.

The Activity Resource Assignment window opens.

Any resources currently assigned to the activity display in the Assigned Resources list.

The first column lists resources assigned to the activity.
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The second column lists the resource category.

The third column lists the rate.

The fourth column lists the distribution.

The rate refers to the amount or number of the resource required. The distribution refers to how the resource

is used by an activity. Resources may be assigned per time period or duration.

To assign a new resource, click the Choose… button next to Assign New Resources.

The Assign New Resources window will open with a list of all available project resources, excluding those

currently assigned to the activity.

Multiple resources may be assigned at once by clicking the check boxes next to the desired resources. When

finished, click the Assign button to close the window.

The new resource(s) will appear in the Assigned Resources list.

To finish the assignment process, click on the row of the desired resource to enable the rate and distribution

columns.

Enter the amount or number of the resource required in the rate column. In the distribution column, choose

from the dropdown button.

When finished, click the Exit icon .

NOTE: If the rate column is left blank, no assignment will take place.

Multiple Activities

To assign a resource, one at a time, to multiple activities, click Tools > Assign Resources… in the resource

section of the dropdown menu.
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The Global Resource Assignment window opens. Every activity in the schedule will be listed in the box. (If

any objects are selected on the canvas, only those will be listed in the box).

Activities may be ordered by description, ID, start date, finish date, or grid number by selecting from the

Order List By dropdown button.

The first column lists the description of the activities.

The second column lists the activity ID.

The third column lists the rate.

The fourth column lists the distribution.

At the top is a dropdown button containing all the resources in the project. To populate the rate and

distribution columns, click the down arrow button and select the desired resource.

The rate and distribution columns will populate according to the resource selected. Only one resource may be

viewed at a time.

To modify resource assignments, click on the row of the desired activity to enable the rate and distribution

columns.

Enter the amount or number of the resource required in the rate column. In the distribution column, choose

from the dropdown button.
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When finished, click the Exit icon .

NOTE: If the rate column is left blank, no assignment will take place.

Assignment Options

The rate refers to the amount or number of the resource required. The distribution refers to how the resource

is used by an activity. Resources may be assigned per time period or duration.

If PolyTime is enabled, the period corresponds with the schedule’s time unit. For example, if the user has set

the base time unit for the schedule as hours, then the option will be per hour. Otherwise, the period will

always default to days.

NOTE: If any resources have been assigned per period and the schedule time unit is changed, they

may not properly convert. For example, 48 widgets per DAY would become 48 widgets per HOUR

instead of 2 widgets per HOUR.

Per Period

If a resource is assigned per period, the rate of consumption will remain fixed while the total amount will

fluctuate with the activity duration. For example, if activity A has been assigned 10 carpenters per day with a

duration of 10 days, then activity A will require 100 carpenter-days. If the duration is reduced to 5 days,

activity A will still require 10 carpenters per day but the total amount will be reduced to 50 carpenter-days.

Per Duration

If a resource is assigned per duration, the total amount will remain fixed while the rate of consumption will

fluctuate with the activity duration. For example, if activity B has been assigned 10 carpenters per duration

with a duration of 10 days, then activity B will require 1 carpenter per Day. If the duration is reduced to 5 days,

activity B will still require 10 carpenter-days total but the rate of consumption will increase to 2 carpenters per

day.
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Viewing the Resource Profile

Once resources are defined and assigned to activities, the histogram and curves (i.e. resource profile) will be

displayed on the canvas.

Choosing Resources to Display

From the menu bar, click Tools > Manage Resources… from the resource section of the dropdown menu.

The Project Resources window opens.

To control which resources are being displayed, check or uncheck the box under the plot column next to the

desired resource.

NOTE: By default, all resources will be displayed unless the plot is turned off during definition of

that resource.

Removing Activities

Individual activities can be removed from the resource profile by selecting them on the canvas and then

clicking Objects > Set Properties for Selected Objects.

In the Set Global Properties window, under the Displays section, click twice to uncheck the box next to

Resource Profile. When finished, click OK.

The selected activities will be removed from both the histogram and cumulative curve calculations.

Hiding or Showing

To hide the histograms and curves on the canvas, click the Resource Display Mode icon in the toolbar.

Modifying Individual Display Settings

To adjust how the histogram is calculated, how to display the plots, or which plots to display, the resource

display settings may be modified.

Click Tools > Modify Resource Display Settings… from the menu bar. The Resource Display Settings

window opens with a number of fields.

Calculate Histogram By

This field determines the period over which the histogram is distributed. To change it, click the down arrow

button to display a dropdown menu.

The histogram may be calculated based on Daily, Weekly, Monthly, Quarterly or Yearly totals. If PolyTime

is enabled, the histogram may only be calculated based on the schedule time unit or above. For example, if

the schedule time unit is set to months, then only Monthly, Quarterly or Yearly totals are available.
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The histogram will display the resource usage based on the time unit selected.

Position of Plots

The resource profile can be anchored to the bottom of the canvas or slide automatically as the canvas scrolls.

If Auto-Scroll is selected, then the resource profile is always visible. Scrolling to any specific vertical point on

the chart keeps the display of resources constant.

If Fixed at the bottom is selected, then the resource profile always anchors at the bottom of the chart, which

might not be seen in the current displayed page but can be seen by scrolling to the bottom of the chart. This

option will cause the screen display of resources to exactly match with the printed schedule.

Height of Plots

The resource profile can cover as much of the vertical height of the window as desired, with 1 being the

maximum.

Limits

If this box is checked and resource limits have been applied, then any resource which is being consumed

over its allowable maximum will be displayed at the cursor when hovering over the histogram on the canvas.

Plots

There are four available plots: the Histogram plot, the Baseline plot, the Early Dates plot, and the Late

Dates plot.

Click the checkbox under the plot column to display the corresponding graph on the canvas.

NOTE: By default, all graphs are plotted unless turned off.

The Histogram plot displays as a color-coded bar chart.

The Baseline curve displays as a green (cumulative) resource curve.

The Early Dates curve displays as a blue (cumulative) resource curve.
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The Late Dates curve displays as a red (cumulative) resource curve.

Histograms represent the daily consumption of resources (or weekly, monthly, etc. as long as it’s greater

than the schedule’s time unit) for each activity.

Baseline represents the total cumulative consumption of resources for every activity. Baseline can be

calculated as RESn = RESn-1 + Ri, where “n” denotes every day between the planned dates for activity “I” and

Ri denotes the resource daily-rate for activity “I”.

Early Dates represents what the total cumulative consumption of resources would look like if all activities

were on their early-dates.

Late Dates represents what the total cumulative consumption of resources would look like if all activities were

on their late-dates.

Plot Rulers

Each plot has it’s own plot ruler. The plot rulers correspond with the list of plots to the left. They may only be

displayed if their corresponding plot is displayed.

To display a desired ruler, check the corresponding checkbox.

When checked, the increment of the ruler can also be adjusted.

Plot Ruler Increments

To adjust the increment of the plot ruler, enter the increment value desired in the field. This value refers to the

amount of resources between each horizontal line. For example, with an increment of 50, every line

represents an additional 50 resources. If the increment were 25, there would be twice as many ruler lines,

with the difference between each line being only 25.

Reading the Resource Graphs & Curves

When measuring consumption for individual resources, make sure only that resource is displayed in the

resource profile. For example, to measure the cost for a particular schedule, all resource except for Budget

would be turned off. This is most easily done by opening the resource key.

To view the resource key for resources being displayed, choose View > Resource Key…. The Resource

Key window opens, displaying all resources currently on screen.
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To temporarily display or hide a resource’s histogram, uncheck the box to the left of the resource name.

Any displayed resources hidden through the resource key only remain hidden until the Resource Key window

is closed.

At that point, all previously hidden resources will display as set in Tools > Manage Resources….

In the following example, Activity A requires 15 units each day of a combination of resources: about 10 of

those are carpenters and about 5 of those are widgets.

We know this by measuring the height at which each resource coincides with the histogram plot ruler. This is

what the histogram does: it makes it quick and easy to see graphically which resources have been assigned

to which activities and how much are required each day.

In this example, the Activity’s duration has been changed from 10 days to 5 days.
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Note that it still requires 10 carpenters per day even after the duration has changed, which means that it must

have been assigned 10 carpenters per day. The amount of widgets, however, has increased from 5 to 10,

which means that Activity A must have been assigned 50 widgets per duration.

The resource curves show the total cumulative consumption of resources for every activity. For Activity A, the

total consumption is derived by multiplying the histogram (i.e. daily consumption) by the total duration of

Activity A. From example 1 to example 2, you can see that the total consumption drops from 150 to 100 as

the duration decreases.

Add the total consumption for every activity together and the result is the baseline curve, colored green. The

early-dates curve, colored blue, shows what the total consumption would look like if every activity were on its

early-dates. The late-dates curve, colored red, shows what the total consumption would look like if every

activity were on its late dates.
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Limiting Resource Consumption

A limit is an object that restricts how much of a resource may be used at any given time. It is drawn on the

canvas, like an activity, with a certain height and “duration”. The height at which the limit is drawn corresponds

to the maximum value activities can consume of that resource when overlapping with the limit.

After defining resources, assigning resources to activities, and adjusting the resource display settings, the

user may set resource consumption limits for specific time periods. Any resource overage appears as a red

portion of the histogram over each of the displayed resources.

NOTE: A limit can never overlap on the timescale with another limit. As a result, a new limit cannot

be added to a period that already has a limit. The original limit must be deleted, moved, or crashed

in duration before a new one can be drawn.

Adding Limits

First, make sure that at least one resource plot is displayed on the canvas. To set a resource limit, click Tools

> Manage Resources… from the menu bar. The Project Resources window opens.

Click the Limit button. The Resource Limits window opens.

First, select the resource for limit definition by clicking the resource name in the list. The following fields will fill

accordingly. They may be modified or left as default.
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Ceiling

This is the ceiling, or upper bound of the ruler, up to which resource limits may be drawn. It cannot be greater

than 2x the highest daily assignment of that resource to any given activity. In other words, for any given day,

the ceiling cannot be more than twice the requirement for that day. Limits may only be drawn beneath this

ceiling. This is a required field.

Increments

This value refers to the amount of resources between each horizontal line. For convenience, the number of

segments this corresponds to is also displayed below.

Height of Plots

This is how much vertical height the resource profile will cover, with 1 being the maximum.

After modifying the fields or leaving them as default, click Start and the canvas ruler will be laid over the

histograms. This ruler is provided as a system of measurement for drawing.

Click the Limit icon to toggle the cursor between the Select Tool and the crosshairs.

To add a limit object, click and drag the crosshairs, paying attention to both the grid level, or height, as well as

the time period, or duration of the limit object. Limits may be drawn at any height beneath the maximum.

Once placed, the limit start date and end date are shown and the limit quantity displays under the bar.
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Click the Done button to finalize the limit. Additional limits may be assigned by repeating the steps above or

concurrently before finalizing.

In this example a maximum resource limit of 8 is set for a selected resource from 10/1 to 10/30.

If any resource limits were assigned before for the selected resource, the limits corresponding to previous

assignments are shown as purple bars.

Modifying or Deleting Limits

To modify or delete a resource limit, open the Assign Resource Limits window by clicking Tools > Manage

Resources… from the menu bar and clicking the Limit button.

Select the desired resource from the list.

Click the Start button.

At this point, a purple ruler spanning the canvas, or gridlines, will be laid over the histograms as well as any

existing limit objects.

To graphically modify a limit, hover over the end of the bar to access the double arrows or select the bar and

use the arrow keys.

To delete a limit, select it using the Select Tool and click Delete.

When finished, click the Done button.

Displaying Limit Overages

After applying resource limits to selected resources, the out-of-limit portions can be highlighted. To display this

warning, click the Resource Limit Mode icon on the toolbar. Overages are displayed in red.

NOTE: Limit overages will only be displayed when the histogram is plotted in the same time unit as

the schedule. To adjust how the histogram is calculated, see Modifying Individual Display Settings.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 178 of 344

http://pmatechnologies.com/user_guide/building-a-schedule/costs-and-resources/viewing-the-resource-profile-2/#modifying-individual-display-settings


To see specific overages, select Tools > Modify Resource Display Settings… from the resources section of

the dropdown menu.

The Resource Display Settings window opens.

Select the checkbox under limits and click the Save button.

Once this option is selected, it will display current and maximum resource consumption levels when the

mouse cursor moves over any red portion of the Histogram.
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Noting Changes in Consumption

NetPoint has the capability to send email notifications to designated users regarding changes in resource

consumption. These notifications may be sent using HTML (recommended) or in TEXT (provided to allow

reading on devices which do not support HTML formatting).

Defining Email Recipients

Before this feature can be used, a list of potential recipients must be created. For each recipient, a full name,

email address, and email format must be specified.

To define email recipients, click Tools > Manage Notification Recipients… from the menu bar. The Project

Members window opens.

Click the New… button.

The Recipient Info window opens with the following fields.

Name

Enter a person in the Name field. This field is required.

Email Address

NetPoint will only check for a valid format. As a result, be sure to enter the Email Address correctly.

Email Format

This field determines the format of the email message sent. HTML is the recommended format. Text should

only be used when the email client does not support HTML. Choosing Both creates a message containing

both formats, and allows the email client to determine which format should be displayed.
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Text Format

HTML Format

Finalizing Recipients

After entering in the fields, click the Add button. The new recipient will be added to the Project Members

window and the Recipient Info window will reset.

Additional recipients may be defined consecutively by repeating the steps above. When finished, click the

Exit icon to close the Recipient Info window.

NOTE: The Add button must be clicked each time to define a recipient before clicking the Exit icon

. Otherwise, the recipient will not be saved to the List.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 181 of 344



Modifying and Deleting Recipients

To modify a recipient that has already been defined, click Tools > Manage Notification Recipients… from

the menu bar. The Project Members window opens.

Select a recipient from the list of Existing Recipients. At this point, the Modify… and Delete buttons become

enabled.

Click the Modify… button.

The Recipient Info window opens, showing the several info fields filled in accordingly.

After making any changes, click the Update button and the Recipient Info window will reset.

Click the Exit icon to close the Recipient Info window.

NOTE: The Update button must be clicked before clicking the Exit icon . Otherwise, the change

will not be saved.

To delete any recipient, open the Project Members window, select a recipient from the list of Existing

Recipients, and click the Delete button. Click the Exit icon to close the Project Members window.

Assigning Resources to Recipients

Assigning resources to recipients is a way to designate an individual recipient responsible for tracking its

usage.

To assign resources to individual recipients, click Tools > Manage Notification Recipients… from the menu

bar. The Project Members window opens.

Select a recipient and click the Assign… button. The Assign Resources to Recipients window opens.
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All existing resources will be listed, grouped by resource category, even if they haven’t been assigned to any

activities yet. Resource categories may be minimized by clicking their title. Any resources already assigned to

the selected recipient will contain a check.

To assign or unassign resources, check or uncheck their boxes respectively.

When finished, click Save to save and close the window.

Notifying Recipients

To generate and email resource notifications, click Tools > Generate Resource Change emails… from the

menu bar. The Send Notification Emails window opens.

The name and email of the sender will be filled in by default. They may be changed, if desired.

When finished, click Send. All recipients assigned resources will get an email.

The email notifications will show ALL resources assigned to the recipient and their corresponding activities

with the following status options:

No change

There have been no changes since the last email.

Added

Something has been added since the last email. For example:
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• A new resource was assigned to the recipient

• A new activity was assigned a resource which the recipient is responsible for

Deleted

Something has been removed since the last email. For example:

• A resource was unassigned from the recipient

• An activity was unassigned a resource for which the recipient is responsible

• A resource assigned to the recipient was deleted

• An activity was deleted which was assigned a resource for which the recipient was responsible

Changed

Something has changed since the last email. For example:

• An activity has been changed (e.g. its start date, finish date, or duration) which was assigned a resource

for which the recipient is responsible

• An activity’s assignment has changed (e.g. the quantity or distribution) for a resource which the recipient

is responsible
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4) Optimizing a Schedule

NetPoint’s synchronous interface, which allows users to build schedules graphically, makes the user

responsible for the layout of the network. This differs greatly from traditional CPM applications, where the

software authors the layout of the network with little-to-no input from the user. Although this greatly enhances

the presentation of the schedule, such flexibility can become overwhelming when working with larger

schedules, and intimidating when importing schedules from CPM applications, such as Primavera or MS

Project, or from Excel.

In these situations, we recommend running the automated layout engine. This tool greatly enhances the

layout of the schedule by assisting with, or completely taking control of, the placement and layout of objects in

the network. Underneath the hood, dozens of factors are taken into account, including relationships between

activities, link geometries, text and description lengths and positions, and grid and canvas dimensions. For

example, how many finish-to-start chains are there? Which links overlap with other links or activities? Are

descriptions clashing? Answers to answer these questions and more are found in a matter of seconds.

In addition to layout, descriptions and IDs may be repositioned with the Global Edit Mode to minimize

clashing; dates and durations can be adjusted by using the gestural interface to level resources; or the

schedule may be analyzed for integrity or other factors. NetPoint provides a number of tools to facilitate these

processes.
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Layouts

In NetPoint, it’s possible to save multiple potential layouts for the same network or schedule. For example,

you could have one layout where activities are organized based on work trades; another, using lanes based

on WBS categories; and yet another optimized to avoid overlaps using the automated layout engine.

Layouts only store positions of objects, geometries of links, and visibility of text boxes and shades. Any other

changes made to a layout – including the positioning, hiding, or showing of data elements; the adding,

deleting, fading, or colors of objects; or any customization of the canvas – will apply across all layouts.

This section details instructions for the following:

1. Creating/modifying

2. Analyzing links

3. Viewing statistics

4. Exporting lists to Excel
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Creating/Modifying

Layouts are created in the Layout Manager. Once created, a layout cannot be modified and then saved

again. This means any changes made to a layout can only be captured by creating a new layout (which will

automatically be based on what is seen on the canvas), and then deleting the original layout. To assist you,

NetPoint keeps track if any changes were made, and it will prompt you to capture a new layout, when

necessary. If an object is deleted from one layout, it will also be deleted from every layout. If an object is

added to one layout, it’s position will be the same (or as close as possible, depending on the number of grids)

across all layouts.

The Layout Manager itself is non-modal, meaning that you can navigate to other menus or make

modifications on the canvas without having to close it. Columns can be sorted, added and removed in the list

of Layouts tab and Structure tab. Once a layout is created, a separate file with a .NPL extension is also

created within the schedule’s project folder containing supporting data.

Steps

Creating New Layouts

1. Click Schedule > Open Layout Manager from the menu bar.

2. Under the list of Saved Layouts, click the New button. A new layout will be added to the list based on

the network currently being viewed on the canvas.

3. To rename the layout, select it in the list under the Description column and enter a new name.

a. When finished, click outside the layout or hit Enter.

4. Click Save or Close to both save the list of layouts and close the manager.

NOTE: At this time, a layout cannot be updated after it has been saved. To effectively update a

layout, first apply the layout to the canvas that you want to update, make the desired changes on

the canvas, save a new layout (which will automatically be based on the current network), and then

delete the layout you originally wanted to update.

Switching Between Layouts

1. Click Schedule > Open Layout Manager from the menu bar.

2. Choose a layout in the list and click Apply. Alternatively, you may right-click on the layout to apply it.

3. If the layout on the canvas contained unsaved changes, a warning will open. To save click Cancel and

see Creating New Layouts above. Otherwise, click Apply, Discard Changes. The canvas will update

with the network of the selected layout.

4. Click Save or Close to both save the list of layouts and close the manager.

NOTE: When switching between layouts, pay special attention to shades and text boxes, because

they may be positioned optimally in one layout but not make sense in another. For example, if a

layout was ran with lanes, previously created shades and text boxes may clash with the lanes’

shades and text boxes. For this reason, the Layouts tab includes a section at the bottom for turning

on and off shades and text boxes specific to certain layouts.

Deleting Layouts

1. Click Schedule > Open Layout Manager from the menu bar.
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2. Choose a layout in the list and click Delete. After deleting the layout, the canvas will still remain the

same.

3. Click Save or Close to both save the list of layouts and close the manager.

NOTE: Layouts will be deleted without being asked for prior confirmation. To restore a deleted

layout, click the Undo icon in the toolbar immediately following the delete, and then click anywhere

in the Layout Manager to refresh the window.

Managing Shades/Text

1. Click Schedule > Open Layout Manager from the menu bar.

2. Choose a layout in the list. The list on the bottom will refresh.

3. To hide a shade or text object, select it in the list and uncheck the box under Show. The canvas will

update in real-time.

4. To fade a shade or text object, select it in the list and check the box under Fade. The canvas will update

in real-time.

5. Click Save or Close to both save the list of layouts and close the manager.

NOTE: The display of shades and text will be unique to each layout; however, the position in one

layout will apply to all layouts.

Sorting, Adding, and Removing Columns

1. Click Schedule > Open Layout Manager from the menu bar. The Layout Manager will open.

2. To sort by a certain characteristic, click on the column’s label. The list will be sorted from top to bottom,

indicated by an upward-facing arrow.

a. To sort from bottom to top, click on the same column’s label again.

3. To add a column to the list of Saved Layouts, right-click on any column. Items with an arrow next to

them contain more items. When clicked, another menu will open

a. Choose the desired field. A checkmark will appear and the column will be added to the list.

b. To close the menu, click anywhere outside of it.

4. To add a column to any other lists (e.g. in the Structure tab), right-click on any column.

a. Choose a desired field. The menu will close and the column will be added to the lit.

5. To remove a column from the list on bottom, left-click on the desired column.

a. Without releasing the mouse, drag it up or down until a black “X” appears.

b. Release the mouse.

6. To rearrange a column, left-click on the desired column

a. Without releasing the mouse, drag it left or right until two red arrows appear to indicate where it will

be placed.

b. Release the mouse

7. When finished, click Close.

NOTE: Any customization is tied to the computer (not to the schedule) and will be reset upon re-

installation of NetPoint.
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Notes

Layouts Tab

The Layouts tab contains two list boxes.

Upper List

The main list on top displays all saved layouts. As you click through the top list, the bottom list refreshes and

shows which shades and text objects are being displayed in a given layout.

Column Definition

Description A text field for describing the layout.

Layout

Score

A measure of layout optimization. The lower the score, the tidier the layout relative to link/

activity crossings, link overlays, and link length in terms of number of grid crossings. For

more info, see Link Scoring.

Date

Created
The date and time the layout was stored.
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Column Definition

Structure

Criteria

Checkboxes displaying whether or not certain structure criteria was used when the layout

was generated (for automated layouts). For more info, see Locking Objects on Grids and

Setting up Swimlanes.

Selection

Criteria

Displays the type of selection criteria used when the layout was generated (for automated

layouts). For more info, see Selection Tab from Running the Engine.

Placement

Criteria

Displays the type of placement criteria used when the layout was generated (for

automated layouts). For more info, see the Placement Tab sections from Running the

Engine.

Link

Penalty

Criteria

Displays the link penalty values when the layout was generated (for automated and

manual layouts). For more info, see Link Scoring.

Statistics
Displays statistics for when the layout was generated (for automated and manual

layouts). For more info, see Viewing Statistics.

Lower List

The secondary list on bottom displays all user-created shades and text objects on the canvas. As you click

through the list on the bottom, the canvas will scroll to their location and they will spotlighted in yellow.

Column Definition

Show Controls whether or not the object will be displayed on the canvas.

Fade Controls whether or not the object is faded on the canvas.

Type Displays whether the object is a shade or text box.

Description Displays a description of the object, and the text (if it’s a text box).

Grid # The grid number or row the object is located on.

Start Date The date the object is located at on the canvas.

Color The color of the object (shades only).
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Analyzing Links

If activities and other objects are the backbone of the schedule, then the links can be said to be the muscles –

they’re the ones that make everything possible, including float calculations. Analyzing the health of your links

can be done in the Links tab of the Layout Manager. For example, links that are redundant can be viewed,

hidden, or faded on the canvas, and links that are convoluted (i.e. intersecting or overlapping) can be

identified and filtered for. Instructions for both are provided below.

Steps

Redundant Links

1. Click Schedule > Open Layout Manager from the menu bar.

2. To choose a different layout, select it in the list and click Apply.

1. If the layout on the canvas contained unsaved changes, a warning will open. To save, click Cancel and

see Creating New Layouts. Otherwise, click Apply, Discard Changes. The canvas will update with the

network of the selected layout.

3. Choose the Links tab.

a. To spotlight a link on the canvas, select it in the list.

b. To hide a redundant link on the canvas, check the box under the Hide column next to the link.

c. To fade a redundant link on the canvas, check the box under the Fade column next to the link.

d. To delete a redundant link on the canvas, select it in the list and click Delete.

4. Click Save or Close to both save and close the manager.

NOTE: Deleting a link is permanent to the schedule and will apply across all layouts.

Convoluted Links

1. Click Schedule > Open Layout Manager… from the menu bar.

2. To choose a different layout, select it in the list and click Apply.

1. If the layout on the canvas contained unsaved changes, a warning will open. To save, click Cancel and

see Creating New Layouts. Otherwise, click Apply, Discard Changes. The canvas will update with the

network of the selected layout.

3. Click the Links tab.

4. Click the down arrow button next to Viewing and choose Convoluted Links.

5. Click the up and down arrows next to Filter our scores < to filter the list of convoluted links.

a. To spotlight a link on the canvas, select it in the list.

6. Click Save to close the manager. Otherwise, any threshold entered will not be saved.

Notes

Links Tab

Redundant Links

Any and all redundant links will show up in the list. As links are selected in the list, the canvas will scroll to

their location and they will spotlighted in yellow. For more info, see Treating Redundancies.
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Column Definition

Hide Controls whether or not to hide or show the link on the canvas.

Fade Controls whether or not to fade the link on the canvas

Description A description of the link defined by the object it’s emanating from and merging into.

Convoluted Links

A convoluted link is simply a link with a geometry that yields a high or less-than-perfect score. As links are

selected in the list, the canvas will scroll to their location and they will spotlighted in yellow. The Filter out

scores will determine which links show up in the list below. Any links with a score above the threshold will

show up. By default, the threshold is equal to 0, which means all links whether convoluted or not will show up

at first. As the number increases, the number of links displayed will likely decrease. For more info, see Link

Scoring. The value set here for the threshold will also be used in the Statistics tab.
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Column Definition

ID A number used internally to identify the link.

Predecessor The object the link emanates from.

Successor The object the link merges into.

Type

A label for categorizing links. The designation is for supplemental information; it has no

bearing on actual schedule logic or calculations. For more info, see the Logic Types

section in Creating FS Links.

Lag A way to enforce a minimum gap. For more info, see Adding Link Lags.

Geometry

The physical shape of the link. A link can bend vertically, horizontally, and diagonally, in

eight different combinations. NetPoint makes use of a scoring system to identify the best

possible geometry for a link. For more information, see Link Geometries.
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Column Definition

Score

A point value based on how many grids the link passes through, or if it crosses over

other objects or overlaps with other links, for example. For more information on scoring,

see Link Scoring.

Global Displays

Any changes made here will ONLY apply to the layout on the canvas currently being viewed, NOT to any

previously stored layouts.

Column Definition

Hide links with gap

more than (Days)
An option for hiding links based on how much gap they have.

Links between lanes
An option for hiding, showing, or fading links that span between swim lanes.

For more info, see Setting up Swimlanes.
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Viewing Statistics

Whether or not one layout is “better” than another is oftentimes subjective. With the introduction of layouts, a

number of new statistics are available to help you objectively analyze different aspects of your schedule. For

example, the number of activities divided by the number of weeks can tell you how busy your schedule is; and

the number of links divided by the number of activities can tell you how dense the logic is. Characteristics like

these and other “vital-signs” can be found in the Statistics tab of the Layout Manager. Instructions are

provided below.

Steps

1. Click Schedule > Open Layout Manager from the menu bar.

2. To choose a different layout, select it in the list and click Apply.

a. If the layout on the canvas contained unsaved changes, a warning will open. To save,

click Cancel and see Creating New Layouts. Otherwise, click Apply, Discard Changes. The canvas

will update with the network of the selected layout

3. Choose the Statistics tab.

4. Click Save or Close to both save and close the manager.
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Notes

Statistics

The following will always correspond to the layout currently being viewed on the canvas.

Sum Link

Score
The sum of the link scores for all links in the network. For more info, see Setting Defaults.

Number of

Redundant

Links

The number of redundant links in the network. For more info, see Treating Redundancies.

Number of

Convoluted

Links

The number of links with a score beneath the indicated threshold. By default, the

threshold will be set at 25 until it’s set in the Links view, at which point whatever threshold

was last used there will also be used here. For more info, see Setting Defaults.

Number of

Active

Grids

The number of grids with objects placed on them by the layout engine.
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Net Sum

Link Score

The sum of the link scores for all links in the network excluding links between lanes if

present. For more info, see Setting Defaults.

Mean Link

Score

The sum of the link scores for all links in the network divided by the number of links in the

network. For more info, see Setting Defaults.

Mean

Activity

Score

The sum of the activity scores for all activities in the network divided by the number of

activities in the network. For more info, see Setting Defaults.

Logic

Index

The number of valid links between activities (i.e. excluding redundant links) divided by the

total number of activities.

Average

Timeline

Density

The number of activities divided by the number of weeks (for a schedule in days) from the

first object to the last object in the schedule. For a schedule in hours, it would be per day;

for a schedule in months, it would be per quarter; etc.).

2

percentile

activity

duration

The value which 2% of all activities have a duration less than or equal to. The width of

these activities on the canvas can be set in the Dimensions view of the Placement tab.

100th

Percentile

Period

Density

The highest number of activities scheduled per week (for a schedule in days). For a

schedule in hours, it would be per day; for a schedule in months, it would be per quarter;

etc.).
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Exporting Lists to Excel

Any list in the Layout Manager can be exported as a single standalone spreadsheet. Instructions provided

below

Steps

Exporting a Standalone Spreadsheet

1. Click Schedule > Open Layout Manager from the menu bar. The Layout Manager will open.

2. Choose the desired tab by clicking its icon.

3. Right-click the columns at the top of any list.

4. Choose either Export Visible Rows & Columns or Export All Rows & Columns.
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Automated Layouts

Automated layouts are generated by running a schedule through the layout engine. Each time the layout

engine is run, a new layout is automatically created and stored in the Layouts tab of the Layout Manager,

alongside any other manual or automated layouts.

Running the layout engine can be as complex or as simple as needed. If you use the default or most recently

saved settings, it can be run with just the click of a button. This may be useful for a novice user or for an

already-optimized schedule, where, over the course of the schedule life-cycle, a particular strategy has

proven to yield a consistently desirable layout. Alternatively, a variety of settings can be adjusted in

the Layout Manager, isolating the effects of the minutest of changes and giving advanced users even greater

control over the resulting layouts.

Any settings that are saved using the Save button will be shared across schedules and across sessions of

NetPoint.

NOTE: The time it takes to run an automated layout depends on the number of objects (activities,

links, milestones, etc.), the computer’s processor/clock speed, how much RAM it has, and the

settings in the Layout Manager. Once a schedule reaches 250 objects, we suggest tweaking some of

these settings to reduce the time required. An “Out of Memory” error may occur on schedules with

over 2100 objects (700 activities + 1400 links). This should be considered an approximate upper

limit. For more details, see Running On Large Schedules.

This section details instructions for the following:

1. Running the engine

2. Locking objects on grids

3. Setting up swimlanes

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 199 of 344

http://pmatechnologies.com/user_guide/optimizing-a-schedule/automated-layouts/running-the-engine/#running-on-large-schedules


Running the Engine

When you run an automated layout, every object in the schedule is analyzed, indexed, and placed back on

the canvas. This analysis begins by identifying clusters of activities and other objects within the network

based on certain characteristics. For example, objects may be grouped by float chains, step chains, or logic

steps (defined below). Once all of the objects in the network have been identified, they’re then indexed and

sorted. To determine their order, a series of rules for breaking ties is used. For example, if three step-chains

have been identified, the chain with the most activities will be ordered first. In the case that two of them share

the same number of activities, then the chain with the longest duration will be ordered first, and so on. These

settings are located in the Selection tab.

After all objects have been analyzed and indexed, they will start to placed back on the canvas. For example,

placement can begin at the top or in the middle of the canvas, and grids can be added to make more space.

These settings are located in the Rules view of the Placement tab. Minimum dimensions can also be

changed to affect how and when activities are placed next to one another, and these settings are located in

the Thresholds view of the Placement tab.

There are actually two different processes that can be performed: a “run” and a “fine-tune,” depending on the

state of the schedule. “Running” will completely rearrange the network, using the settings from

the Structure, Selection, Placement, and Penalties tabs to improve the schedule’s layout. This is best for

schedules that are being imported from another application or where a significant overhaul of the layout is

desired. ”Fine-tuning” will only make small adjustments based on activity and link scores from

the Placement and Penalties tabs. This is typically best when attention has already been given to the layout,

or when an automated layout has already been run before. If the resulting fine-tune cannot improve the layout

(i.e. increases the layout score by more than 5%), the fine-tune will be canceled and the canvas will revert to

the previous layout.

NOTE: Whether “running” or “fine-tuning,” all activities and planning objects have the potential to

be rearranged unless they have been assigned to a lane, locked on a grid, or actualized left of the

data date. For more info, see Setting Up Swimlanes and Actualizing Objects.

Steps

Run from Default Settings

1. Click Schedule > Run Automated Layout from the menu bar, or click the Run Automated Layout

icon in the toolbar.

2. The canvas will update and a new layout will automatically be saved in the Layouts tab of the Layout

Manager.

Run from Custom Settings

1. Click Schedule > Open Layout Manager from the menu bar.

2. Click through the Structure, Selection, and Placement tabs to modify the available settings.

3. When ready, click Run.

4. The canvas will update, the manager will switch to the Layouts tab, and a new layout will automatically

be saved.

5. To save the settings for future use, click Save. Setting that are not unique to the schedule will carry

through when accessed from other schedules or across sessions. Otherwise, click Close.
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Fine-Tune Only

1. Click Schedule > Open Layout Manager from the menu bar.

2. Click through the Placement and Penalties tabs to modify the available settings.

3. Click Fine-Tune.

4. The canvas will update, the manager will switch to the Layouts tab, and a new layout will automatically

be saved.

5. To save the settings for future use, click Save. Setting that are not unique to the schedule will carry

through when accessed from other schedules or across sessions. Otherwise, click Close.

NOTE: To fine-tune a layout with swim lanes, make sure > Always Fine-Tune After Running is

selected in the Schedule menu. Otherwise, clicking Fine-Tune will not maintain lane configurations.

Running On Large Schedules (>250 activities, links, milestones, etc.)

1. Click Schedule from the menu bar and make sure Animate When Running and Always Fine Tune

After Running are turned off (they should not have a check next to them).

2. Choose Open Layout Manager from the Schedule menu, click the Structure tab, and make sure lanes

are turned off (the box next to Derive Lanes from should be unchecked).

3. Click the Placement tab.

4. Next to Start at, make sure Halfway Grid is chosen.

5. Next to Layout Spacing, make sure Single is chosen.

6. Click Run.

7. OPTIONAL: If you want to run with swim lanes, click the Structure tab, check the box next to Derive

Lanes from, and click Run again.

8. Click Fine-Tune. Note: this step may take a few minutes with overly large schedules.

9. In the Layouts tab, click New.

10. Select it in the list and type a new name.

11. To save the settings for future use, click Save. Setting that are not unique to the schedule will carry

through when accessed from other schedules or across sessions. Otherwise, click Close.

Resetting the Layout Manager

1. Click Schedule > Layout Manager Settings from the menu bar.

2. Choose Load Last Saved to reset to the last saved state or Load Defaults to reset to the default state.

NOTE: All settings that are not unique to the schedule will be reset; notable exclusions include lists,

such as layouts, codes, links, or statistics, for example.
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Notes

Selection Tab

Select Activities by

Objects may be identified and clustered based on float chains, step chains, or logic steps.

Float

Chains

A float chain is a path of activities through the network where the total float of each successor

is the same as the total float of its immediate predecessor (the critical path is an example of a

float chain whose activities share a total float of zero). When chosen, a chain of activities who

share the same total float with one another is selected and placed (for example, the critical

path), followed by another chain of activities who share the same total float with one another,

and so on. Choose this option when you want your layout to be organized in terms of

float values.

Step

Chains

A step chain is a path of activities through the network where the logic step of each successor

is exactly one higher than its immediate predecessor. When chosen, a chain of activities with

consecutive logic steps is selected and placed, starting with an object that has a logic step of

1, followed by an object with a logic step or 2, and so on, ending with an object that has the

highest logic step. Once complete, another chain of activities with consecutive logic steps is
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identified in a similar manner, and so on. Choose this option when you want your layout

to be organized in terms of relationships.

Logic

Step

A logic step is the numbered position of an activity in a logic chain (if in multiple logic chains,

the highest of those numbers). For example, any activity in the network that is connected to

the project start will have a logic step of 1, regardless of how late in time the activity is

scheduled. When chosen, first all the activities with a logic step of 1 are selected and placed,

then all the activities with a logic step of 2, and so on. Choose this option when you want

your layout to be drawn from left to right.

FS

Strings

An FS string is path of three or more activities (either a float chain or step chain) that are

connected in a finish-to-start relationship (each intermediate activity having only one

predecessor and one successor). FS Strings can be chosen if either Float Chains or Step

Chains is chosen. When selected, the chains containing FS strings are sorted after all the

chains without FS strings but before individual objects are sorted. Check this option when

you want FS strings to be drawn on the outside (top and bottom) of the network.

Selection Order

After clusters have been identified, they are ordered based on the following rules, which can be turned on or

off or can be rearranged by clicking and dragging them up or down in the list. In any case, the clusters will

always be ordered first followed by individual objects. By default, these rules have already been configured to

yield the best result for the majority of schedules. It’s difficult to suggest when to apply or not apply certain

rules, or to change the direction, due to the individuality of every schedule. We suggest using trial and error

until you are satisfied with the layout. The following options are available for both float chains and step

chains. The direction can be reversed by clicking in the cell and using the drop-down button.

Number of Locked

Activities
The number of locked activities in the chain.

Number of

Activities
The number of activities in the chain.

Total Float* The total float of the chain. *Only available for float chains.

Chain Duration The length of the chain in calendar days.

Logic Index
The number of links between activities (excluding redundant links) divided by the

total number of activities in the chain.

Start Date The start date of the earliest activity in the chain.

Finish Date The finish date of the last activity in the chain.
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The following options are available for logic steps. Since logic steps are not chains, ordering is applied on the

individual object level.

Start Date The start date of the object.

Duration The duration of the object.

Finish Date The finish date of the object.

Placement Tab (Rules View)

Grid Placement

After the starting grid is utilized, whichever grid yields the lowest score for that object will always be

chosen. In the case that no single grid yields the lowest score, the settings for Proceed and Choose active

over inactive will be used as tiebreakers. For more info on activity and link scores, see Link Scoring.

Start at

The starting grid is where the first object (and any subsequent objects with no

predecessors) will be placed when the layout engine is run. You can choose the top,

middle, or bottom grid of the canvas. Choose the top grid if you want most milestones

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 204 of 344

http://pmatechnologies.com/user_guide/building-a-schedule/setting-defaults-2/#link-scoring


and benchmarks toward the top, and a generally top-heavy layout; the halfway grid if

you want most milestones and benchmarks toward the middle, and an evenly

balanced layout; and the bottom grid if you want most milestones and benchmarks

toward the bottom, and a generally bottom-heavy layout. For large schedules or to

reduce processing time, choose Top. For more details, see Running On Large

Schedules.

Proceed

If an object cannot be placed on the grid with the lowest score – for example, if the

preceding relationship is start-to-start or finish-to-finish; or, if there is already an object or

link in that location; or, if the grid above and below yield the same score – the direction will

come into play. In these cases, you can choose to proceed up first or down first. Choose

Up Before Down when starting at the bottom grid.

Choose

Active

Over

Inactive

An active grid is one that already contains an object. An inactive grid is one that is totally

empty. If an object cannot be placed on the grid with the lowest score, objects will be

placed on grids which already have objects (active) by default. Uncheck this rule if you

have tight grid spacing or layout spacing to create a taller layout.

Replenish

inactive

grids

when

used

During processing, inactive grids are added in-between active grids. In the event that an

object gets placed on one of these inactive grids, two inactive grids are added to maintain

the proper spacing, so long as the checkbox is selected.

Aesthetic

The following settings are visual only:

Layout

Spacing

Layout Spacing will determine how many inactive (empty) grids are added in-between

active grids after processing. Regardless of what’s chosen (Single, Double, or Triple),

one and only one grid will be added during processing. Single spacing will result in a

higher layout score. For more info, see Link Scoring. Increase this setting if you want

more padding in between rows of activities or a taller layout. For large schedules

or to reduce processing time, choose Single. For more details, see Running On

Large Schedules.

Stack

activity

descriptions

if needed

By default, activity descriptions will be stacked if they begin clashing with other text or

objects. Uncheck this rule if you have tight grid spacing or layout spacing and

prefer to shorten descriptions manually where necessary.

Allow links

with a D leg

By default, diagonal links will be used when necessary. This setting also applies when

creating links in NetPoint. Uncheck this rule if you do not want any diagonal links.

Hide links

with gap >

Controls whether or not long links (links spanning a wide period of time) will be hidden,

depending on how many days of gap they have. Check this rule if you do not want
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links spanning a wide period of time to show up, and adjust the threshold

accordingly.

Show links

between

lanes

Controls whether or not tall links (links spanning multiple lanes) will be displayed,

hidden, or faded. Only relevant if the layout is being run with lanes activated.

Include

redundant

links in link

score

calculations

By default, redundant links will not be included in link score calculations, and will

therefore not affect the resulting layout. Check this rule if you want the position and

geometry of redundant links to be taken into account when laying out the

network. For more info, see Treating Redundancies

Placement Tab (Thresholds View)

Grid Spacing

Value

(inches)

Grid spacing is the distance in inches between gridlines (by default, 0.35 inches). Increase

this number if you want more padding in between rows of objects or a taller layout.
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Zero-gap Linked Activities

Allow

on

same

grid…

If the durations of two zero-gap linked activities are too small, it can be difficult to tell where one

activity begins and another one ends (when they’re on the same grid). The Zero-gap Linked

Activities thresholds are for deciding when such activities can be placed on the same

grid. Increase these numbers if you want to increase the frequency with which zero-gap

linked activities are placed on separate gridlines.

Non-linked Activities

Allow

on

same

grid…

If non-linked activities are too close to one another on the same grid such that any link between

them wouldn’t be visible, it could appear as though they were linked. The Non-Linked

Activities threshold is for deciding what distance is too little for placing such activities on the

same grid. Increase this number if you want more space between non-linked activities.

Displays & Formatting

Add

page

tiles…

Controls whether or not page tiling will be added (but not removed) to ensure that 98% of all

activities are at least the width specified, when zoom and stretch are 100%. Decrease this

number if you have activities with extremely short and extremely long durations

together in the same schedule (e.g. 1 day activities with 100 day activities).

Max

width…

If milestone and benchmark descriptions exceed the Max. width for milestone & benchmark

names, additional lines will be added accordingly. Decrease this number if your milestones

and benchmarks have long descriptions and are close to other objects.

Automated Layouts Menu

The automated layouts menu is located in both the Schedule menu as well as underneath the Run

Automated Layout icon in the toolbar.

Open

Layout

Manager

This menu item opens the Layout Manager to the Layouts tab.

Animate

When

Running

If selected, the layout will be animated as it’s redrawn in real-time. For large schedules

or to reduce processing time, make sure it is turned off. For more details, see

Running On Large Schedules.

Always

Fine Tune

By default, “running” and “fine-tuning” are applied separately, and the results are stored in

different layouts.t. If selected, running will always include a fine-tune, and the results will

be saved in a single layout in the Layouts tab. For large schedules or to reduce
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After

Running

processing time, make sure it is turned off. For more details, see Running On Large

Schedules.

Run

Automated

Layout

Select to start processing.

Layout

Manager

Settings

Within the Layout Manager, there’s a difference between “lists” and “settings”. In short,

“lists” are schedule-specific (except for the one in the Selection tab), whereas “settings”

can carry through from one project to another. If Load Defaults is selected, all

“settings” will reset to their states when NetPoint was installed. If Load Last Saved is

selected, all “settings” will reset to their states when the manager was most recently

saved. To load the settings from a previously run layout, see Resetting The Layout

Manager.
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Locking Relative Positions

Locking is a way to freeze an object relative to other objects. For example, if you have activity A locked on

grid 1, B locked on grid 10, and C locked on grid 20, then A will be above B, and B will be above C, but not

necessarily on the same gridlines. If lanes are used and an activity is both locked and assigned to a lane, the

lane assignment will override the locking. By default, actualized objects are locked, but this can be

deselected.

Locking can be done on an activity-by-activity basis, or it can be done automatically by entering a threshold

and locking all of the activities whose activity scores fall below that threshold. All activities and planning

objects will be rearranged unless they have been assigned to a lane or locked on their grids. Instructions for

locking individual activities and for locking multiple activities are provided below. For more info on lanes, see

Setting Up Swimlanes.

Steps

Individual Objects

1. Click Schedule > Open Layout Manager from the menu bar.

2. Click the arrow to the right of the Structure tab, and choose Locking.

3. Check the box next to On. NOTE: If the box is un-checked, the most recent locking setup will be

stored internally for future use.

4. To lock an object, check the box next to it under the Lock column.

5. To apply immediately, see Running the Engine. Otherwise, click Save to store the changes.

Multiple Activities

1. Click Schedule > Open Layout Manager from the menu bar.

2. Click the arrow to the right of the Structure tab, and choose Locking.

3. Check the box next to On. NOTE: If the box is un-checked, the most recent locking setup will be

stored internally for future use.

4. Check the box next to Lock All.

5. Type a number and press the TAB key on your keyboard (or click the up and down arrows with the

mouse). All activities whose score is less than this value will be locked (milestone and benchmarks will

not be included with this option). NOTE: If any objects were locked individually, they will be

combined with the activities locked here.

6. To apply immediately, see Running the Engine. Otherwise, click Save to store the changes.
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Notes

Locking View

The locking view consists of two list boxes.

Upper List

The main list on top shows all activities, delays, milestones, benchmarks, and hammocks in the schedule. As

you click through the list on the top, the canvas will scroll to their location and they will spotlighted in

yellow. As any of the objects from the list above are locked, they are copied to the list below.

Column Definition

Type The type of object.

Lock Controls whether or not the object will be locked to its respective grid.

Score

The sum of the link scores for every valid (not redundant) link connected to that activity

divided by the number of links connected to that activity. For more information on scoring,

see Link Scoring.
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Column Definition

Description The text field for describing the activity.

Abbr.

Description

A text field limited to 48 characters to be displayed on the canvas if the description is too

long.

Grid The gridline or row number that the object is drawn on.

Start Date The date the object begins.

Duration The amount of time the object takes to complete.

Finish Date The date and/or time the object will be finished.

Lower List

As you click through the list on the bottom, the canvas will scroll to their location and they will spotlighted in

yellow.

Column Definition

Type The type of object.

Score

The sum of the link scores for every valid (not redundant) link connected to that activity

divided by the number of links connected to that activity. For more information on scoring,

see Link Scoring.

Description The text field for describing the activity.

Abbr.

Description

A text field limited to 48 characters to be displayed on the canvas if the description is too

long.

Grid The gridline or row number that the object is drawn on.

Start Date The date the object begins.

Duration The amount of time the object takes to complete.

Finish Date The date and/or time the object will be finished.

Reason
The reason the object was locked, whether by the user, from the score, or because it was

actualized.
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Setting up Swimlanes

Lanes are a way to organize activities visually on the canvas. Lanes can be based on codes and their values

or on work breakdown structure headings. Once applied, a lane is represented by a horizontal shade

extending the entire width of the canvas, and a name (which may or may not be displayed). The height of the

lane is determined by the number of activities in the lane and if and how they overlap.

To create lanes from a work breakdown structure, the schedule must have been imported from P6 and the

WBS defined prior. For more info, see the notes at the end of this section. To create lanes from codes, you

must have a single-assignment code and its values defined and activities assigned to them. The values will

become lanes, and the activities assigned to them will be placed accordingly. For more info on creating and

assigning codes and values, see the Codes chapter.

NOTE: For large schedules or to reduce processing time, make sure lanes are turned off. For more

details, see Running On Large Schedules of the Running Automated Layouts section.

Steps

Activating Lanes

1. Click Schedule > Open Layout Manager from the menu bar and choose the Structure tab.

2. Check the box next to Derive Lanes from. Codes will be chosen by default.

3. To create lanes from WBS levels, click the dropdown on the left and choose WBS.

4. Click the dropdown on the right, and choose the desired code (or the level, for WBS).

5. To exclude a value from having a lane created for it, un-check the box next to it under the I/O column.

6. Click Run. For more info, see Running the Engine.

NOTE: After running, all shades and text boxes will be hidden automatically. To unhide, see

Managing Shades/Text of the Working with Layouts section.

Customizing Lanes

1. Click Schedule > Open Layout Manager from the menu bar and choose the Structure tab.

2. Click the Configure button. The Lane Properties window will open.

a. Adjust the properties and click the Update button.

b. If desired, select another lane in the Layout Manager to refresh the Lane Properties window.

c. Repeat steps a and b.

d. When finished, click the Exit icon in the upper right.

3. To change where a lane will show up, click on its row anywhere in the list.

a. Keeping the mouse depressed move the row up or down. The new location will be indicated by a red

line and two arrows.

b. When finished, release the mouse.

4. Click Run.

5. When satisfied, click Close. WARNING: Any changes made in the Lanes view and Lane Properties

window will reset after changing to another tab or closing the Layout Manager, respectively (even

if using the Save button).
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Notes

Lanes View

The Lanes view consists of two list boxes.

Upper List

The main list on top shows a preview of the lanes in the order that they’ll appear on the canvas. Each row

represents a lane, and the background color of the row corresponds to the color of the lane on the canvas. As

you click through the top list, the secondary list on bottom refreshes to show which activities are assigned to

the selected lane (value).

Column Definition

I/O Controls whether or not a lane will be created from the value.

Value The description of the lane, as inherited from the value.

Title A customizable description of the lane that can be displayed on the canvas.
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Lower List

The lower list show which objects are assigned to each lane. As you click through the list, the canvas will

scroll to the location of each object and it will be spotlighted in yellow.

Column Definition

Icon An image representing the type of object.

Description The text field for describing the object.

Abbr.

Description

The text field limited to 48 characters to be displayed on the canvas if the description

is too long

ID The user-entered unique identifier.

Start Date The date and/or time the object begins.

Duration The amount of time the activity takes to complete.

Finish Date The date and/or time the object will be finished.

Lane Properties

Field Definition

Title

The description for the lane. By default, it inherits the same value that was entered in the

structure tab. It can be hidden or displayed on the canvas as desired. To adjust the font or

formatting of multiple titles at a time, use the Text tab of the Set Global Properties window.

For more info, see Bulk-Editing Objects.

Shade

Color

The color that the lane will display as. For codes, lanes are assigned a global scheme of

alternating yellow and white shades but can be customized on an individual basis by un-
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Field Definition

checking Use Global Scheme. For WBS nodes, lanes are assigned a default color based

on their level, up to level 6. Any levels past 6 will be white.

Assigned

Objects

If checked, the color will apply to all activities assigned to this lane with a total float value

less than or equal to the criticality threshold.

Displays
The title can be toggled on or off the canvas. When checked, it shows up as a text object

toward the top of the lane along the left edge of the canvas

NOTE: Any changes made here will NOT apply in real-time or to previously stored layouts, only to

those created in the future after the layout engine is re-run.

Global Swim Lane Settings

Unlike the settings in the Lane Properties window which apply to individual lanes, these options apply to all

lanes globally and are stored uniquely for each schedule.

Lane Color (Codes)

If a lane’s shade color is selected to use the global scheme in the Lane Properties window, it’s color will be

determined here. If it’s the first lane on top, third, fifth, etc., it is an odd-numbered lane; if it is the second from

the top, fourth, sixth, etc., it is an even-numbered lane.
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Lane Color (WBS)

If using a WBS hierarchy, the lane’s shade color will be determined slightly differently. Instead of even and

odd, colors are assigned to each level up to 6. Any levels past 6 will be white. Colors can be reset for each

level by clicking the dropdown and choosing the color under Default.

NOTE: Any changes made here will NOT apply in real-time or to previously stored layouts, only to

those generated in the future after the layout engine is re-run.

Creating Lanes from WBS levels

When creating lanes from a work breakdown structure, you can choose which level to use as the bases for

the lanes. This does NOT mean that ONLY the activities assigned to that level will be drawn but rather that

any activities assigned to a lower level will also be drawn in their higher visible level. For example, if choosing

Level 1, any activities assigned to Level 2 or below will show up in their corresponding level 1’s. With the

following WBS, for example:

1.0 Lincoln Hospital

1.1 Design and Engineering

1.2 Interior Finishes

1.2.1 Coverings

1.2.2 Paint

1.3 Foundations

A lane would be created for Design and Engineering, Interior Finishes, and Foundations. Any activities

assigned to Coverings or Paint would end up under Interior Finishes.

If choosing Level 2, a lane would be created for Design and Engineering, Interior Finishes, Coverings, Paint,

and Foundations. In this case, the lane for Interior Finishes could be empty if every activity were actually

designated at the second level.
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Locking Schedule Dates

To prevent unintentional changes to the horizontal positions of objects on the canvas, the Date Lock mode

can be used. Date Lock mode prevents any mouse-based changes to horizontal positions of objects on the

canvas; however, if need be, dates can still be changed via property boxes, and all objects can still be moved

to different grids.

Steps

1. Click the down arrow to the right of the Change Display Mode icon from the toolbar.

2. Choose Date Lock from the menu.

NOTE: Pressing the ALT key while moving an object will temporarily enable Date Lock.
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Criticality

In GPM (and CPM), the critical path is the longest continuous path to the project completion (or an interim

contractual milestone), when anticipating on-time or early completion. If anticipating late completion, the

critical path is any continuous path that extends beyond the contract date for a completion milestone.

In NetPoint, criticality (if based on total float) is a signal of whether an activity’s total float is at or below a

threshold (often zero, except in the case of early or late completion). For special circumstances where

criticality is to be based on drift or float (rather than total float), that option is allowed within NetPoint, and the

threshold can be changed to any number, positive or negative.

For example, if a project were already significantly behind schedule, a large number of activities might already

be critical. To reduce the noise and identify only the most critical, the threshold could be changed to -5 instead

of 0. Conversely, if a project were ahead of schedule, there might not be any critical activities. In this case, the

threshold could be set to positive 5 so that even activities with total float were signaled out. By default, critical

activities and hammocks are automatically turned red, but they may be outlined instead to preserve their

original color.

When using outlines, actualized activities will only have their nodes outlined in red to preserve the blue outline

on the bar. In-progess activities will have their progressed portion outlined in blue and their remaining portion

outlined in red. Actualized milestones and benchmarks will not be outlined in red, despite the setting.

NOTE: A hammock will display as critical if at least 1 member is critical.

Steps

Changing the Criticality Threshold

1. Click Schedule > Modify Schedule Properties in the menu bar.

2. Increase or decrease the number next to Criticality Threshold.

3. If desired, click the dropdown next to Criticality Factor and choose accordingly.

4. When finished, click OK.

Using Outlines for Criticality

1. Click Objects > Use Outlines for Critical Objects (non-actualized only) from the menu bar.
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Repositioning Fields (GEM)

Fields such as descriptions, dates, and float values, also known as data elements, can be repositioned on the

canvas to eliminate clashing or simply better coincide with the geometry of the network. Supported objects

include activities, delays, milestones, benchmarks, links, data dates, and hammocks. If any fields end up

being more than 3″ away from their host objects, they will be reset to default the next time the schedule is

opened. Repositioning can be done individually for a single object or for the entire schedule using the Global

Edit Mode, or GEM.

Upon entering GEM, most toolbar icons as well as the menu bar will be disabled (except for select actions

within the Edit menu). In addition, most actions via right-click will be disabled, except for actualizing, fading,

or hiding/showing, for example. GEM also includes a tool for aligning text boxes.

NOTE: GEM is a mode distinct from (and behaves as a toggle with) the traditional “build mode” of

NetPoint, where objects and relationships are added to the canvas. Upon entering GEM, all dates

become fixed, and no object property boxes are accessible. However, object descriptions can still

be modified by double-clicking them on the canvas. In addition, objects can still move between

grids by using the up and down arrows on the keyboard or in the Gestural Window. No canvas

objects can be selected, modified, or moved, except for text objects (including annotations).

Steps

By Right-Clicking

1. With the Select Tool chosen in the toolbar, right-click on the desired activity, delay, milestone,

benchmark, link, data date, or hammock.

2. Choose the Customize Positions of or Customize Data Positions option. The object will be spotlit in

purple.

3. Left-click with the mouse the field you wish to move.

4. Without letting go, drag the field to its new position.

5. Release the mouse.

6. When finished, right-click anywhere on the canvas and choose Save Modified Positions.

Through GEM Mode

1. Click the Display Mode (GEM/Date Lock/Normal) icon in the toolbar, or click the down arrow and

choose Global Edit Mode (GEM). All fields will be highlighted in orange.

2. Left-click with the mouse the field you wish to move.

a. Without letting go, drag the field to its new position. Alternatively you can use the arrow keys on the

keyboard to move in increments of 1/20th of an inch.

b. Release the mouse.

3. To modify multiple objects of the same type, select the first object on the canvas.

a. Press and hold the SHIFT key on the keyboard.

b. Select one or more objects of the same type (activities, delays, and hammocks will all be considered

as activities). Alternatively, you can click on a blank portion of the canvas and drag a rectangular

marquee box around all of the desired objects, or use the Multi-Object Select Tool .

c. Repeat step 2-2b. All matching fields will jump to match the new position.

4. When finished, exit GEM by clicking the Display Mode (GEM/Date Lock/Normal) icon in the toolbar.
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Aligning Text Objects

1. Click the Display Mode (GEM/Date Lock/Normal) icon in the toolbar.

2. Identify a text object that you’d like to align others to, and select it on the canvas.

3. Press and hold the SHIFT key on the keyboard.

4. Select one or more additional text objects. Alternatively, you can click on a blank portion of the canvas

and drag a rectangular marquee box around one or more text objects or use the Multi-Object Select

Tool .

5. In the auxiliary toolbar, click the down arrow next to the Align Text Horizontal or Align Text

Vertical icons.

6. Choose from the sub menu.

7. When finished, exit GEM by clicking the Display Mode (GEM/Date Lock/Normal) icon in the toolbar.

Notes

GEM Toolbar

Upon entering GEM, an auxiliary toolbar will also open, offering the following options:

Keep Dates

Symmetric

When selected, this icon will tie an activity’s start and finish dates together so

that any changes to positions mirror each other symmetrically.

Vertical

Only

When selected, this icon will lock data elements to the vertical axis, preventing

them from being moved horizontally.

Horizontal

Only

When selected, this icon will lock data elements to the horizontal axis, preventing

them from being moved vertically.

Align Text

Horizontally

When expanded, this menu allows all selected text objects (excluding

descriptions) to be aligned to their tops, centers, or bottoms. Text objects will

align to whichever object was first selected. If they were selected using the

rectangular drag box, they will align to whichever object was placed on the

canvas first.

Align Text

Vertically

When expanded, this menu allows all selected text objects (excluding

descriptions) to be aligned to their lefts, centers, or rights. Text objects will align

to whichever object was first selected. If they were selected using the

rectangular drag box, they will align to whichever object was placed on the

canvas first.
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Paste Format

The paste format feature allows you to copy the styling of one object and paste it to another. This includes the

positioning of data elements (descriptions, dates, etc.), element displays (whether or not data are being

displayed on the canvas), and formatting (size, colors, etc.). This feature is especially useful for applying the

styling of one object that has already been customized to your specifications to another set of objects.

Styling can be pasted for all object types, but it can only be applied to other objects of the same type at any

given time. For example, if you copy the styling of an activity, it can be pasted to other activities, but not to

milestones (they will be ignored if selected). If you want to edit the formatting of different types of objects

simultaneously, see Bulk-Editing Objects for more info. If you want to edit the positioning of different types of

objects simultaneously, see Repositioning Fields (GEM).

Steps

1.
With the Select Tool chosen in the toolbar,

select the object you want to copy the styling

from on the canvas.

2.
In the toolbar, click the Copy icon (or press CTRL

+ C on the keyboard).

3.

Select one or more objects of the same type that

you want to paste the styling to on the canvas.

NOTE: Activities, delays, and hammocks are

all considered objects of the same type.

4.

In the toolbar, click the down arrow next to the

Paste icon and choose Paste Format (or

press SHIFT + CTRL + V on the

keyboard).NOTE: If more than one object was

selected when copying, Paste Format will be

disabled.
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5.

The following dialog opens before the paste

completes. Turn on or off the application of

displays, positioning, or formatting on an

element-by-element basis in the tab for the type

of object selected.NOTE: Styling will only be

pasted to objects of the same type as the one

copied; if any other types of objects were

selected, they will remain unchanged.

6.
When finished, click OK. After pasting, the

objects will remain selected.

7.
To de-select and verify the results, click away in

an empty portion of the canvas
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Notes

Default Paste Format Options

The Set Default Paste Format Options window can be accessed at any time via Edit > Default Format

Copy Options…. This window allows you to turn on or off the application of displays, positioning, or

formatting on an element-by-element basis. All of these options are available in separate tabs for each object

type.

It also provides a checkbox at the bottom in order to control the display of this window after every paste

format operation. If it is set to display after a paste, the checkbox will instead allow the modified options to be

saved as the new default options.

Examples

Allowing for individual control over display and position aspects of data elements gives a lot of flexibility when

pasting the format to target objects. In the example below, the duration of Activity 1 has been moved to the

right of the description, and the duration display has been turned off for Activity 2.
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If only the display column is checked for the duration, pasting from Activity 1 to Activity 2 will yield the

following result.

But if only the position column is checked, pasting from Activity 1 to Activity 2 will instead yield this result.

Even though the duration is not displayed for Activity 2, it’s position has been updated behind the scenes. If it

were turned on, it would display accordingly.

In the final example, both columns have been checked, and the paste yields the following result as expected.

NOTE: Durations will not paste between partially actualized and non-actualized activities.
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Fine-Tuning/Gestural Controls

When working on devices with touchscreens, or if you have to zoom way out for particularly large

schedules, using your fingers or the mouse to change dates or durations can be difficult or imprecise. To

make fine-tuning easier in these cases, NetPoint provides on-screen gestural controls for decreasing and

increasing the duration of an activity (known as crashing and extending, respectively), and for moving one or

more objects horizontally (known as pushing and pulling) and vertically (known as shifting).

Keep in mind that when you use the gestural controls (or arrow keys on the keyboard) to push or pull

multiple objects, each object will move according to the working days (or time units) defined in its own

calendar. If all objects have the same calendar, then using the gestural controls or keyboard arrow keys to

move multiple objects can achieve expected results. However, if some objects have different calendars, those

based on calendars with more working days will appear to move ‘faster’ on the canvas. In this case, using the

mouse may yield results closer to your expectations. For more info, see the Notes section below.

NOTE: If a milestone is assigned a calendar that’s different from that of its predecessors or

successors, and the network is pulled backwards, gaps may open up as the chain crosses a

weekend or non-working days. As such, it is recommended to always keep milestones on the same

calendar as their predecessors/successors.

Steps

Crashing/Extending (Activities)

1. Click the Gestural icon in the toolbar.

2. Select the desired activity on the canvas. To select multiple activities, select the desired activities one-by-

one on the canvas using the Multi-Select Tool, or click on a blank portion of the canvas and drag a

rectangular marquee box around all of the desired activities.

3. Enter a number next to By or click the up and down arrows to modify the magnitude of the change.

4. To crash or extend by percent duration (as opposed to by time), click the dropdown arrow and

choose Percent.

5. To reduce the duration (crash) of the selected activities from the start, click the innermost arrow at the

start (or press L on the keyboard + the RIGHT arrow key). To reduce the duration from the finish, click

the innermost arrow at the finish (or press R on the keyboard + the LEFT arrow key).

6. To increase the duration (extend) of the selected activities from the start, click the outermost arrow at the

start (or press L on the keyboard + the LEFT arrow key). To increase the duration from the finish, click

the outermost arrow at the finish (or press R on the keyboard + the RIGHT arrow key)

7. When finished, click the red Exit icon.

Pushing or Pulling Objects

1. Click the Gestural icon in the toolbar.

2. Select the desired object on the canvas. To select multiple objects, select the desired objects one-by-one

on the canvas using the Multi-Select Tool, or click on a blank portion of the canvas and drag a

rectangular marquee box around all of the desired objects.

3. Enter a number next to By or click the up and down arrows to modify the magnitude of the change.

Positions may only be moved in increments of time.

4. If percent is chosen, click the dropdown arrow and choose Day (or, if PolyTime is enabled, the

corresponding time unit). Otherwise, pushing/pulling will be disabled.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 225 of 344



5. To move the selected objects later in time, click the RIGHT arrow button below the activity (or press the

RIGHT arrow key on the keyboard).

6. To move the selected objects earlier in time, click the LEFT arrow button below the activity (or press

the LEFT arrow key on the keyboard).

7. When finished, click the red Exit icon.

NOTE: If optimizing or performing what-if scenarios, it is recommended to use an increment of no

greater than 10. Large increments should only be used in specific situations (e.g. if a window is

missed and the network must be delayed a year).

Shifting Objects Vertically

1. Click the Gestural icon in the toolbar.

2. Select the desired object on the canvas. To select multiple objects, select the desired objects one-by-one

on the canvas using the Multi-Select Tool, or click on a blank portion of the canvas and drag a

rectangular marquee box around all of the desired objects.

3. To move the selected objects up a grid, click the UP arrow button below the activity (or press the

UP arrow key on the keyboard).

4. To move the selected objects down a grid, click the DOWN arrow button below the activity (or press the

DOWN arrow key on the keyboard).

5. When finished, click the red Exit icon.

Notes

When multiple objects are moved with the arrow keys or gestural controls, the starting date of each object is

moved by the specified number of working days in the calendar of the object. This means that objects

assigned calendars with more non-working days will move ‘faster’ than objects assigned calendars with fewer

non-working days. When multiple objects are moved with the mouse, the starting position of each object is

moved by the same distance, and the dates are then recalculated from the new starting positions. For

example, imagine two activities assigned different calendars that start and finish on the same dates:
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If both “Sample Calendar Activity” and “Sample US Activity” are selected and dragged with the mouse until

the starting date of the first activity is 11/8 the following is the result:.

However, if the move is performed using the arrow key four times the result is:

The difference occurs because the “Sample Calendar Activity” is moved by 4 calendar days, while “Sample

US Activity” is moved by 4 working days (equivalent to 6 calendar days because the starting point of each

activity moves past a weekend).
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Adjusting Zoom & Stretch

Zooming and stretching can help to reduce data clashing, clarify logic relationships, or just better fit the user’s

monitor size. The zoom function magnifies or shrinks the canvas proportionally. The stretch function increases

or decreases the horizontal width of the canvas. Zooming and stretching will only temporarily enhance

readability on a digital display. They will have no effect on the printed page and they will reset when the file is

printed or saved and closed. To permanently affect the canvas, you must adjust the page size or grid spacing,

or use page tiling.

Steps

By Percentage

1. Click the Zoom/Stretch icon in the toolbar.

2. To adjust the Zoom Factor, click the up or down arrows, or enter a desired number.

3. To adjust the Stretch Factor, click the up or down arrows, or enter a desired number.

4. To return to defaults, click the Reset button accordingly.

5. When finished, click the red X in the upper right-hand corner. Any changes will be automatically saved.

NOTE: The Zoom Factor can be set from 25 to 300 percent of the default page layout. The Stretch

Factor can be set from 25 to 1000 percent of the default page layout.

Using the Keyboard

1. To zoom, press the SHIFT key on the keyboard

a. Without letting go, scroll up (to zoom in) or down (to zoom out) with the mouse.

b. When satisfied, release the key.

2. To stretch, press the CTRL key on the keyboard.

a. Without letting go, scroll up (to increase) or down (to decrease) with the mouse.

b. When satisfied, release the key.

With the Mouse (stretch only)

1. Click the Select Tool icon in the toolbar.

2. Move the cursor over the calendar strips at the top of the canvas.

3. Left-click with the mouse, noticing the percentage appear.

4. Without letting go, drag the mouse to the left (to decrease) or right (to increase).

5. When satisfied, release the mouse.

NOTE: If the stretch factor is reduced to a point where the width of a time unit is less than the width

of a pixel on screen, the stretch factor text will turn red. Modifying the network under these

conditions is not recommended, as input from the mouse could no longer translate accurately on

the canvas. It is recommended to increase the stretch factor before proceeding to work on the

network.
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Filters and Searching

Filters allow all objects in the schedule to be searched for based on specific sets of criteria. Filters are often

used to generate a list of objects that can then be bulk-edited. For example, to maintain GPM planned

dates before exporting to P6, you could filter the schedule for all activities and milestones with drift buffer

greater than 0 and apply start-no-earlier constraints to all of them.

The list of objects that results from a filter can also be highlighted or faded on the canvas, and filtering can

also be used to find just a single object in the schedule. If you’re just trying to find a specific activity and you

know it’s description, you can use the Activity Quick Search instead. Instructions for both are provided.

Steps

Applying a Filter (Example: Objects on Planned Dates)

1. Click Edit > Search and Filter Objects from the menu bar.

2. Click the down arrow under Objects to Include and add or remove any objects by checking the boxes

next to their names. For this example, add Start Milestones and Finish Milestones

a. Click outside of the list to close it.

3. Click the down arrow under Options and add or remove any criteria by checking the boxes next to

them. For this example, leave them blank.

a. Click outside of the list to close it.

4. To activate criteria in the Properties section, click the down arrow next to a given property and change it

from Ignore. For this example, click the down arrow next to Drift Buffer and choose >. In the number

control to the right of Drift Buffer, enter 0.

5. To activate colors, resources, codes, or calendars as a criteria, select one or more items from their

corresponding lists. For this example, leave all as Ignore.

6. When finished, click Add to List.

7. To modify the results, repeat steps 2-5 and click Refine List.

8. To add another search to the results, repeat steps 2-8 and click Add to List again.

9. When finished, click the red X in the upper right corner. The List of Filtered Objects window will remain

open with the objects spotlighted in yellow on the canvas.

Working with Filter Results

1. Follow steps 1-8 above.

2. To reorder the list, click the down arrow next to Order List By and choose from the options.

3. To locate an object on the canvas, choose it in the list. The canvas will scroll to it and the object will be

boxed in black and red.

4. To fade or highlight an object on the canvas, choose it in the list and press Fade or Highlight

accordingly.

5. To reset any fades or highlights, press Restore.

6. To select one or more objects, mark the selection circle field in between the object icon and the

description field, or use the Select All button to select every item in the list.

7. To edit selected objects in bulk, click Objects > Set Properties for Selected Objects. For more info, see

Bulk Editing of Objects.

8. When finished, click the red X in the upper right corner.

Finding a Single Activity

1. Click Edit > Find an Activity… from the menu bar.
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2. Enter any portion of the description into the box.

3. If more than one activities results, select one in the list and click Find.

4. The window will close and the activity will be spotlighted on the canvas.

Notes

Search Criteria

Objects to Include

By default, activities and delays will be included in the search.

Options

No Successors/

Predecessors

Check these boxes to find objects without any successors or predecessors. If both

were checked, all unlinked or unconnected objects would result.

After Project

Completion
Check this box to find any objects that finish after the project completion date.

SNE/FNL

Constraints

Check these boxes to include any objects which have had their start or finish dates

constrained accordingly.

Superimposed

On Grids

Check this box to find any objects that are overlapping on the same horizontal grid

line.

Redundant Link
Check this box to include any links that are redundant. For more information, see

Treating Redundancies.
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Properties

Description Fields & ID
Search for objects that contain, start with, or match certain

characters. Not case sensitive.

Duration, Float, Buffer, Total

Float, Drift, Drift Buffer, Link

Gap

These fields can be searched based on whether or not they are

less than, greater than, equal to, or in between a given number.

Criticality Search for critical or non-critical objects.

Color Search for objects of a certain color. Multiple colors can be chosen.

Assignments

Resources

Search for objects based on what resources they’ve been assigned. Any will yield objects

with ANY resources assigned; None will yield objects with NO resources assigned.

Multiple resources can be chosen.
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Codes/

Values

Search for objects based on what values they’ve been assigned. Any will yield objects

with ANY values assigned; None will yield objects with NO values assigned. Multiple

values can be chosen.

Calendars Search for objects based on what calendar they’ve been assigned.

Criteria Behavior

Parameters under Properties and Options behave as AND-CRITERIA, meaning that an object must match

ALL of the parameters chosen to be added to the list. For example, if No Successors is chosen and

Superimposed on Grids is chosen, only those objects which have both no successors AND are

superimposed on grids will be added to the list.

Parameters under Colors, Resources, and Codes/Values behave as OR-CRITERIA, meaning that an object

which matches ANY of the parameters will be added to the list. For example, if Carpenters is chosen and

Electricians is chosen, objects which have been assigned carpenters OR electricians will be added to the

list.

If you’ve selected Activities, No Successors, Superimposed on Grids, Carpenters and Electricians all

together, then activities that have both no successors AND are superimposed on grids that have been

assigned either carpenters OR electricians will be added to the list.
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Bulk-Editing Objects

Multiple objects may be edited at the same time through the Set Global Properties window. Bulk-editing

objects in this way can be instrumental in saving time. The process involves first selecting all objects you want

to edit on the canvas and then making the desired changes in each relevant tab in the Set Global Properties

window.

If you already know exactly which objects you want to modify, they can be selected one-by-one or in groups

on the canvas. In other cases, you may not be able to identify or locate all of the objects on the canvas, and

filtering may be required. For example, to maintain GPM planned dates before exporting to P6, you could

search for all activities and milestones with drift buffer greater than 0 (via the Apply Filters window), and then

apply start-no-earlier constraints in bulk.

Objects that can be bulk-edited include activities, delays, embeds, links, milestones, benchmarks, shades,

and text boxes. Each object type has its own tab that contains the available properties that can be

modified. Notable exclusions include properties unique to individual objects, such as descriptions and IDs.

Any change made will override the individual settings for all objects selected, but only for the type of object in

a given tab. For example, if the box next to Float were checked in the Activity tab, every activity selected

would have its float displayed on the canvas, but milestones would not be affected. In order to display float for

every milestone selected, the corresponding box would have to be checked in the Milestone tab as well.

Steps (Example: Applying SNE Constraints)

1. With the Multi-Object Select Tool chosen in the toolbar, select the desired objects one-by-one on

the canvas. Alternatively, you can click on a blank portion of the canvas and drag a rectangular marquee

box around all of the desired objects. For this example, see Applying a Filter to make the selection.

2. With the objects still selected, click Objects > Set Properties for Selected Objects from the menu bar.

3. Choose the tab for the type of object you want to modify. For this example, stay on the Activity tab.

4. To make a change, click the control next to the property you want to modify. For this example, under the

Constraints section, click twice in the box next to Start no earlier than until a check appears, and then

click once in the box next to Use Planned Dates until a check appears.

5. If more than one type of object was selected, repeat steps 3-4 for each object type.For this example, click

the Milestones tab and repeat step 4.

6. When finished, click OK. Changes from across all tabs will be applied at once.

NOTE: If the outcome is not as desired, click Undo or press Ctrl+Z on the keyboard to cancel the

last set of changes.

Notes

Setting Properties with Check Boxes

A property with a minus sign next to it indicates mixed assignment and will be left the way it was before

the Set Global Properties window was opened.
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If a check box showing a minus sign is clicked, it becomes blank. In the case of displays, a blank box means

that the property will not be displayed. In the case of actualization, a blank box means that an actualized

activity would be de-actualized.

If a blank check box is clicked, it becomes checked. In the case of displays this means the checked property

will be displayed. Clicking once more will cycle the check box back to the mixed state, which will leave the

property for all applicable objects the way it was prior to entering the Set Global Properties window.

Constraint Behavior

Applying no-earlier-than (NET) or no-later-than (NLT) constraints may have a different effect depending on

whether or not any of the selected activities or milestones currently have or previously had constraints set in

the past. For example, for NET constraints:

If an activity
or

milestone…
…and… …then…

Has NEVER

HAD a no-

earlier-than

constraint

before…

Start-no-earlier-

than is checked…
No constraint will be set.

Has NEVER

HAD a no-

earlier-than

constraint

before…

Both Start-no-

earlier-

than and Use

Planned Dates

are checked…

An NET constraint will be applied at its current start date.

Currently HAS

a no-earlier-

than-

constraint…

Start-no-earlier-

than is checked…
No change will be made.

Currently HAS

a no-earlier-

Both Start-no-

earlier-

The existing NET constraint will be reset to the current start

date.
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If an activity
or

milestone…
…and… …then…

than-

constraint…

than and Use

Planned

Dates are checked…

Once HAD a

no-earlier-than

constraint…

Start-no-earlier-

than is checked…

An NET constraint will be applied at whatever date the

constraint was last set at unless the current start date is

earlier than its last constraint date, in which case no

constraint will be set.

Once HAD a

no-earlier-than

constraint…

Both Start-no-

earlier-

than and Use

Planned

Dates are checked…

An NET constraint will be applied at its current start date.

If both Start-no-earlier-than and Use Planned Dates are unchecked, the objects will be unconstrained but

their most recent constraint dates will still be remembered internally.

Text Style

The description and the abbreviated description can be styled/formatted differently or the same. To make

them different, choose Description from the dropdown, customize the options, and then choose Abbr.

Description from the dropdown, and customize the options for it. The settings will be saved, and you can

switch between the two to confirm.

To make them the same, choose Both from the dropdown, and then customize the options. Note that

choosing both will only overwrite the options that receive a change. For example, imagine the description’s

font has been formatted to Arial and the abbreviated description’s font has been formatted to Tahoma.

If Both is chosen from the dropdown and the font is set to Calibri, then the font for both the description and

the abbreviated description will be set to Calibri, but the color, alignment, style, and size will be unaffected,

since they didn’t receive any change. This can be confirmed by switching between the description and the

abbreviated description and reviewing them without losing any of the changes.

NOTE: If both the description and the abbreviated description have been turned off but the ID is

turned on, then the ID will inherit the formatting of the abbreviated description. Otherwise, it will

inherit the formatting of whichever description field is being displayed along with it.

Activity Tab

For info on individual fields, see Adding/Modifying Activities.
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Milestone Tab

For info on individual fields, see Adding/Modifying Milestones/Benchmarks.
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Benchmark Tab

For info on individual fields, see Adding/Modifying Milestones/Benchmarks.
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Embed Tab

For info on individual fields, see Using Embeds to Create SS and FF Links.
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Link Tab

For info on individual fields, see Creating FS Links.

Shade Tab

For info on individual fields, see Markup Tools.
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Text Tab

For info on individual fields, see Markup Tools.
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Schedule Statistics

NetPoint tracks a number of statistics for each plan, such as the number of activities, types of links, and float

distributions.

Steps

1. Click Schedule > View Statistics… from the menu bar. The Schedule Statistics window will open.

2. When finished, click the red X in the upper right to close the window.

Notes

Field Definition

Activity

Count
The number of activities in the schedule.

Hammock

Count
The number of hammocks in the schedule.

Link Count The number of links in the schedule.

Redundant

Link Count
The number of redundant links in the schedule.

Logic Index The number of valid links divided by number of activities in the schedule.
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Field Definition

Start

Embeds
The number of start embeds in the schedule.

Finish

Embeds
The number of finish embeds in the schedule.

Start

Milestones
The number of start milestones in the schedule.

Finish

Milestones
The number of finish milestones in the schedule.

Start

Milestones
The number of start benchmarks in the schedule.

Finish

Milestones
The number of finish benchmarks in the schedule.

Zero-gap

Links
The number of zero-gap links in the schedule.

Project

Duration in

Calendar

Periods

The number of days (or, if PolyTime is enabled, number of minutes, hours, etc.)

between the project start and project completion, including holidays, non-working

periods, and weekends.

Project

Duration in

Work

Periods

The number of days (or, if PolyTime is enabled, number of minutes, hours, etc.)

between the project start and project completion, excluding holidays, non-working

periods, and weekends (based on whichever calendar has been selected as default).

Longest

Path in

Calendar

Periods

The chain of linked objects that lasts the most number of days (or, if PolyTime is

enabled, number of minutes, hours, etc.) including holidays, non-working periods, and

weekends.

Longest

Path in Work

Periods

The chain of linked objects that lasts the most number of days (or, if PolyTime is

enabled, number of minutes, hours, etc.) excluding holidays, non-working periods, and

weekends.

Hard-Links

Count
The number of hard links in the schedule.
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Field Definition

Soft-Links

Count
The number of soft links in the schedule.

Resource-

Links Count
The number of resources links in the schedule.

External-

Links Count
The number of external links in the schedule.

Contractual-

Links Count
The number of contractual links in the schedule.

Float

Distributions
The percentile rank for different float values.
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Predecessors and Successors

As objects become linked, they form chains. For any object in a chain, its predecessors are those that are

connected by a link that terminates at the given object, and its successors are those that are connected by a

link that emanates from the given object. A list of an object’s predecessors and successors can be viewed in

NetPoint, and predecessor/successor data can also be exported to excel. Instructions for both are provided.

Steps

Viewing and Breaking Links

1. Right-click on a desired object and choose View Predecessors and Successors from the menu. The

Predecessor and Successors window will open.

2. To remove the link between the selected object and a given predecessor or successor, select it in the list

and click Break Link. The link will be removed upon closing the window.

3. When finished, click the red Exit icon.

Comparing Resources

1. With the Select Tool chosen in the toolbar, right-click on a desired object and choose View

Predecessors and Successors from the menu.

2. To view assignments for a given resource, click the dropdown button next to Compare Resources and

choose from the list.

3. To add, modify, or remove a resource assignment, select the desired activity in the list.

4. Under Rate, click in the box and enter, edit, or remove the value. NOTE: If the rate column is left

blank, no assignment will take place.

5. To distribute the assignment over the entire duration of the activity, click the drop down button

under Distribution and choose /Duration.For more info, see Assignment Options.

6. When finished, click the red Exit icon to close the window. Changes will be saved automatically.

Exporting to Excel

WARNING: When a template is exported to Excel, the new Excel file will automatically overwrite the

last-exported Excel file unless the last one was renamed or moved. To avoid losing the previous Excel

file, rename it or move it to a different location before doing the next export.

1. With the Select Tool chosen in the toolbar, right-click on a desired object and choose View

Predecessors and Successors from the menu. If desired, the predecessor/successor data that’s

exported can be customized first. To do so, skip to step 1 of Modifying/Exporting an Existing Template

instead and choose “Defaults – Logic, Predecessors & Successors” from the dropdown.

2. Click the Export button. Excel will open with the exported data. NOTE: On export, the Excel file will be

automatically saved in the schedule’s project folder and become linked to the schedule for

updating. This new file will automatically overwrite the last-exported Excel file (for that schedule)

unless it was renamed or moved.

3. If you plan on exporting additional templates in the future, then we suggest renaming the file or moving it

to a different location to avoid having it being overwritten. Click File > Save As from the menu bar, enter

a name, and click Save .NOTE: If you DO rename or move the file, you can ONLY initiate an update

from it from within Excel. For more info, see Updating from Linked Reports.

NOTE: For more info, see Predecessor and Successor Data in the Exporting Linked Reports section.
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Notes

Predecessors and Successors Window

Column Definition

Type The type of object, such as activity, link, milestone, benchmark, delay, or hammock.

Description The object’s description field, used to describe the object.

ID The object’s ID. The ID is a unique identifier.

Rate The amount or number of the resource required.

Distribution
How the resource is used by an activity. Resources may be assigned per time period or

duration.

Float
The float of the object. The float is the amount of time an object can be delayed before

delaying the completion of the project.

Relation

The relationship with the selected object, such as start-to-start (SS), finish-to-finish (FF),

finish-to-start (FS), or start-to-finish (SF). If the relationship is SS or FF, it’s followed by

the lead or lag of the embedded node.

Gap The duration of the link to the selected object.
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Split-Screen/Multiple Canvases

NetPoint allows you to divide each window into more than one canvas for the same schedule. This can be

useful when you have a large schedule that can’t fit within view all at once. The window can be split vertically,

horizontally, or both, the latter of which produces four canvases.

Each canvas can be independently zoomed and scrolled, and each canvas can have the resource plots and

Date Lock mode turned on and off independently. Everything else applies to all canvases, including the

GEM, Logic and Planning modes, canvas formatting, grid spacing, and stretch factor. Any modifications to

the network performed in one of the canvases will be immediately reflected in the others. Please refer to the

following steps.

Steps

1. Open the desired project via File > Open Project from the menu bar.

2. To split the window into two side-by-side canvases, choose View > Vertical Split.

3. To split the window into two canvases stacked on top of each other, choose View > Horizontal Split.

4. To split the window into four canvases, apply steps 2 and 3 (in either order).

5. To switch focus and control from one canvas to another, click the Select Tool icon from the toolbar

and left-click with the mouse on an empty portion of the canvas.

6. To resize the canvases, move the cursor over the dividing line between canvasses.

a. Click-and-drag the double sided arrow that appears in the desired direction.

7. To remove the split, move the cursor over the dividing line between canvasses. .

a. Click-and-drag the double sided arrow that appears to any edge of the application window.

Alternatively, click View from the menu bar and uncheck the split you wish to remove.

Notes

The Active Canvas

At any given time, only one canvas can be active per window. Changes made in the active canvas will be

reflected in the other canvases for the same window; the time it takes will depend on the size of the

schedule. Always change the active canvas before adding or making any modifications to it; otherwise, the

cursor may not update and the date will not follow along.
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Vertical Split:

Horzontal Split:
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Double Split :
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6) Updating a Schedule

Once a schedule has been created, it may be updated to track and monitor progress. In NetPoint, entering

actual dates and durations (also known as “statusing”) is done just like drawing activities or leveling

resources—graphically on the canvas. The entire process involves setting a data date, storing a target,

statusing activities, and then actualizing statused activities. An update is complete once all activities left of the

data date have been actualized.

Unique to NetPoint is the ability to calculate float attributes forensically. As the schedule is revised right of the

data date, drifts, floats, and total floats continue to refresh for actualized activities left of the data date,

reflecting any re-planning of the network.

Tip: To maintain a record of date-specific as-built forensic float attributes, save each update individually. Also,

the user may choose to further secure the data. See Setting a Password.
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Data Dates

A data date is an object on the canvas used to represent the date to which the project has been statused.

Data dates help provide a clear visual indicator of the progress of the schedule. The data date appears as a

blue circle with a blue line extending the height of the canvas on that date.

By default, the data date is set to the project start. When equal to the project start, however, it cannot be

displayed or modified. Once a new data date is inserted, the prior data (if any) date will become faded, and if

any un-actualized objects cross the data date, a red counter will appear in the upper-right corner displaying

the exact number.

A data date cannot be moved on the canvas. If needed, it may be modified using the arrow keys on the

keyboard or the Gestural Interface. For more info, see Pushing or Pulling Objects. Likewise, a data date

cannot be deleted. However, the most current data date may be reset to the project start. Instructions for this,

as well as inserting, hiding, or showing the data date, are provided below.

Steps

Inserting a Data Date

1. Click the Data Date icon in the toolbar.

2. Move the cursor over the canvas and stop at the desired date, indicated by the text above the crosshairs

.

3. Left-click with the mouse and release.

4. In the confirmation, choose to either capture or not capture a corresponding target. For more info, see

Managing Targets.

NOTE: If working in CPM Mode, all activities to the left of the data date (or crossing through it) must

have start and finish constraints applied before the data date is placed. Otherwise, the network (i.e.

all connected activities and milestones) will jump to the data date (since this is where drift is

calculated to) and be unable to be actualized. To set constraints globally for all necessary objects,

see Bulk-Editing Objects.

Resetting the Data Date

1. Click the Select Tool icon in the toolbar.

2. Right-click on the data date and select Reset to Project Start.

NOTE: This will have the effect of deleting all previous data dates and de-actualizing all objects.

Hiding/Showing Data Dates

1. Click Schedule > Modify Schedule Properties and choose the Displays tab.

2. Check or uncheck the boxes next to Current Data Date and/or Old Data Dates, as desired.
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NOTE: Old data dates can only be displayed if the current data date is displayed.
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Managing Targets

A target is a snapshot of a schedule at a given moment in time. Creating a target captures the start date,

finish date, duration, drift, float, and total float of all activities, milestones, benchmarks, delays, and

hammocks. As the schedule progresses, current activity data may then be compared to earlier target data.

The Targets Manager is where all the target functionality is located, such as capturing targets, comparing

targets to one another, and exporting targets. The window itself is non-modal, meaning that you can navigate

to other menus or make modifications on the canvas without having to close it.

By default, the Targets Manager comes pre-loaded with a permanent target for the current state of the

schedule. This can not be renamed or deleted and will update in real-time with the network, regardless of

whether or not the schedule has been saved. This section provides guidance on capturing and deleting

targets. Instructions are provided below.

Steps

Capturing a Target

1. Click Tools > Open Targets Manager from the menu bar. The Targets Manager will open.

2. Beneath the list, click New. A target will be added to the list, and the timestamp and most current data

date (if any) will populate. NOTE: When generated by dropping a data date, the most current data

date will be the one already existing NOT the one being added.

3. Begin typing to rename the target and press ENTER.

4. When finished, click Close. Any changes will be automatically saved.

NOTE: Targets can also be captured automatically by dropping a data date and following the

prompt. In these cases, they will be automatically named “Before DD at MM/DD/YYYY”.

Renaming a Target

1. With the Targets Manager open, select the desired target in the list.

2. Click the Rename button. You may also double-click the target to enter editing mode.

3. Begin typing to and press ENTER.

4. When finished, click Close. Any changes will be automatically saved.

Deleting a Target

1. With the Targets Manager open, select the desired target in the list.

2. Click Delete.

3. In the confirmation, click Yes.

4. When finished, click Close. Any changes will be automatically saved

Notes

The Targets Tab

The Targets tab contains two list boxes. The main list on top displays all captured targets; the secondary list

on bottom displays a tabular comparison.
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Upper List

Column Definition

Base Controls whether or to use the target as the base for comparison purposes.

Alternate Controls whether or not to use the target as the alternate for comparison purposes.

Description A text field for describing the target.

Data Date

(DD)

The date of the most recent data date, if any, on the canvas when the target was

captured. NOTE: For targets that are generated by dropping a data date, the most

current data date will be the one already existing NOT the one being added.

Timestamp The date and time when the target was captured.
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Statusing and Entering Percent Complete

Once the data date has been set and a target has been captured, actual dates and durations can be entered

(also known as “statusing”). In NetPoint, actual dates and durations are one in the same with planned dates

and planned durations. As a result, statusing individual activities is best done graphically on the canvas.

However, if multiple activities haven’t yet started, they can be delayed to the data date as a group

automatically. In addition, percent of work completed can be entered using the Estimated Complete field.

Instructions for each are provided below.

Steps

Statusing Manually

1. Click the Select Tool icon in the toolbar.

2. Select the desired object on the canvas.

3. If the object has been delayed or started earlier, drag it to the right or left respectively and release the

mouse when finished.

4. To change the duration of an activity, hover the mouse over the start or finish node respectively until a

double-arrow appears.

5. Click and drag the node earlier or later until it lands on the desired date.

6. Release the mouse. This will also update the duration.

NOTE: Dates and durations can also be statused graphically using the Gestural Interface or

numerically through an object’s property window. For more info, see Fine-Tuning/Gestural Controls.

Statusing to the Data Date

1. With the Select Tool chosen in the toolbar, double-click the red counter on the data date, or

click Schedule > Manage Schedule Progress… from the menu bar.

2. Select a desired activity in the list.

3. Press the CTRL key on the keyboard

4. Without releasing the CTRL key, select the next desired activity in the list, scrolling if necessary.

5. Repeat step 4 as many times as needed.

6. Click Slide to DD.

7. Click the red “X” to close the window.

NOTE: If an attempt is made to slide an activity to the data date but that activity has any successors

that have already been actualized (i.e. blocking objects), the activity will only jump to the blocking

objects. A notification will appear and the blocking objects will be spotlighted in yellow until the

user makes a change on the canvas, such as moving an object. The yellow box can also be cleared

by choosing Objects > Restore Faded Colors for All Objects.

Entering Percent Complete

1. With the Select Tool chosen in the toolbar, double-click an activity or right-click and choose

Properties.

2. Enter a number next to Estimated Complete.

3. Click OK.
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Actualizing Objects

Once dates and/or durations have been updated on the canvas (i.e. statused), objects must be actualized to

complete the update process. Once actualized, the object becomes outlined in blue, and its dates and

dependencies remain fixed unless purposely de-actualized. However, if a portion of an activity is finishing

after the data date (i.e. a partially actualized or in-progress activity), the remaining duration will not be outlined

in blue and may still be modified.

In addition, for activities, delays and hammocks, a new field Calculated Complete will appear in the property

window showing the percent of duration completed (progressed duration divided by total duration). This field

cannot be edited and will only display for actualized activities. To manually enter the percent of work

completed, see Statusing and Entering Percent Complete. Instructions for actualizing are provided below.

Steps

Actualizing a Single Object

1. With the Select Tool chosen in the toolbar, right-click on the desired object and choose Actualize.

2. To de-actualize, repeat step 1 and choose Deactualize.

Actualizing Selected Objects

1. With the Select Tool chosen in the toolbar, select the desired objects on the canvas.

2. Click Objects > Set Properties for Selected Objects… from the menu bar.

3. In the Properties section, click twice to check the box next to Actualized.

4. Click OK.

5. To deactualize, repeat steps 1-4 clicking once to uncheck the box.

NOTE: Each type of object has an individual tab and must be actualized within their respective tabs

as noted above. For more info, see Bulk-Editing Objects.

Actualizing all Pending Objects

1. With the Select Tool chosen in the toolbar, double-click the red counter on the data date, or click

Schedule > Manage Schedule Progress… from the menu bar.

2. Select the first row in the list on top and scroll to the bottom of the list.

3. Press the SHIFT key on the key board and select the last row in the list.

4. Click Actualize.

5. Click the red “X” to close the window.

NOTE: The CTRL key can be used to select non-adjacent activities.
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Comparing Updates

NetPoint generates comparisons by using targets that correspond with different states of a schedule. This is

done by first designating one target as the base and then another as the alternate. At any given time, only two

targets can be compared to one another, but any target can be the alternate and any target can be the

base. NetPoint includes both a tabular comparison and a visual comparison.

This chapter includes details for the following:

1. Tabular comparisons

2. Visual target mode

3. Exporting targets/comparisons
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Tabular Comparison

Once a target has been captured in the Targets Manager, a base and an alternate must be designated

accordingly. Any target can be the base and any target can be the alternate, but only two targets can be

compared at a time. Start dates, durations, finish dates, floats, drifts, and total floats can be compared to

determine the variance, if any, between the two targets. At least one target must be defined to generate the

comparison. For more info, see Managing Targets.

Variances are calculated as base minus alternate for start date, duration, and finish date. To put it simply, a

negative variance can be interpreted as a delay, and a positive variance can be interpreted as a gain. To the

contrary, for drift, float, and total float, variances are calculated as alternate minus base. In this case, a

negative variance can be interpreted as a decrease, and a positive variance can be interpreted as an

increase.

NOTE: If an object is deleted from the schedule, it will no longer show up in the comparison, even if

it existed when the target being compared was captured. If an object was added after the target was

captured, it will not have any data and “None” will be displayed.

Steps

Viewing the Comparison

1. Click Tools > Open Targets Manager from the menu bar. The Targets Manager will open.

2. In the first column on the left (base), check the box next to a desired target.

3. In the second column (alternate), check the box next to a different target.

Enlarging the Comparison

1. With the comparison being viewed, click the Enlarge icon above the tabular comparison. The

Expanded Comparison window will open.

2. When finished, click the Exit icon.

Sorting, Adding, and Removing Columns

1. To sort by a certain field, click once on the column’s label to sort from top to bottom, or click twice to sort

from bottom to top.

2. To add a column, right-click on any column.

a. Choose the desired field. The menu will close.

3. Repeat step 2 as desired.

4. To remove a column, left-click on the desired column.

a. Without releasing the mouse, drag it up or down until a black “X” appears.

b. Release the mouse.

5. Repeat step 4 as desired.

6. To rearrange a column, left-click on the desired column

a. Without releasing the mouse, drag it left or right until two red arrows appear to indicate where it will

be placed.

b. Release the mouse

7. When finished, click Close. Any changes will be automatically saved.

Enabling/Disabling Canvas Scroll

1. Click Tools > Open Targets Manager from the menu bar. The Targets Manager will open.
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2. Click the List icon in the upper-right corner

3. Click Scroll Canvas with Manager Selections. A checkmark will appear or disappear accordingly.

Notes

Targets Tab

The list on the bottom displays the tabular comparison. As you click through the list, the canvas will be

scrolled and the item spotlighted. For more info on how to turn off scrolling, see the steps above.

Lower List

Column Definition

Icon An image representing the type of object.

Description The text field for describing the object.

ID The user-entered unique identifier

Abbr. Description
A text field limited to 48 characters to be displayed on the canvas if the description

is too long.

Base Start Date The object’s start date when the base target was captured.

Alternate Start

Date
The object’s start date when the alternate target was captured.
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Column Definition

Start Date

Variance

The base minus the alternate, in time units (i.e. days), according to calendar for

each object.

Base Duration The object’s duration when the base target was captured.

Alternate

Duration
The object’s duration when the alternate target was captured.

Duration Variance
The base minus the alternate, in time units (i.e. days), according to calendar for

each object.

Base Finish Date The object’s finish date when the base target was captured.

Alternate Finish

Date
The object’s finish date when the alternate target was captured.

Finish

Date Variance

The base minus the alternate, in time units (i.e. days), according to calendar for

each object.

Base Drift The object’s drift when the base target was captured.

Alternate Drift The object’s drift when the alternate target was captured.

Drift Variance
The alternate minus the base, in time units (i.e. days), according to calendar for

each object.

Base Float The object’s float when the base target was captured.

Alternate Float The object’s float when the alternate target was captured.

Float Variance
The alternate minus the base, in time units (i.e. days), according to calendar for

each object.

Base Total Float The object’s total float when the base target was captured.

Alternate Total

Float
The object’s total floatwhen the alternate target was captured.

Total

Float Variance

The alternate minus the base, in time units (i.e. days), according to calendar for

each object.
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NOTE: Durations and their variances for milestones and benchmarks will show up as empty. Drift,

float, total float, and their variances for benchmarks will show up empty.

Expanded Comparison

The enlarged comparison is the same as the smaller version, but how its columns are arranged will be saved

separately.
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Visual Target Mode

In Visual Target Mode, activities that are ahead of or behind schedule can be made either smaller, larger, or

lighter or darker, resulting in a visual comparison. The definition of ahead of schedule and behind schedule

can be customized through a filter to include variances in start dates, durations, finish dates, floats, drifts, total

floats, or any combination desired. And the criteria of the filter can be defined as “and”, in which case an

activity must satisfy ALL of the criteria, or the criteria can be defined as “or”, in which case an activity can

satisfy ANY of the criteria.

Once a filter has been applied and the Visual Target Mode icon selected, any activity which matches the

filter will be formatted on the canvas. This formatting will have NO effect on colors or sizes specified outside

of Visual Target Mode and the two will be stored separately. If an activity is modified within Visual Target

Mode such that it no longer matches filter (e.g. its duration is crashed and its variance reaches zero), its

formatting will refresh dynamically, resulting in kinetic, real-time feedback. Visual Target Mode requires at

least one target to have been captured by the user and a base and alternate designated.

Activities whose finish dates are at least 5 days behind schedule have been made darker and bigger;

activities whose finish dates are at least 5 days ahead of schedule have been made lighter and smaller;

activities which match neither are faded.

NOTE: Whereas the tabular comparison can be generated between any two targets, the visual

comparison can ONLY be generated if one of the two targets is the Current State. If two targets have

been selected but neither is the Current State, the formatting on the canvas will be cleared and the

Update button will be disabled.
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Steps

Viewing the Comparison

1. Click the Visual Target Mode icon in the toolbar. The Visual Target Mode Filters window will open.

a. If a base and/or alternate have not yet been designated, the Targets Manager will open. In the first

column on the left (base), check the box next to a desired target.

b. In the second column (alternate), check the box next to Current State.

2. If no criteria have been added yet, click the Add button, and customize as desired. Otherwise, skip to

step 3.

3. Click the Update button.

4. When finished, click the Exit icon in the upper right.

Clearing the Comparison

1. Click the Visual Target Mode icon in the toolbar.

Adding Filter Criteria

1. Click Tools > Modify Visual Target Filters from the menu bar. The Visual Target Mode Filters window

will open.

2. Click the Add button.

3. Customize as desired.

4. Click Update to save the changes and display them on the canvas.

5. When finished, click the Exit icon in the upper right.

Modifying Filter Criteria

1. Click Tools > Modify Visual Target Filters from the menu bar. The Visual Target Mode Filters window

will open.

2. Select the desired cell in the list.

3. Customize as desired.

4. Click Update to save the changes and display them on the canvas.

5. When finished, click the Exit icon in the upper right

Deleting Filter Criteria

1. Click Tools > Modify Visual Target Filters from the menu bar. The Visual Target Mode Filters window

will open.

2. Select the desired row in the list and click the Remove button.

3. Click Update to save the changes and display them on the canvas.

4. When finished, click the Exit icon in the upper right

Notes

Bar Shadows and Selecting Activities

In Visual Target Mode, selecting an activity on the canvas will trigger a light grey shadow to appear beneath

its bar, indicating its position and dates from the base target. In addition, fields will no longer reset or enlarge.

Visual Target Mode Filters

The Visual Target Mode Filters window can be left open and worked with side-by-side with

the Targets Manager, if desired.
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Field Definition

Base

Target
The description of the target currently selected as the base.

Alternate

Target
The description of the target currently selected as the alternate.

Match

Controls how to aggregate multiple criteria. The criteria can either be considered as “and”,

in which case an activity must satisfy ALL of the criteria, or the criteria can be considered as

“or”, in which case an activity can satisfy ANY of the criteria.

Display

Shadows

Displays the bar shadows for all objects matching the filter. When selected, selecting an

activity will no longer trigger the shadow.

Filter Criteria

Column Definition

Variance

in

A field for determining what the given criteria is based on. Options include start date,

duration, finish date, float, drift, and total float.

Operator
A field for determining how the variance relates to the threshold. Options include at least,

up to, and equals. For greater than, choose at least; for less than, choose up to.

Threshold A field for entering the degree of variance.
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Column Definition

Unit A field for choosing the threshold’s unit. Options include in days (or time unit) or percent.

Status

A field for choosing between positive or negative variance. Options include ahead of

schedule, behind schedule, and on schedule. NOTE: When choosing On Schedule, the

Operator will automatically be taken to be Equals and any value in the Threshold will

be ignored.

Size
A field for formatting the size of any matching activities. Options include no change, small,

normal, and large.

Color
A field for formatting the color of any matching activities. Options include no change, light

green, green, and dark green.

Non-matching Objects

This formatting will have NO effect on colors or sizes specified outside of Visual Target Mode and the two will

be stored separately.

Column Definition

Reset Sizes to

Normal

Controls whether or not all objects not captured by the filter will be reset to their

default normal size.

Reset Colors to

Green

Controls whether or not all objects not captured by the filter will be reset to their

default green color.

Fade
Controls whether or not all objects not captured by the filter will be faded on the

canvas.

All Objects

Column Definition

Variances

When selected, variances will be displayed for all objects, but only if the parent field is

displayed in the object’s property window. By default, variances will show up beneath the

parent field for start date, finish date, and all float values, but to the right for the duration.

Variances cannot be repositioned separately from their parents but are controlled by them.

If the activity is sufficiently short, variances will be displayed to the right for all fields and

repositioned with their parents according to NetPoint’s clashing algorithm (this does not

occur if the positions have already been customized by the user). The user is reminded that

the float block and duration cannot be displayed at the same time in these cases. If both

are selected, only the float block will show up until the activity is stretched back out.

Variance values are always calculated according to the object’s calendar.
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Exporting Targets/Comparisons

Comparisons can be exported as part of a linked Excel report or as a single

standalone spreadsheet. Instructions for both are provided below.

Steps

Exporting the Linked Excel Report

1. Click Tools > Open Targets Manager from the menu bar. The Targets Manager will open.

2. Click the List icon in the upper-right corner of the Targets Manager.

3. Choose Export Default Report to Excel. Excel will open.

NOTE: For a detailed explanation of this report, see Target Data in the section Exporting Link

Reports.

Exporting a Standalone Spreadsheet

1. Click Tools > Open Targets Manager from the menu bar. The Targets Manager will open.

2. Click the Enlarge icon above the tabular comparison. The Expanded Comparison window will open.

3. Click the Export to Excel button, or rIght-click on the columns at the top.

4. Choose either Export Visible Rows & Columns or Export All Rows & Columns.
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Displaying Percents Complete and In-Progress Durations

If desired, the Estimated Complete or Calculated Complete can be displayed on the canvas in place of the

duration; however, only one can be displayed at a time. Turning any one of them on will automatically turn the

others off.

When an activity is in-progress, the planned duration will be split into the progressed duration and remaining

duration. By default, these will show up to the left and right of the data date line but can be customized

manually. Each field can be turned off individually; however, the planned duration will not be able to be

displayed while in progress.

Likewise, the Estimated Complete and Calculated Complete will be split into progressed completes and

remaining completes. However, these can only be turned on and off as a pair.

Steps

1. With the Select Tool chosen in the toolbar, double-click an activity or right-click and choose

Properties.

2. Click the Displays tab.

3. Check the box next to the desired field.

4. Click OK.

NOTE: These fields can also be turned on or off for multiple objects at a time. For more info,

see Bulk-Editing Objects.

Notes
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Forensic Floats for Actualized Objects

Since the Graphical Path Method (GPM) doesn’t depend on early and late-dates to calculate float, GPM float

attributes continue to refresh for actualized activities left of the data date. This is called forensic float, and it

can be particularly useful when analyzing a schedule for delays after the project has started or finished.

By default, forensic float is not turned on, meaning when a data date is set and activities are actualized, float

attributes will disappear and be disabled in the property boxes. Instructions for enabling forensic floats are

provided below.

NOTE: When a data date is dropped, the drift of an un-actualized or partically-actualized activity will

go negative until it’s actualized, since drift is measured from the data date. In addition, for in-

progress activities, float and drift calculations ignore links to and from embeds on the left side of

the data date.

Steps

1. Click Objects > from the menu bar and choose Display Float and Drifts for Actualized Objects.

NOTE: If float attributes still are not showing up, make sure they’re turned on for the desired

objects. This can be done one-by-one in their property windows or one-at-a-time. For more info,

see Bulk-Editing Objects.

Notes

Drift, float, buffer, and total float are displayed in that order below the activity bar on the same line. They may

be distinguished from one another by the shape of their bounding boxes: drift points to the left, or project start;

float and buffer point to the right, or project completion; and total float points in both directions.

In this example, drift is equal to 30, float is equal to 70, and buffer is equal to 5. Either buffer or total float may

be displayed, but not both at the same time.
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7) Inputs and Outputs

NetPoint schedules can be imported from and exported to Primavera P6, Deltek Open Plan, and Microsoft

Project, and exported to Synchro Professional. Activities and resources can also be defined in Excel and then

imported into NetPoint, and NetPoint can export reports to Excel. Instructions for all, in addition to printing,

presenting, and capturing snapshots, are provided in this chapter.
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Preparing to Export from NetPoint (GPM)

When exporting to P6, Open Plan, or MS Project, any activities or milestones placed on planned-dates

(between their early-start and late-start) will be pulled back to their traditional CPM early-start dates. In order

to maintain a comparable network, constraints must be applied to any activities and milestones starting on

planned-dates. This can be accomplished using a filters.

Steps

Constraining Activities and Milestones

1.
Click Edit > Search and Filter

Objects… from the menu bar.

2.

Click the down arrow

under Objects to Include and

add Start

Milestones and Finish

Milestones by checking the

boxes next to their names.

Make sure to click outside of

the list to close it.

3.

In the Properties section, click

the down arrow next to Drift

Buffer and choose >.

4.
In the number control to the

right of Drift Buffer, enter 0.
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5.
At the bottom, click Add to

List.

6.
In the List of Filtered Objects,

click Select All.

7.

To close both windows, click

the red X in the upper right

corner of the List of Filtered

Objects window.

8.

To begin bulk-editing, click

Objects > Set Properties for

Selected Objects from the

menu bar.

9.

Under the Constraints section,

click twice in the box next to

Start no earlier than until a

check appears, and then click

once in the box next to Use

Planned Dates until a check

appears.
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10.
Click the Milestones tab and

repeat step 9.

11.

When finished, click OK.

Changes from across all tabs

will be applied at once.

Notes

For more info, see Constraining Activities.
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Primavera Project Management

NetPoint features round-trip importing and exporting with Primavera P6. This is done by first exporting an

.XER file from one application and then importing it into the other. NetPoint can write XER files versions 6.2.1,

7.0, 8.1, 8.2, and 8.3 and read XER files versions 6 and onward.

Primary information such as activities, logic, grid position, and assignments are all maintained, while some

formatting characteristics such as link geometries, shades, page size, and canvas color are not. For a full list

of supported fields, see the notes at the end of the following sections.

This section details instructions for the following:

1. Importing from P6

2. Exporting to P6
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Importing from P6

To import a schedule from P6 into NetPoint, you must first go to P6 and export it as an XER file. While in P6,

a couple of important steps should be taken to prevent any potential conflicts. For example, in NetPoint, the

relationship calendar is based on the predecessor activity. This should have been set in P6 from the onset,

but if not, it should be reviewed and updated beforehand (see “in P6″ steps below). In addition, the project

should be “scheduled” to avoid any potential terminations and “summarized” to ensure that the project start

and end dates are correct. And finally, all activities should be of the “task-dependent” type.

Upon importing, a new NetPoint file will be created and the data from the XER file brought in. At this time, you

cannot update or import into an existing NetPoint schedule. If the schedule was created in P6, or if it was

created in NetPoint using a version prior to 4.1, release 25 Feb 2013, the user should run the automated

layout engine to optimize the network. For more information, see Running the Engine. Instructions for

importing are provided below.

NOTE: Any start dates later than noon will be adjusted to the beginning of the next day; any finish

dates earlier than noon will be adjusted to the end of the previous day. This will result in dates that

are different from those in P6. This can be avoided by making sure all activities start before noon

and end after noon.

Steps

In P6

1. While viewing the desired project, click Tools > Schedule from the menu bar. If this project has already

been imported before, skip to step 1.4.

a. Click the Options button.

b. Under Calendar for Scheduling Relationship Lag, make sure Predecessor Activity Calendar is

selected*.

c. Click Close.

d. Click the Schedule button.

2. Click Tools > Summarize > Open Projects from the menu bar.

3. Click OK.

4. Click File > Export from the menu bar. With Primavera PM / MM – (XER) selected, click Next.

5. With Project selected, click Next.

6. Check the box next to the desired projects and click Next.

7. Name the file and click Finish.

*NOTE: Changing the calendar for the relationship lag can potentially affect activity dates. If the

calendar is changed, please review the schedule afterward.

In NetPoint

1.

Click File >

Import/

Export from

the menu bar

and choose
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Import from

Primavera

(XER)…

2.

Browse for the

desired XER

file and click

Open.

3.

If the file

contained more

than one

project, choose

the desired one

from the

dropdown

above the list.

Otherwise, skip

to step 4.

NOTE: At this

time, only one

project can be

imported at a

time.
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4.

To exclude an

item from being

imported,

uncheck the

box under the

Import column

next to its

name in the list.

When finished,

click Import.

5.

A report will

open showing a

summary of

any

incompatibilities

that were

found.

When ready,

click Finalize

Import. The

schedule will

then open in

NetPoint.

Notes

Unsupported Fields

NetPoint characteristics that are not maintained during round-trip import and export include: layouts, delays,

shades, notepads, text objects, link geometries, custom positioning (of descriptions, dates, etc.), resource

limits, resource formatting (color, histogram pattern, color intensity), page size and tiling, grid spacing, canvas

color, calendar strips and sightlines, and global text size.

Supported Fields

The following fields are brought into NetPoint. If a field is not listed, then it does NOT transfer. Some

examples of fields that do not transfer are identified where relevant.

Objects

The following objects and their fields are imported:
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This field
in P6

Becomes
this field

in
NetPoint

Notes

Task

Dependent
Activity

Start/Finish

Milestone

Start/

Finish

Milestone

For benchmarks, see Constraints below.

Level of

Effort
Hammock

Only LOE’s which are connected to their fragnet by start-to-start AND

finish-to-finish relationships will be imported as hammocks.

Lag

Embedded

node or

link lag

If positive, the lag will be captured in the embed unless it is larger than the

duration of the activity, in which case it will be captured in the link lag. If

negative, it will be captured in the link lag for FS relationships or otherwise

ignored.

Documents
Info

Objects

Documents associated with activities, milestones, or benchmarks will be

assigned to the appropriate object. Project documents will become info

objects on the canvas.

Activity

Name
Description

Activity ID ID

Start Start Date Start dates later than noon are adjusted to the beginning of the next day.

Finish
Finish

Date
Finish dates earlier than noon are adjusted to the end of the previous day.

Actual

Start
Start Date

Actual

Finish

Finish

Date

Original

Duration
Duration

Remaining

Duration

Remaining

Duration
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This field
in P6

Becomes
this field

in
NetPoint

Notes

Actual

Duration
Duration

Free Float Buffer

Total Float Total Float

Calendars

In NetPoint, calendars are based on 24 hours/day whereas in P6, calendars can have different numbers of

working hours/day. After a round trip (P6 -> NetPoint -> P6), all calendars will get the same number of

working hours/day. This may cause changes in duration of assigned activities and in effect the schedule.

Any calendars at the project level will transfer, regardless of whether or not they’ve been assigned; any

calendars at the global level will transfer, as long as they have been assigned to at least one activity; and any

global calendars from which a project calendar was created will transfer.

Resources

Any resource that has been assigned, regardless of which project it is under, will be brought into NetPoint;

however, any resources that haven’t been assigned, even if within the same project, will not transfer. In

addition, NetPoint only supports resources on activities. This means any activities with 0 duration (delays),

milestones, or levels of effort (hammocks) will not have their resources transfer.

If you plan on bringing the schedule back into P6 after bringing it into NetPoint, consider using only resources

from within the same project, since NetPoint will assign a unique ID resulting in duplicate assignments. For

more details, see the Resources section in Exporting to P6.

If any activities in P6 have fractional durations (e.g. 5.5 days) and are imported into a day-based NetPoint

schedule, NetPoint will round their durations based on when in the day the activities finish (down if finishing

before noon, or up if finishing after noon). Resources would then be distributed based on the assignment

selected for the activity (per day or per duration). If per duration is chosen, the rate will remain constant. The

following fields are imported:

This
field in

P6

Becomes
this field

in
NetPoint

Notes

Resource

Name
Name
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This
field in

P6

Becomes
this field

in
NetPoint

Notes

Price/

Unit
Cost/Day

P6 stores the price/unit using hours (e.g. $0.125/hour). When the XER file is

exported from P6, this value is rounded to 2 decimal places (e.g. $0.13),

which is then converted to cost/day, resulting in a different overall value. After

importing from P6, it is recommended to review the cost/day of each resource

to correct for any significant differences due to rounding.

Resource

Type
Category

Budgeted

Units

Rate/Dur

or Rate/

Day

An activity with duration type of “fixed units” will have its resources end up as

rate/duration. An activity with duration type “fixed units/time” will have its

resources end up as rate/day. When the XER file is exported from P6, this

value is rounded to 1 decimal place (e.g. 0.15/day would become 0.2/day),

resulting in a different overall value. After importing from P6, it is

recommended to review the assignments of each resource to correct for any

significant differences due to rounding.

NOTE: The “Resource ID” field from P6 does not transfer.

Codes

Activity codes in P6 transfer to NetPoint. This includes all codes from the project level plus any codes from

the global level that have had at least one of their values assigned. Unassigned values of global codes will not

be brought into NetPoint.

If you plan on bringing the schedule back into P6 after bringing it into NetPoint, consider using only project

codes instead, since NetPoint will not be able to re-export them back as global. For more details, see the

Codes section in Exporting to P6.

This field in P6 Becomes this field in NetPoint Notes

Activity Code Name Name

Description Value

NOTE: The “Code Value” field is transferred into NetPoint but cannot be edited

Constraints

P6 supports several constraints; however, NetPoint only supports start-no-earlier than and finish-no-later

than. If any milestones have must-start-on or must-finish-on constraints, they will be converted to benchmarks
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automatically. All other constraint types will be ignored, which may lead to different network behavior. The

following constraints are imported:

This field in P6 Becomes this field in NetPoint Notes

Finish On/Mandatory Finish (milestones) Finish benchmark On activities, ignored.

Finish On Or After (finish milestones) Finish-no-earlier than (FNE) On activities, ignored.

Finish On Or Before Finish-no-later than (FNL)

Start On/Mandatory Start (milestones) Start benchmark On activities, ignored.

Start On Or After Start-no-earlier than (SNE)

Start On Or Before (start milestones) Start-no-later than (SNL) On activities, ignored.

Relationships

P6 allows FS relationship for start and finish milestones; however, in NetPoint a link with a start milestone as

predecessor can only be SS or SF; a link with a finish milestone as successor can only be FF or SF. After a

round trip, such links on milestones using FS links will be changed to match NetPoint requirements.
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Exporting to P6

When exporting, keep in mind that there are many differences between NetPoint and P6. Items like

resources, calendars, codes, and constraints, for example, are all handled slightly differently. In addition,

some characteristics are not maintained during round-trip import and export. For a full list of supported fields,

see the notes at the end of this section.

Before exporting, if any activities or milestones have been scheduled on planned-dates, make sure to follow

the instructions in Preparing to Export from NetPoint (GPM). Once exported, the XER file must be imported

into P6 to complete the process.

NOTE: Before attempting to update an existing project in P6, make sure to see Tips for Round-

Trip below.

Steps

In NetPoint

1.

Click File > Import/

Export from the

menu bar and

choose Export to

Primavera (XER).

2.

Enter a P6 Project

ID (name) and

choose the XER

version closest to

your version of P6.

NOTE: If you want

to update an

existing project in

the P6 database,

make sure you

enter the same P6

Project ID. Before

attempting to

update, see Tips

for Round-

Trip below.

3.

If desired, check

the box under

Calendars to

export them as

global.
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NOTE: If

unchecked, they

will be exported at

the project level.

4.

If desired, check

the box under

Project Codes

and/or Project

Resources to

export them each,

respectively.

NOTE: If you want

to update an

existing project in

the P6 database,

checking this box

will result in

duplicate codes

and values. For

more info, see

Codes below.

5.

If desired, choose a

different or custom

range for Working

Hours/Day.

NOTE: In a day-

based schedule,

NetPoint does not

distinguish

between which

hours are working

and which hours

are not. These

options allow you

to configure how

P6 will handle

resources and

other properties,

before it’s even

opened in P6.
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6.
When finished, click

Next.

7.

If satisfactory, click

Export.Otherwise,

click

Configure and

return to step 2.
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8.
Enter a name and

click Save.

In P6

1. Click File > Import from the menu bar.

2. In the Import Format screen, with Import PM / MM (XER) selected, click Next.

3. In the Import Type screen, with Project selected, click Next.

4. In the File Name screen, click … to the right of the file path, browse for the desired XER file, and click

Open.

5. In the File Name screen click Next.

6. In the Import Project Options screen, if the Project ID that was entered on export from NetPoint already

exists in the P6 database, the check box under Match will be selected. Even though match is checked,

you’ll have the option under Import Action to update the existing project, create a new one, add to,

ignore, or replace. Once chosen, click Next.*

7. In the Update Project Options screen, click Next.

8. In the Finish screen, click Finish.

9. In the confirmation, click OK.

10. With the schedule open, click Tools > Schedule from the menu bar (or press F9 on the keyboard).

11. Click Schedule. All activities will move to their early dates.

*NOTE: Before attempting to update an existing project, see Tips for Round-Trip below.

Notes

Tips for Round-Trip

How to “update” an existing project depends on the nature of each project itself. If a project hasn’t been coded

or resource-loaded, choosing Update Existing Project will be straightforward. However, if a project has been

coded or resource-loaded, choosing to update may result in duplicate codes, resources, and

assignments. For more info, see Codes and Resources below. Another option is to choose Replace Existing

Project; however, be careful, as any additional project data not stored by NetPoint, such as baselines and

timesheets will be deleted.
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Unsupported Fields

Characteristics that are not maintained during round-trip import and export include: layouts, delays, shades,

notepads, text objects, link geometries, custom positioning (of descriptions, dates, etc.), resource limits,

resource formatting (color, histogram pattern, color intensity), page size and tiling, grid spacing, canvas color,

calendar strips and sightlines, and global text size.

Supported Fields

The following fields are sent out from NetPoint. If a field is not listed, then it does NOT transfer.

Objects

The following objects and their fields are exported:

This field
in

NetPoint

Becomes this field
in P6

Notes

Activity,

Delay
Task Dependent

Milestones

and

benchmarks

(both start

and finish)

Start/Finish Milestone
Benchmarks in NetPoint become milestones with Mandatory

Start or Mandatory Finish constraints in P6 accordingly.

Hammock Level of Effort

Any unconnected milestones or benchmarks will be

connected to the LOE with a start-to-start or finish-to-finish

relationship accordingly.

Embed, link

lag
Lag

If both exist in the same relationship, they will be combined.

For example, an SS relationship with a link lag of 5 days and

an embed lag of 5 days will transfer as an SS with 10 day

lag in P6.

Info Object Documents

Info objects that have been attached to activities,

milestones, or benchmarks will be assigned to the

appropriate object. Info objects drawn on the canvas will

also be exported and associated with the exported project

Description Activity Name Any description over 120 characters will be truncated.

ID Activity ID If empty, IDs are created in P6 with prefix “~”.

Start Date Start, Actual Start

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 285 of 344



This field
in

NetPoint

Becomes this field
in P6

Notes

Finish Date Finish, Actual Finish

Duration
Original Duration, Actual

Duration

Remaining

Duration
Remaining Duration

No-earlier-

than

Constraint

Start On Or After (for

activities and start

milestones), Finish On

Or After (for finish

milestones)

No-later-

than

Constraint

Finish On Or Before

(activities and finish

milestones), Start On Or

Before (start

milestones)

Buffer Free Float

Total Float Total Float

Grid Position —
This field is exported for round-trip purposes only and isn’t

used in P6.

Color —
This field is exported for round-trip purposes only and isn’t

used in P6.

Shape

(milestones/

benchmarks)

—
This field is exported for round-trip purposes only and isn’t

used in P6.

Text

Formatting
—

This field is exported for round-trip purposes only and isn’t

used in P6. Includes font, color, alignment, style, size, and

line breaks.
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This field
in

NetPoint

Becomes this field
in P6

Notes

Text Display —

This field is exported for round-trip purposes only and isn’t

used in P6. Includes whether text fields, date fields, float

fields, etc. are turned on or off.

Calendars

In NetPoint, calendars are based on 24 hours/day whereas in P6, calendars can have different numbers of

working hours/day. After a round trip (P6 -> NetPoint -> P6), all calendars will get the same number of

working hours/day. This may cause changes in duration of assigned activities and in effect the schedule.

If Create Calendars as Global is checked but a calendar created in P6 with the same name already exists in

the global record, it will NOT be overwritten or replaced. Instead, another calendar will be created with its own

properties and assigned to the corresponding activities. The latest one will always show up last behind any

other identically named calendars. Recurring holidays (“fixed-date” holidays in NetPoint with a repeat factor of

1 year) will transfer individually, with each case being a separate holiday.

If you plan on updating an existing P6 project, consider avoiding the use of the two NetPoint default calendars

(“United States” and “Calendar Days”). In fact, it is strongly recommended to delete them from within P6 after

exporting (if they were exported as global, delete them from the global record; if they were exported from the

project level, delete them from the project record). This should be done after every export to P6 to prevent

duplicates in NetPoint when being brought back in.

Resources

Resources are transferred to P6 in the root level under “R-<ProjectID>”. This means if you export a project

from P6 to NetPoint with resources from a different project, and then you import it back into P6 choosing to

update the existing project, you will have duplicate resources and assignments: one from the other project

and one from the current project, since the resource ID will have changed. This will only happen the first time

the P6 schedule is updated. To work around this, make sure all the resources you’ve assigned in P6 are from

within the same project.

The primary resource setting is also not maintained, which will need to be reset manually after the round

trip. Any resources assigned to objects other than activities will not be imported by NetPoint and therefore get

removed after the round trip

NOTE: When using PolyTime, resource assignments may be inaccurate when exporting a plan that

uses any time unit other than days. The following approaches may be taken to correct the outcome:

1) wait to resource load the schedule until the file is exported; 2) reassign every resource to every

activity after exporting to correct the values; or 3) delete the resource assignments prior to

exporting and start with a clean resource-assignment slate, but with the resources defined.
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This
field in

NetPoint

Becomes
this field

in P6
Notes

Name

Resource

ID,

Resource

Name

The “Resource ID” field is filled in with the name of the resource as well.

Cost/Day Price/Unit
P6 stores the cost per hour. For example, $1 dollar per day will be

transferred to P6 as $0.125/hour.

Category
Resource

Type

Any category other than material, equipment, and labor is converted to

material, equipment, or labor.

Rate/Dur,

Rate/Day

Budgeted

Units &

Remaining

Units

In NetPoint, an activity may have some resources assigned to it “per day”

and other resources assigned to it “per duration”. This is called a mixed

assignment. In P6, the resource assignments for a given activity must be all

of the same type. If an activity has its resources exported per day, that

activity will have its duration type set as “fixed units/day” in P6. If an activity

has its resources exported per duration, that activity will have its duration

type set as “fixed units” in P6. For more on distribution types, see

Assignment Options. If the activity is in progress or actualized, resource data

will also be mapped to the “Actual Units”.

NOTE: Limits, Histogram Pattern, Color, and Color Intensity are not exported at this time.

Codes

Codes in NetPoint transfer as activity codes in P6. NetPoint cannot export codes as global, meaning all codes

will end up at the project level. For example, if you export a project from P6 to NetPoint with codes that were

global, and then you import it back into P6 choosing to update the existing project, you will have duplicate

assignments: one from the global level version of the code and one from the project level version of the code.

The following fields are exported:

This
field in

NetPoint

Becomes
this field

in P6
Notes

Name

Activity

Code

Name
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This
field in

NetPoint

Becomes
this field

in P6
Notes

Value Description

In NetPoint, multiple values per code may be assigned to the same activity.

In P6, however, only one value per code may be assigned to the same

activity. Project codes are not exported if they are set to have multiple values

in NetPoint (even if only one value is actually defined for the code or

assigned to an activity).

NOTE: The “Code Value” field in P6 will be filled in with a unique ID generated by NetPoint.
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Deltek Open Plan

NetPoint features round-trip importing and exporting with Deltek Open Plan. This works by asking the user for

a username and password and then establishing a connection with the Open Plan database located on the

same machine as NetPoint. Schedules can be exported from NetPoint, updated externally, and imported back

in. Information such as logic and lags, grid position, colors, milestone and benchmark shapes, text formatting

(e.g. fonts, sizes, if descriptions are on two lines, etc.), and which data elements have been turned on or off

are all maintained, meaning that if a schedule is imported back into NetPoint, it will still look the same as it did

before.

NOTE: Delays, link shapes, resource formatting (e.g. color, pattern, etc.), and canvas objects (e.g.

shades, notepads, and text objects) are not maintained during round-trip import/export. For a full

list of supported fields, see the following sections.

This section details instructions for the following:

1. Importing from Open Plan

2. Exporting to Open Plan
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Importing from Open Plan

To import a schedule, the user must have a username and password to access the Open Plan database, and

the project must be stored on the same machine as NetPoint.

After importing, the plan will vary slightly depending on whether or not the schedule was originally created in

NetPoint or Open Plan. If the schedule was originally created in NetPoint, subsequently exported, and is now

being imported back, the look and layout of the schedule will be the same. If the schedule was created in

Open Plan, or if it was created in NetPoint using a version prior to 4.1, release 25 Feb 2013, NetPoint will

layout the network avoiding clashes, but the user should run the automated layout engine. For more

information, see Running The Engine. If further manual repositioning of data elements is desired,

see Repositioning Fields (GEM) .

NOTE: The calendar for a relationship (link) cannot be defined as that of the predecessor. As a

result, dates and float values in NetPoint will not align with those in Open Plan in the case where the

calendar chosen for relationships in Open Plan has different holidays over the course of a link than

those of its predecessor’s calendar.

Steps

In Open Plan

1. In Open Plan, click Project > Time Analysis from the menu bar (or press F9 on the keyboard), enter

a Time Now, and click OK.

2. Close the project to ensure that NetPoint can access it properly.

In NetPoint

1.

In NetPoint,

click File >

Import/

Export… from

the menu bar

and choose

Import From

Open Plan…

2.

If Open Plan is

already open,

skip to step 3.

If Open Plan

isn’t open,

you’ll be

prompted to

enter your

Open Plan
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credentials and

click OK.

3.

Browse for the

desired project,

select it in the

list, and

click Import.

4.

A report will

open showing a

summary of

any

incompatibilities

that were

found.

When ready,

click Finalize

Import. The

schedule will

then open in

NetPoint

Notes

Objects

The following objects and their fields are imported:
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This field
in Open

Plan

Becomes
this field

in
NetPoint

Notes

Activity Activity

Start/

Finish

Milestone

Start/

Finish

Milestone

For benchmarks, see Constraints below.

Hammock Hammock

Lag
Embed or

link lag

If positive, the lag will be captured in the embed unless it is larger than the

duration of the activity, in which case it will be captured in the link lag. If

negative, it will be captured in the link lag for FS relationships, otherwise

ignored.

Description Description

ID ID

Start Start Date

Finish
Finish

Date

Duration Duration

Free Float Buffer

Total Float Total Float

Calendar Calendar

Holidays will only be included if they fall between the start and end dates of

the project. If a holiday coincides with a non-working day, it will not be

transferred into NetPoint.

Resources

NetPoint imports resources on a full-time basis only. For example, if any activities in Open Plan have

fractional durations (e.g. 5.5 days) and are imported into a day-based NetPoint schedule, NetPoint will round

their durations based on when in the day the activities finish (down if finishing before noon, or up if finishing

after noon). Resources would then be distributed based on the assignment selected for the activity (per day or

per duration). If per duration is chosen, the rate will remain constant. Check the pre-import report for any

discrepancies in activity durations or resource assignments. The following fields are imported:
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This field
in Open

Plan

Becomes
this field

in
NetPoint

Notes

Description Name

Unit Cost Cost/Day

Category Category

Resource

Level
Rate/Day

Open Plan only supports units/day. When importing, this value is rounded to

1 decimal place (e.g. 0.15/day would become 0.2/day), resulting in a

different overall value. After importing from Open Plan, it is recommended

to review the assignments of each resource to correct for any significant

differences due to rounding.

Codes

Activity codes in Open Plan become project codes in NetPoint. Assignments, along with the following fields,

are imported:

This field in Open Plan Becomes this field in NetPoint Notes

Code Name

Value Value

Constraints

Open Plan supports several constraints; however, NetPoint only supports start-no-earlier than and finish-no-

later than. If any milestones have must-start-on or must-finish-on constraints, they will be converted to

benchmarks automatically. All other constraint types will be ignored, which may lead to different network

behavior. The following constraints are imported:

This field in Open Plan Becomes this field in NetPoint Notes

Fixed Target (milestones) Benchmark On activities, ignored.

Not Earlier Than Start/finish no-earlier-than (SNE/FNE) On activity finish date, ignored.

Not Later Than Start/finish no-later-than (SNL/FNL) On activity start date, ignored.

On Target (milestones) Benchmark On activities, ignored
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Exporting to Open Plan

To export a schedule, the user must have a username and password to access the Open Plan database. The

exported schedule will be stored on the same machine as NetPoint.

When exporting, keep in mind that there are many differences between NetPoint and Open Plan. Items like

resources, calendars, codes, and constraints, for example, are all handled slightly differently. An explanation

of these difference can be found in the notes below. If any activities or milestones have been scheduled on

planned-dates, make sure to follow the instructions in Preparing to Export from NetPoint (GPM) before

exporting.

Steps

In NetPoint

1.

Click File > Import/Export from

the menu bar and choose Export

to Open Plan.

2.

Enter your Open Plan

credentials and choose a Project

Name.

NOTE: If Open Plan is already

open, the Username and

Password will already be

known and disabled

accordingly.

3.

If desired, check the box

under Project Codes and/

or Project Resources to export

them each, respectively.
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4.

When finished, click OK. The

schedule will appear under the

Projects node in the Open Plan

Explorer window.

5. Click OK to confirm.

In Open Plan

1. With the schedule open in Open Plan, click Project > Time Analysis from the menu bar (or press F9 on

the keyboard).

2. Specify current time and click OK.

Notes

Objects

The following objects and their fields are exported:

This field
in

NetPoint

Becomes
this field
in Open

Plan

Notes

Activity,

Delay
Activity
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This field
in

NetPoint

Becomes
this field
in Open

Plan

Notes

Milestones

and

benchmarks

(both start

and finish)

Start/

Finish

Milestone

Milestones that were benchmarks in NetPoint are given Fixed Target

dates Open Plan.

Hammock Hammock

Each hammock must include at least one member activity. Otherwise, the

schedule may not export or network logic may not transfer. Furthermore,

we recommend that hammocks contain a continuous network of member

objects.If present in hammocks, a start milestone or benchmark must

have at least one successor within the hammock and a finish milestone or

benchmark must have at least one predecessor within the hammock. Any

unconnected milestones or benchmarks will be connected to the LOE

with a start-to-start or finish-to-finish relationship accordingly.

Embedded

nodes and

link lags

Lag

If both exist in the same relationship, they will be combined. For example,

an SS relationship with a link lag of 5 days and an embed lag of 5 days

will transfer as an SS with 10 day lag in P6.

Description Description Any description over 100 characters will be truncated.

ID ID If empty, IDs are created in Open Plan with prefix “NP”.

Start Date Start

Finish Date Finish

Duration Duration

No-earlier-

than

Constraint

Not Earlier

Than
Constraints transfer to “Target Dates” in Open Plan

No-later-

than

Constraint

Not Later

Than
Constraints transfer to “Target Dates” in Open Plan

Buffer Free Float

Total Float Total Float
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This field
in

NetPoint

Becomes
this field
in Open

Plan

Notes

Calendar Calendar

Recurring holidays (“fixed-date” holidays in NetPoint with a repeat factor

of 1 year) will transfer individually, with each case being a separate

holiday.

Grid Position —
This field is exported for round-trip purposes only and isn’t used in Open

Plan.

Color —
This field is exported for round-trip purposes only and isn’t used in Open

Plan.

Shape

(milestones/

benchmarks)

—
This field is exported for round-trip purposes only and isn’t used in Open

Plan.

Text

Formatting
—

This field is exported for round-trip purposes only and isn’t used in Open

Plan. Includes font, color, alignment, style, size, and line breaks.

Text Display —
This field is exported for round-trip purposes only and isn’t used in Open

Plan. Includes text fields, date fields, float fields, etc.

Resources

In NetPoint, an activity may have some resources assigned to it “per day” and other resources assigned to it

“per duration”. This is called a mixed assignment. In Open Plan, all resource assignments are assigned per

day. For more on distribution types, see Assignment Options. The following fields will be exported:

NOTE: When using PolyTime, resource assignments may be inaccurate when exporting a plan that

uses any time unit other than days. The following approaches may be taken to correct the outcome:

1) wait to resource load the schedule until the file is exported; 2) reassign every resource to every

activity after exporting to correct the values; or 3) delete the resource assignments prior to

exporting and start with a clean resource-assignment slate, but with the resources defined.

This field
in

NetPoint

Becomes this
field in Open

Plan
Notes

Name Description

Cost/Day Unit Cost
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This field
in

NetPoint

Becomes this
field in Open

Plan
Notes

Category Category
“Material” and “commodity” become “material”, “dollars” becomes

“other direct cost”, and every other type becomes “labor”.

Rate/Dur,

Rate/Day
Resource Level

Upon export, all resource assignments are converted to units per

day.

NOTE: Histogram, Color, and Color Intensity are not exported at this time.

Codes

In NetPoint, multiple values per code may be assigned to the same activity. In Open, however, only one value

per code may be assigned to the same activity. Project codes are not exported if they are set to have multiple

values in NetPoint (even if only one value is actually defined for the code or assigned to an activity). The

following fields are exported:

This field in NetPoint Becomes this field in Open Plan Notes

Name Code

Value Value
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Microsoft Project

NetPoint features round-trip importing and exporting with MS Project 2007 and 2010. This is done by first

exporting an XML file from one application and then importing it into the other. Information such as logic and

lags, grid position, colors, milestone and benchmark shapes, text formatting (e.g. fonts, sizes, if descriptions

are on two lines, etc.), and which data elements have been turned on or off are all maintained, meaning that if

a schedule is imported back into NetPoint, it will still look the same as it did before.

NOTE: Delays, link shapes, resource formatting (e.g. color, pattern, etc.), and canvas objects (e.g.

shades, notepads, and text objects) are not maintained during round-trip import/export. For a full

list of supported fields, see the following sections.

This section details instructions for the following:

1. Importing from MS Project

2. Exporting to MS Project
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Importing from MS Project

An imported plan will vary slightly depending on whether or not the schedule was originally created in

NetPoint or MS Project. If the schedule was originally created in NetPoint, subsequently exported, and is now

being imported back, the look and layout of the schedule will be the same. If the schedule was created in MS

Project, or if it was created in NetPoint using a version prior to 4.1, release 25 Feb 2013, NetPoint will layout

the network avoiding clashes, but the user should run the automated layout engine. For more information, see

Running the Engine. If further manual repositioning of data elements is desired, see Repositioning Fields

(GEM). Instructions are provided below.

Steps

In MS Project

1. While viewing the desired schedule, click File > Save As from the menu bar.

2. Click next to Save as type and choose XML Format (*.xml).

3. If desired, change the File name and click Save.

In NetPoint

1.

Click File >

Import/

Export from

the menu bar

and choose

Import from

MS Project

XML…

2.

Browse for the

desired XML

file and click

Open.
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3.

A report will

open showing a

summary of

any

incompatibilities

that were

found.

When ready,

click Finalize

Import. The

schedule will

then open in

NetPoint.

Notes

Objects

The following objects and their fields are imported:

This
field in
MSP

Becomes
this field

in
NetPoint

Notes

Task Activity

Task (with

0

duration)

Start/

Finish

Milestone

If the task has no predecessor or starts before noon, it becomes a start

milestone. Otherwise, it becomes a finish milestone.

Summary

Task
Hammock Only one level (the lowest) is brought in.

Lag

Embedded

node or

link lag

If positive, the lag will be captured in the embed unless it is larger than the

duration of the activity, in which case it will be captured in the link lag. If

negative, it will be captured in the link lag for FS relationships, otherwise

ignored.

Name Description

NetPoint

Activity ID
ID

If the NetPoint Activity ID field isn’t available, then the information in the ID

field will transfer over.
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This
field in
MSP

Becomes
this field

in
NetPoint

Notes

(custom

field)

Start Start Date

Finish
Finish

Date

Actual

Start
Start Date

Actual

Finish

Finish

Date

Duration Duration

Remaining

Duration

Remaining

Duration

Actual

Duration
Duration

Free Slack Buffer

Slack Total Float

Calendar Calendar
Repeating holidays that do not occur within the entire range of the project

will transfer as individual holidays to NetPoint.

Resources

MS Project only supports units/day; any schedule that was exported from NetPoint and then brought in should

be have its resource assignment distributions reviewed.The following resource fields are imported:

This field in MSP Becomes this field in NetPoint Notes

Resource Name Name

Std. Rate Cost/Day
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This field in MSP Becomes this field in NetPoint Notes

Type Category

Work (also Units) Rate/Day MS Project only supports units/day.

Codes

Codes that have been entered in the Custom Fields tab of a task will become project codes in NetPoint. The

following fields are imported:

This field in MSP Becomes this field in NetPoint Notes

Custom Field Name Name

Value Value

Constraints

MS Project supports several constraints; however, NetPoint only supports start-no-earlier than and finish-no-

later than. If any milestones have must-start-on or must-finish-on constraints, they will be converted to

benchmarks automatically. The following constraints are imported:

This field in MSP Becomes this field in NetPoint Notes

Must Start On Start benchmark On activities, ignored.

Must Finish On Finish benchmark On activities, ignored.

Start No Earlier Than Start No Earlier Than

Start No Later Than Ignored

Finish No Earlier Than Ignored

Finish No Later Than Finish No Later Than
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Exporting to MS Project

When exporting, keep in mind that there are many differences between NetPoint and MS Project. Items like

resources, calendars, codes, and constraints, for example, are all handled slightly differently. An explanation

of these difference can be found in the notes below.

Before exporting, if any activities or milestones have been scheduled on planned-dates, make sure to follow

the instructions in Preparing to Export from NetPoint (GPM). Once exported, the XML file must be imported

into MS Project to complete the process. Instructions for both are provided below.

Steps

In NetPoint

1.

Click File > Import/

Export from the

menu bar and choose

Export to MS

Project XML…

2.
Enter a new name

and click Save.

In MS Project

1. Click File > Open from the menu bar.

2. Click the button next to File name and choose XML Format (*.xml)

3. Browse for the desired XML file and click Open.

4. Choose how to import the project and click Finish.

Notes

Objects

The following objects and their fields are exported:
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This field in
NetPoint

Becomes
this field in

MSP
Notes

Activity, Delay Task

Milestones and

benchmarks

(both start and

finish)

Task (with 0

duration and

set as

milestone)

Benchmarks in NetPoint become milestones with Must Start On or

Must Finish On constraints accordingly.

Hammock
Summary

Task

Embedded

nodes and link

lags

Lag

If both exist in the same relationship, they will be combined. For

example, an SS relationship with a link lag of 5 days and an embed

lag of 5 days will transfer as an SS with 10 day lag in P6.

Description Name Any description over 255 characters will be truncated.

ID

NetPoint

Activity ID

(custom field)

ID’s in MS Project are numeric only.

Start Date
Start, Actual

Start

Finish Date
Finish, Actual

Finish

Duration

Duration,

Actual

Duration

Remaining

Duration

Remaining

Duration

No-earlier-than

Constraint

No Earlier

Than

Constraint

In MS Project, only one constraint per task is supported. If an

activity or milestone in NetPoint has 2 constraints, only the start

constraint will be transferred.

No-later-than

Constraint

No Later

Than

Constraint

In MS Project, only one constraint per task is supported. If an

activity or milestone in NetPoint has 2 constraints, only the start

constraint will be transferred.
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This field in
NetPoint

Becomes
this field in

MSP
Notes

Buffer Free Slack

Total Float Slack

Calendar Calendar Holidays only export within the project start and completion.

Grid Position —
This field is exported for round-trip purposes only and isn’t used in

MS Project.

Color —
This field is exported for round-trip purposes only and isn’t used in

MS Project.

Shape

(milestones/

benchmarks)

—
This field is exported for round-trip purposes only and isn’t used in

MS Project.

Text Formatting —

This field is exported for round-trip purposes only and isn’t used in

MS Project. Includes font, color, alignment, style, size, and line

breaks.

Text Display —
This field is exported for round-trip purposes only and isn’t used in

MS Project. Includes text fields, date fields, float fields, etc.

Resources

In NetPoint, an activity may have some resources assigned to it “per day” and other resources assigned to it

“per duration”. This is called a mixed assignment. In MS Project, all resource assignments are assigned per

day. For more on distribution types, see Assignment Options. The following fields will be exported:

This
field in

NetPoint

Becomes
this field
in MSP

Notes

Name
Resource

Name

Cost/Day Std. Rate

Category Type

“Material” and “commodity” become “material”, “dollars” becomes “cost”, and

every other type becomes “work”. KNOWN ISSUE: The unit cost for a

resource with category “dollars” in NetPoint exports as 0.
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This
field in

NetPoint

Becomes
this field
in MSP

Notes

Rate/Dur,

Rate/Day

Work (also

Units)
Upon export, all resource assignments are converted to units per day.

NOTE: Histogram, Color, and Color Intensity are not exported at this time.

Codes

In NetPoint, multiple values per code may be assigned to the same activity. In MS Project, however, only one

value per code may be assigned to the same activity. Project codes are not exported if they are set to have

multiple values in NetPoint (even if only one value is actually defined for the code or assigned to an

activity). Single-assignment codes export to the Custom Fields tab.

This field in NetPoint Becomes this field in MSP Notes

Name Custom Field Name

Value Value
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Microsoft Excel

NetPoint features round-trip importing and exporting with Microsoft Excel 2010 onwards. This is useful for

spreadsheet-style data entry, building custom reports, working with raw schedule output, and for performing

custom analyses or computation methods otherwise not offered by NetPoint.

This section details instructions for the following:

1. Importing generic spreadsheets

2. Exporting linked reports

3. Updating from linked reports
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Importing Generic Spreadsheets

NetPoint allows you to import information from user-created spreadsheets. For example, you may have a list

of activities you’ve compiled in Excel based on previous projects or collected from different team

members. Upon importing, NetPoint will identify the fields that it recognizes and map them automatically;

however, some manual correction and mapping may be necessary. If any fields remain unmapped, or if the

same field is mapped to more than one column, the OK button will become disabled and warning icons will

appear. For a full list of supported fields, see the notes at the end of this chapter.

Before importing, make sure the Excel file has been saved, as the content from the most recently saved file

will be imported. If Excel is open, do not close it during any step of the import process, and vice versa. Also,

make sure that the sheet being imported isn’t protected, as this may interfere with the import process. Data

can be imported into new or previously-saved schedules.

NOTE: Upon import, any comments on cells in Excel will be removed. To avoid loss of any

comments, duplicate the Excel file and import the duplicate.

Steps

1. With NetPoint open, click File > Import/Export from the menu bar and choose Import From Excel

File…. An explorer window will open.

2. Browse for the desired Excel file and click Open. The Import from Excel window will open.

3. To change to a different sheet, click the down arrow next to Import Sheet and choose accordingly.

4. To change to a different row, click the arrows up or next next to Based on Row.

5. To include or exclude data from a given column, check or uncheck the box next to its name.

6. To map a new field or correct a default mapping, click the down arrow button to the right and choose

accordingly.

7. Once all fields are mapped successfully, click OK. A report will open listing any warnings found

(all warnings will be added to the cells in Excel if the file was closed beforehand).

8. To correct any invalid data, click Cancel Import.

9. To continue with the import, click Finalize Import.

Notes

Supported Fields

Object Type

For an activity, enter as “activity,” “task,” “task dependent,” “fixed units,” “fixed duration,”

or “fixed work”. For a milestone, enter as “milestone,” “start milestone,” “sm,” “finish

milestone,” or “fm”. For a benchmark, enter as “benchmark,” “start benchmark,” “sb,”

“finish benchmark,” and “fb”. For delay, enter as “delay”. If missing or invalid, it will be

imported as an activity.

ID
Can be any combination of letters and numbers (case sensitive). Characters such as “-”

are supported but others such as “#” will be dropped.

Description Can be any combination of letters, numbers, and characters.
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Calendar

Must be defined in the file you are importing into. For example “United States” or

“Calendar Days”. Case sensitive. To assign a global calendar, make sure to include

[space][parenthesis]Global[parenthesis], e.g. “Calendar (Global)”. If missing or invalid, it

will be set to the default calendar for the schedule you’re importing into.

Duration

Must be greater than 0 for activities and equal to 0 for milestones and benchmarks. If

missing or invalid, it will be set as 1 for activities and 0 for milestones, benchmarks, and

delays.

Start Date

Can be entered in any date format recognized by Excel, including but not limited to: 3/

14/2012; 3/14/12; 03/14/12; 14-Mar-12; 14-Mar-2012; March 14, 2012; Wednesday,

March 14, 2012. If a date is entered that is not in that object’s calendar’s work days, the

object goes to the next work day for that calendar. If missing or invalid, it may be set to

its early date. NOTE: If a cell hasn’t been formatted as a date, then the date will be

brought in according to the date format of the operating system. For example, 1/2/

13 will be brought in as February 1st if Windows is using a UK format but January

2nd if Windows is using a US format.

Finish Date

Can be entered in any date format that is recognized by Excel, including but not limited

to: 3/14/2012; 3/14/12; 03/14/12; 14-Mar-12; 14-Mar-2012; March 14, 2012; Wednesday,

March 14, 2012. If a date is entered that is not in that object’s calendar’s work days, the

object goes to the next work day for that calendar. If missing or invalid, it may be set to

its early date. NOTE: If a cell hasn’t been formatted as a date, then the date will be

brought in according to the date format of the operating system. For example, 1/2/

13 will be brought in as February 1st if Windows is using a UK format but January

2nd if Windows is using a US format.

Predecessor

Enter as EITHER [Row #][Relationship][Lag] OR if ID’s are being defined,

[ID][Relationship][Lag], e.g. “12FS1″ or “ABFS1″. In either case “[Lag]” is optional, e.g.

“12FS” or “ABFS”. If ID’s are being defined, row numbers can NOT be used. Possible

relationships include SS, FS, FF, or SF. If the relationship or row #/ID is not recognized,

the link will not be imported.

Successor

Enter as EITHER [Row #][Relationship][Lag] OR if ID’s are being defined,

[ID][Relationship][Lag], e.g. “12FS1″ or “ABFS1″. In either case “[Lag]” is optional, e.g.

“12FS” or “ABFS”. If ID’s are being defined, row numbers can NOT be used. Possible

relationships include SS, FS, FF, or SF. If the relationship or row #/ID is not recognized,

the link will not be imported.

Color

Enter as EITHER R,G,B (for example, 255, 50, 50) OR by name. A list of supported

names can be found at http://www.rapidtables.com/web/color/RGB_Color.htm. If invalid

or not recognized, it will be set as the default color for that object.
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Exporting Linked Reports

The export to Excel feature is designed to provide a more flexible way to build reports and update schedules.

Custom spreadsheets can be configured based on any number and combination of objects and their data,

allowing you work with as much raw data as desired in order to build custom reports and templates for

updating schedules. Note that the resulting Excel files contain minimal formatting and presentation.

A few common combinations of data to export come pre-saved as templates to help get you started. Both

default and user-created templates are shared at the system-level, meaning that a template created for one

schedule will be available when working with any other schedule. You can choose to export data from an

existing template as-is, reconfigure an existing template and then export the data, or create a new template

altogether to export from. In addition, the export process can be automated and triggered directly from your

desktop by specifying the desired schedule and report ahead of time. Instructions for each are provided.

If you’re exporting data to Excel to edit and update NetPoint, the fields that can be edited are identified in

bold in the Configure Rows & Columns window in NetPoint and in the corresponding cells in Excel. All

other columns will be protected, except for the code table, resource table, and target sheets (for more on

protected sheets, see the notes at the end of this section). For more info on updating, see Updating from

Linked Reports.

WARNING: When a template is exported to Excel, the new Excel file will automatically overwrite the

last-exported Excel file (for that schedule) unless the last one was renamed or moved. To avoid losing

the previous Excel file, rename it or move it to a different location before doing the next export.

NOTE: The schedule will be saved each time a template is exported. To avoid having changes

permanently saved, save the schedule as a separate document first, or use Undo to roll back the

changes before closing the schedule.

Steps

Creating a New Template

1. With NetPoint open, click File > Import/Export from the menu bar and choose Export to Linked Excel

File.

2. Click the New button.

3. Make sure the circle is checked next to New Configuration.

a. To remove or add object, check the boxes next to their labels.

b. To include a field, select it in the Available list on the left and click the >> button.

c. To remove a field, select it in the Included list on the right and click the << button.

4. Once configured, click the Save button.

5. Enter a description and click Save.

6. To finish the export process, click the Export button. Excel will open with the exported data, and the file

will be automatically saved in the schedule’s project folder.

7. If you plan on exporting additional templates in the future, then we suggest renaming the file or moving it

to a different location to avoid having it being overwritten. Click File > Save As from the menu bar, enter

a name, and click Save. NOTE: If you DO rename or move the file, you can ONLY initiate an update

from it from within Excel. For more info, see Updating from Linked Reports.
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NOTE: When adding/removing fields, fields within Object Data, Links Data, Resource Data, and

Target Data will re-order themselves automatically. Fields within Predecessor Data, Successor Data,

Tables, and Hammocks will depend on the order that they’re added.

Modifying/Exporting an Existing Template

1. With NetPoint open, click File > Import/Export from the menu bar and choose Export to Linked Excel

File.

2. Choose a desired template from the list.

3. To export right away, click the Export button and skip to step 4. To modify first, click the Modify

button. NOTE: Only user-created templates can be modified. If you reconfigure a default template,

you will not be able to export it unless you first save it as a new template.

a. To remove or add objects, check the boxes next to their labels.

b. To include a field, select it in the Available list on the left and click the >> button.

c. To remove a field, select it in the Included list on the right and click the << button.

d. Once configured, click Save and continue to step 2e. To save it as a new template, click Save As.

a. Enter a description and click the Save button.

e. To finish the export process, click the Export button. Excel will open with the exported data, and the

file will be automatically saved in the schedule’s project folder.

4. If you plan on exporting additional templates in the future, then we suggest renaming the file or moving it

to a different location to avoid having it being overwritten. Click File > Save As from the menu bar, enter

a name, and click Save. NOTE: If you DO rename or move the file, you can ONLY initiate an update

from it from within Excel. For more info, see Updating from Linked Reports.

NOTE: When adding/removing fields, fields within Object Data, Links Data, Resource Data, and

Target Data will re-order themselves automatically. Fields within Predecessor Data, Successor Data,

Tables, and Hammocks will depend on the order that they’re added.

Automating the Export Process

1. In windows explorer, navigate to the location where NetPoint has been installed

2. Right-click on “NetPoint.exe” and click Create Shortcut.

3. In the notification, click Yes.

4. On the desktop, find the new shortcut and right-click and choose Properties.

5. Next to Target, add the following to the end, without the quotation marks: (space) “path” (space) “/”

“Report” (space) “template$1″ (space) “template$2″ (space) “etc.”, where (space) shouldn’t be spelled out

but just a single space from your spacebar, “path” is equal to the filepath for your schedule, “Report” is

just a required variable, and “template$n” is equal the name of the template(s) you want to export. Be

sure to substitute any spaces in your template name with dollar signs ($), and don’t forget to remove the

quotation marks above. For example, if you want to export the templates called “Default – All Objects”

and “Default – Targets” for the schedule “Tech Transfer”, the target would look like the following (with the

bold being what you would add):”C:\Program Files\NetPoint\NetPoint.exe” C:\Users\ Administrator\

Documents\NetPoint Projects\Tech Transfer\NetPointFile.np4 /Report Default$-$All$Objects

Default$-$Targets

6. When finished, click OK.

7. To initialize the export, double-click the shortcut or right-click and choose Open. The schedule will open

in NetPoint and the report will open in Excel.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 313 of 344

http://pmatechnologies.com/user_guide/inputs-and-outputs/microsoft-excel-42/updating-from-linked-reports/#transfer


8. If you plan on exporting additional templates on the same day, then we suggest renaming the file or

moving it to a different location to avoid having it being overwritten. Click File > Save As from the menu

bar, enter a name, and click Save.

9. If desired, you may rename the shortcut by right-clicking on it and choosing Rename.

10. Enter a name and click outside to finish.

NOTE: Upon export, the Excel file will be automatically saved in the schedule’s project folder and

named after the template, with the month and day appended to the end. Excel files that are

generated automatically can only have their changes pushed from within Excel. For more info, see

Updating from Linked Reports.

Notes

Working with Multiple Schedules

Only one linked Excel file can be open at a time. This means that when using File > Import/Export >

Export to Linked Excel File, or Open Linked Excel File, any Excel files that were open for other schedules

will be closed, and any unsaved changes will be lost. To have linked Excel files open for more than one

schedule at a time, open them directly from their project folders or through Excel instead of through NetPoint.

Filename Incompatibility

Once exported, the Excel file will be automatically named using the same name as the project. However,

Excel does not allow filepaths over 218 characters or which contain any of the following symbols: < > ? [ ] : | *.

Any templates that are exported from NetPoint projects that do not satisfy these criteria will have to be

renamed in Excel. As a result, you’ll only be able to initialize an update from such files from within Excel.

Tips for Excel

Field-to-Column Mapping

Each field that is exported will become a column in Excel, organized horizontally in the order that they appear

in the list on the right of the Configure Rows & Columns window. At this time, fields/columns cannot be

reordered after being added. For example, to move a desired field higher, remove the fields above it and re-

add them back below.

Column Descriptions

The names of the column headers in Excel will be derived directly from how they appear in the list on the right

of the Configure Rows & Columns window.

Sheet Structure

Depending on which information is chosen for exporting, the resulting Excel file may contain multiple sheets.

Object data, including predecessor and successors, will be located on a sheet with the same name as the

template itself. For target data, each target will get its own sheet. For resource data, each resource will also

get its own sheet (or pair of sheets, if consumption and/or cost is exported per day or per month, the second

sheet being reserved for a graph).

By default, all fields under the Object Data node in the Configure Rows and Columns window will be

repeated on all other eligible sheets. This can be customized by right-clicking and choosing accordingly.

Unprotecting Excel Sheets

Any column that cannot be edited will be protected in Excel, except for the code table, resource table, and

target sheets. When protected, some features in Excel, such as Find and Replace, may not be available. To
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access these features, unprotect the sheet in the Review tab or menu option using “NetPoint” as the

password.

Cut/Copy/Paste

Only cells which can be edited will allow cut, copy, or paste, unless the sheet has been unprotected, as

described above. In any case, cut and paste should be strictly avoided, as it will alter the underlying formula

of the cells. As an alternative, you can right-click on a cell and choose clear contents. Copy and paste may

be used; however, when pasting, it is recommend to paste only values. This can be accessed via the paste

options.

Project Info and Spreadsheet Key

The last sheet of every report contains information specific to the project:

• Project filepath

• Date exported

• Name of the template

• Time unit of the schedule

• Project Start Date

• Project Completion Date

• Data Date

• Asterisk Key

In addition, at the top of every sheet is a key explaining various aspects of the report.

Available Fields

Object Data

If exported, each object that is included (activities, links, milestones, benchmarks, delays, hammocks) will

become a row in Excel, organized in the order they were added to the network (system ID). The system ID

will always automatically be exported, and will be the first column on the left, after the change log. After

exporting, these fields will be located on a sheet with the same name as the template itself.

Field Definition

Object

Type
The type of object, whether activity, link, milestone, benchmark, delay, or hammock.

Description The object’s description. The description is for describing the object.

Abbr.

Description

The object’s abbreviated description. This abbreviated description is better for displaying

on the canvas and is limited to 48 characters.

Start Date The object’s start date.

Finish Date The object’s finish date.

Duration The object’s duration.
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Field Definition

Progressed

Duration
For in-progress activities, the amount of duration actualized up to the data date.

Remaining

Duration
For in-progress activities, the amount of duration unactualized after the data date.

Calculated

Complete

For actualized activities, the amount of progressed duration divided by total duration. If an

activity or hammock contains an un-actualized portion before the data date, the

calculated complete will export as NA.

Estimated

Complete
A user-entered estimate of work completed.

Calendar
The object’s calendar. This calendar dictates on which days work may take place on the

object.

ID The object’s ID. The ID is a unique identifier.

Start

Constraint
If applied, a constraint on the start date that prevents the object from starting earlier.

Finish

Constraint
If applied, a constraint on the finish date that prevents the object from finishing later.

Float*

The float of the object. The float is the amount of time an object can be delayed before

delaying the completion of the project. *An asterisk denotes that the activity is actualized,

and that the value is forensic.

Total Float*
The total float of the object. Total float is equal to float + drift. *An asterisk denotes that

the activity is actualized, and that the value is forensic.

Buffer*

The buffer of the object. The buffer is the amount of time an object can be delayed before

delaying the start of its nearest successor. *An asterisk denotes that the activity is

actualized, and that the value is forensic.

Drift*

The drift of the object. The drift is the amount of time an object can gain before advancing

the start of the project. *An asterisk denotes that the activity is actualized, and that the

value is forensic.

Drift

Buffer*

The drift of the object. The drift buffer is the amount of time an object can gain before

advancing the finish of its nearest predecessor. *An asterisk denotes that the activity is

actualized, and that the value is forensic.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 316 of 344



Field Definition

Codes

The codes and values assigned to the object. Where an assignment exists, the cell

underneath the value’s column will get an “x”. Export this field for modifying the codes

assigned to an activity or doing global assignments.

Predecessor and Successor Data

If chosen for exporting, predecessor and successor data will be added to the main sheet (the sheet with the

same name as the template itself). Note that for every object, all predecessors and all successors are

grouped together in one cell for each type. For example, if “Activity A” is a predecessor to “Activity B” and

“Activity C,” then both “Activity B” and “Activity C” will show up under the “Successor Description(s)” column,

separated by commas. The same goes for their IDs and/or finish date(s).

Field Definition

Predecessor(s)

Description-

Relationship

All, if any, of its predecessors’ descriptions follow by their relationships. Relationships

are displayed as either FS (finish-to-start), SS (start-to-start), or FF (finish-to-finish)

followed by the link gap, e.g. “Activity1-SS0″.

Predecessor(s)

ID-

Relationship

All, if any, of its predecessors’ given IDs followed by their relationships. Relationships

are displayed as either FS (finish-to-start), SS (start-to-start), or FF (finish-to-finish)

followed by the link gap, e.g. “12345-SS0.”

Predecessor

System ID(s)
All, if any, of its predecessors’ system IDs.

Predecessor

ID(s)
All, if any, of its predecessors’ given IDs.

Predecessor(s)

Description
All, if any, of its predecessors’ descriptions.

Successor(s)

Description-

Relationship

All, if any, of its successor’s descriptions follow by their relationships. Relationships

are displayed as either FS (finish-to-start), SS (start-to-start), or FF (finish-to-finish)

followed by the link gap, e.g. “Activity1-SS0″.

Successor(s)

ID-

Relationship

All, if any, of its successor’s given IDs followed by their relationships. Relationships

are displayed as either FS (finish-to-start), SS (start-to-start), or FF (finish-to-finish)

followed by the link gap, e.g. “12345-SS0.”

Successor

System ID
All, if any, of its successors’ system IDs.
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Field Definition

Successor

ID(s)
All, if any, of its successors’ given IDs.

Successor(s)

Description
All, if any, of its successors’ descriptions.

Link Data

If exported, link data will show up in its own sheet called “Links”.

Field Definition

Predecessor The beginning object in the relationship.

Successor The ending object in the relationship.

Type
The type of relationship of the link. Relationships can be either FS (finish-to-start), SS

(start-to-start), or FF (finish-to-finish).

Lag

The lag, if any, of the relationship. The lag is the amount of time after the start of a

predecessor and the start of its successor or the finish of a predecessor and the finish of

its successor in a start-to-start relationship or finish-to-finish relationship respectively.

Gap The gap value of the link. The gap is the duration of a link.

Logic Type The logic type of the link. For more info, see Creating FS Links.

Shape The geometry of the link. For more info, see Optimizing Link Geometries.

Resource Data

When exporting resource data, most of the fields will become columns in Excel, organized horizontally in the

order that they appear in the list on the right of the Configure Rows & Columns window. Specifically, Rate/

Dur, Rate/Day, Total Consumption, Total Cost, Consumption, and Cost are repeated for every resource

and put on their own sheet with Consumption and Cost actually spanning several columns, one column for

every unit of time during which the project takes place. If multiple units of time are chosen (e.g. days and

months), then all of the sheets for the first time unit will show up followed by all of the sheets for the next time

unit. A resource’s sheet can be identified by its name, which follows as “Res-[description]-[internal ID]-[time

unit]”. For example, if resources are exported by day and the schedule contains a resource named “Plumber”

with an internal ID of “5,” then the sheet would be titled “Res-Plumber-5-day”. At the end of the Excel file, a

resource “summary” sheet will be added for each time unit exported.

Graph Consumption and Graph Cost are also repeated for every resource and put on their own sheet at the

beginning of the Excel file, with all of the consumption sheets showing up first followed by all of the cost
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sheets. If multiple time units are chosen (e.g. days and months), then all of the sheets for the first time unit will

show up followed by all of the sheets for the next time unit. For example, if Graph Consumption and Graph

Cost were exported by days and months for a schedule with 3 resources, there would be 3 sheets for

consumption/day and 3 sheets for consumption/month followed by 3 sheets for cost/day and 3 sheets for

cost/month. These sheets follow a similar naming convention, which follows as “type-description-ID-time unit”.

For example, if consumption and cost are exported by day, then the consumption and cost graphs for the

same Plumber resource would be located on the sheets titled “Cons-Plumber-5-by-day” and “Cost-

Plumber-5-by-day”, respectively. Before each of the consumption and cost sheets, a “total” graph will be

added for each time unit exported.

NOTE: For graphs to be exported, their data must be included too. For example, for Graph Cost to

be exported, Cost must be included for at least one time unit; for Graph Consumption to be

exported, Consumption must be included for at least one time unit. If an attempt is made to add a

Graph Cost or Graph Consumption without at least one time unit for Cost or Consumption

respectively, NetPoint will choose a default time unit (year) and add it with the graph. Likewise, if

Cost or Consumption are completely removed from a template, their graphs will be removed as well.

NOTE: Depending on your machine, choosing to export the graphs may add a significant amount of

processing time.

Field Definition

Rate/Day

The quantity of this resource assigned to that activity on a per day basis. Export this

field for modifying the resources assigned to an activity or doing global

assignments. To assign a resource per day, enter a value in the Rate/Day column,

AND make sure there is a no walue or a “0” in the Rate/Dur column. As soon as

there is a value in the Rate/Dur column, any value in the Rate/Day column will not

be used.

Rate/Dur

The quantity of this resource assigned to that activity on a per duration basis. To

assign a resource per duration, enter a value in the Rate/Dur column. As soon as

there is a value in the Rate/Dur column, any value in the Rate/Day column will not

be used. If this column contains a “0”, the value from Rate/Day will be used

instead.

Total

Consumption
The rate/day times the duration of the activity (or the rate/dur).

Total Cost The cost/day time the duration of the activity.

Consumption

A per time unit breakdown of the consumption of this resource over the duration of the

schedule. Consumption will span several columns, one column for every unit of time

during which the project takes place. Right-click in the list on the left to add individual

time units; right-click in the list on the right to remove them. If added without choosing,

years will be the default.
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Field Definition

Cost

A per time unit breakdown of the cost of this resource over the duration of the

schedule. Cost will span several columns, one column for every unit of time during

which the project takes place. Right-click in the list on the left to add individual time

units; right-click in the list on the right to remove them.If added without choosing, years

will be the default.

Graph

Consumption

Whether or not to include graphs of all the consumption data. The consumption field

must be included for at least one time unit.

Graph Cost
Whether or not to include graphs of all the cost data. The cost field must be included for

at least one time unit.

Target Data

When exporting target data, the reported fields will be repeated for every target, with each target getting its

own sheet named after the number of the target followed by the description. For example, the first target’s

sheet could be named “Target1-Baseline” followed by “Target2-Update” and so on. Like with object data, each

field that is exported will become a column in Excel, organized horizontally in the order that they appear in the

list on the right of the Configure Rows & Columns window.

NOTE: If no targets have been stored in NetPoint, then no sheets will actually show up in Excel for

targets.

Field Definition

Target Start Date The object’s start date when the target was captured.

Start Date Variance The target minus the current, in time units (i.e. days).

Target Finish Date The object’s finish date when the target was captured.

Finish Date Variance The target minus the current, in time units (i.e. days).

Target Duration The object’s duration when the target was captured.

Duration Variance The target minus the current, in time units (i.e. days).

Target Float The object’s float when the target was captured.

Float Variance The current minus the target, in time units (i.e. days).

Target Total Float The object’s total float when the target was captured.
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Field Definition

Total Float Variance The current minus the target, in time units (i.e. days).

Target Drift The object’s drift when the target was captured.

Drift Variance The current minus the target, in time units (i.e. days).

Tip: At this time, variances are only calculated to the current state, not between any two targets, but

such reports can be exported from the Target Manager by clicking Tools > Open Targets Manager, right-

clicking on the columns, and choosing Export all Rows & Columns.

Tables

Tables are another way for adding or deleting codes and resources from the schedule. When exported, they

will be put in their own separate sheets. For more instructions, see Adding and Modifying Codes via Excel

and Adding and Modifying Resources via Excel.

Field Definition

Code

Table

An editable table for adding, modifying, and deleting codes. Export this table for

managing codes and values.

Resource

Table

An editable table for adding, modifying, and deleting resources. Export this table for

managing resources and cost.

Hammocks

Hammocks will show up on the main data sheet.

Field Definition

Min Member Drift The lowest drift value of all a hammock’s members.

Min Member Float The lowest float value of all a hammock’s members.

Min Member Buffer The lowest buffer value of all a hammock’s members.

Min Member Total Float The lowest total float value of all a hammock’s members.

Member List A list of all members of the hammock.
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Updating from Linked Reports

With the Excel data transfer feature, you can export a schedule to Excel, update its activity IDs or assign new

resources, and then push those changes back into NetPoint without closing or leaving either application. In

this scheme, Excel serves as a seamless data entry and updating method. Other uses for the Excel data

transfer feature include spell checking or changing line breaks in activity descriptions, for example.

Fields that can be edited are identified in bold in both the Configure Rows & Columns window as well as in

Excel itself. All other columns will be protected, except for the code table, resource table, and target sheets

(for more on protected sheets, and for a full list of supported fields, see the notes at the end of this section).

In order execute the Excel data transfer, the file from which you want to update must be generated by an

export from NetPoint. For example, to update activity IDs, first export activities and their ID fields to Excel. For

more information, see Exporting Linked Reports.

NOTE: NetPoint must remain open at all times during exporting and/or updating. If NetPoint is ever

closed, you must close Excel and then open NetPoint again to refresh the link between applications

before you can initiate an update. Excel, on the other hand, can be closed and opened as many

times as desired without interrupting the connection.

Steps

Editing in Excel

1. Make sure the Excel file you want to edit and update from was generated by an export from NetPoint. For

more information, see Exporting Linked Reports.

2. If the Excel file you want to edit was just exported from NetPoint and opened, skip to step 6. If not, click

File > Import/Export from the NetPoint menu bar.

3. Choose Open Linked Excel File. NOTE: If you open the desired Excel file from within Windows

Explorer or Excel itself, you can still edit and save it; however, to initiate an update, you must

close it and open it from the NetPoint menu bar. When opening an Excel file that was renamed or

moved, double-check that the project it is linked to is the same as the project you intend to

update. You can do this by verifying the filepath next to Project in the upper left-hand corner of

the Excel file.

4. Edit any cells whose columns are identified in bold. Once modified, a cell will be colored in blue and its

row will be populated with a star under the Changed column.

5. When finished, click outside of the cell being edited or press Enter.

6. To update, see Initiating an Update from within Excel.

Initiating an Update from within Excel

1. If you’re coming from Editing in Excel, skip to step 3. Otherwise, click File > Import/Export from the

NetPoint menu bar.

2. Choose Open Linked Excel File. NOTE: If you open the desired Excel file from within Windows

Explorer or Excel itself, you can still edit and save it; however, to initiate an update, you must

close it and open it from the NetPoint menu bar. When opening an Excel file that was renamed or

moved, double-check that the project it is linked to is the same as the project you intend to

update. You can do this by verifying the filepath next to Project in the upper left-hand corner of

the Excel file.
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3. In Excel, choose the ADD-INS tab and click the Update Schedule icon in the Menu

Commands section.

4. To review the changes first, click Review Changes. To accept without reviewing, click Accept All and

skip to step 7.

a. To deny a change, uncheck the box next to it under the Accept column.

b. When finished, click the Continue button.

c. When ready, click the Accept All button.

5. Excel will open and any changes from NetPoint will be brought in as well.

Adding and Modifying Codes via Excel

1. First, export the “Default – Code & Code Assignments” template from NetPoint (or any other template as

long as it includes the Code Table). For detailed steps, see Modifying/Exporting an Existing Template.

2. In the linked Excel file, click the Code Table tab.

3. To add a new code, click in the first empty row under the Name column and enter a description.

a. Next to the name under the Value column, enter a value. NOTE: Once the name and value have

been entered successfully, ADD will appear under the Changed column.

b. To allow more than one value of the same code to be assigned to the same activity, leave an “X”

under the Multi Assignments column.

c. To enter another value, repeat steps 3-3b using the same description under the Name column for

every row.

d. To enter another code, repeat steps 3-3b using a different description under the Name column.

4. To delete a value, enter any text (for example, an “x” or “DEL”) under the Delete column.

5. To delete a code, enter any text under the Delete column for every one of its values.

6. To modify a code or value, select its description and change it accordingly

7. When finished, choose the ADD-INS tab and click the Update Schedule icon in the Menu

Commands section.

8. To review the changes first, click Review Changes .To accept without reviewing, click Accept All and

skip to step 9.

a. To deny a change, uncheck the box next to it under the Accept column.

b. When finished, click the Continue button.

c. When ready, click the Accept All button.

9. Excel will open and any changes from NetPoint will be brought in as well.

Adding and Modifying Resources via Excel

1. First, export the “Default – Cost, Resources & Assignments” template from NetPoint (or any other

template as long as it includes the Resource Table). For detailed steps, see Modifying/Exporting an

Existing Template.

2. In the linked Excel file, click the Resource Table tab.

3. To add a new resource, click in the first empty row under the Resource Name column and enter a

description.

a. Next to the name under the Cost Per Unit column, enter a value. Once the name and cost per unit

have been entered successfully, ADD will appear under the Changed column.

b. To specify a category, choose from the list.

c. To enter another resource, repeat steps 3-3b.

4. To delete a resource, enter any text (for example, an “x” or “DEL”) under the Delete column.

5. To modify a resource, select one of its cells and change it accordingly.

6. When finished, choose the ADD-INS tab and click the Update Schedule icon in the Menu

Commands section.
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7. To review the changes first, click Review Changes. To accept without reviewing, click Accept All and

skip to step 8.

a. To deny a change, uncheck the box next to it under the Accept column.

b. When finished, click the Continue button.

c. When ready, click the Accept All button.

8. Excel will open and any changes from NetPoint will be brought in as well.

NOTE: Colors for resources will be set automatically and can modified from within NetPoint. For

more info, see Modifying an Existing Resource.

Notes

Forcing two-line Descriptions

Long descriptions can be forced to two lines in Excel by pressing ALT + Enter.

Unprotecting Excel Sheets

Any column that cannot be edited will be protected in Excel, except for the code table, resource table, and

target sheets. When protected, some features in Excel, such as Find and Replace, may not be available. To

access these features, unprotect the sheet in the Review tab or menu option using “NetPoint” as the

password.

Cut/Copy/Paste

Only cells which can be edited will allow cut, copy, or paste, unless the sheet has been unprotected, as

described above. In any case, cut and paste should be strictly avoided, as it will alter the underlying formula

of the cells. As an alternative, you can right-click on a cell and choose clear contents. Copy and paste may

be used; however, when pasting, it is recommend to paste only values. This can be accessed via the paste

options.

Reconciling Changes

In the event that a schedule has been edited in NetPoint and an attempt is made to update it from Excel,

those changes will NOT be lost or overwritten. This is because only those rows with an asterisk in the

Changed column in Excel will have their data pushed back into NetPoint. For example, if Activity A is edited

in Excel, and Activity B is subsequently edited in NetPoint, Activity B will not revert in NetPoint when being

updated from Excel. In fact, Activity B will actually be updated in Excel based on the change from NetPoint.

An exception occurs, however, if Activity A is edited in both Excel AND NetPoint. In this case, the change

from Excel is pushed into NetPoint regardless of whether or not it was edited in NetPoint more recently.

Supported Fields

Field Definition

Description The object’s description. The description is for describing the object.

Abbreviated Description
The object’s abbreviated description. This abbreviated description is

better for displaying on the canvas and is limited to 48 characters.
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Field Definition

Estimated Complete
The estimated complete field is a user-entered field for estimating the

percent of work completed.

ID The object’s ID. The ID is a unique identifier.

Codes Add or remove codes.

Code Names A short description of the code.

Code Values A short description of the value.

Code Assignment

Behavior
Whether or not multiple values can be assigned to the same activity.

Code Assignments
The codes and values assigned to the object. Where an assignment

exists, the cell underneath the value’s column will get an “x”

Resources Add or remove resources.

Resource Names A short description of the resource.

Resource Categories A label for describing the type of resource.

Resource Cost The cost of the resource per unit of time.

Resource Assignments

(Rate/Day or Rate/

Duration)

The quantity of a resource assigned to an activity on a per day or per

duration basis.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 325 of 344



Native XML

For integrating NetPoint schedule data with applications other than Primavera P6, Deltek Open Plan, MS

Project, or MS Excel, NetPoint can import and export native XML files. Activity ID’s, descriptions, planned

dates, and durations; predecessor/successor logic; resources; codes; and calendars are included in the

export. Instructions are provided below.

Steps

Importing

1. Click File > Import/Export > Import From Native XML… from the menu bar. An explorer window will

open.

2. Browse for the desired file and click Open.

Exporting

1. Click File > Import/Export > Export to Native XML… from the menu bar. An explorer window will open.

2. Browse for the desired location and click Save.
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Synchro Professional

Synchro Professional is a 4D building information modeling (BIM) application that allows project planners to

better simulate and model complex construction sequences by providing enhanced visualization and

animation capabilities. Synchro Professional controls the display of 3-dimensional objects, like building

components and other physical structures, based on a timeline which can be defined by the start and finish

dates of NetPoint activities. Before utilizing NetPoint schedule data in Synchro Professional, the NetPoint

schedule must first be exported as a native XML file. The export will include activity ID’s, descriptions,

planned dates, and durations; predecessor/successor logic; resources; codes; and calendars. Please consult

Synchro’s documentation regarding which data they import. Instructions are provided below.

Steps

Exporting from NetPoint

1. Click File > Import/Export > Export to Native XML… from the menu bar. An explorer window will open.

2. Browse for the desired location and click Save.

Importing an XML from NetPoint into Synchro

1. Click File > Import > PMA NetPoint from the main menu. An explorer window will open.

2. Click Browse, locate the desired file, and click Open.

3. Select Next, and then click Import to import all available attributes.

4. An import report will open. Click Finish to complete the import.

To utilize NetPoint’s schedule data in Synchro Professional, follow the instructions provided by Synchro for

linking 3D objects with activities. Once linked, you will be able to simulate and visualize the construction

sequence in 3D, driven by a NetPoint schedule.
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Capturing Snapshots

A snapshot may be captured of the entire schedule or from the user’s selection.

Steps

Entire Schedule

1. Click File > Take Snapshot > Of Entire Schedule (as printed) from the menu bar. The Screenshot

Settings window opens.

2. Confirm the width.

3. To save to your computer, choose File next to Save To. Otherwise, leave as Clipboard.

a. Confirm the Image Format.

b. Click the Choose button.

c. Browse for the desired location, enter a filename, and click Open.

4. When finished, click OK. If clipboard was chosen, you may now paste the image in the desired

application.

From Selection

1. Click File > Take Snapshot > From Selection (as printed) from the menu bar. The cursor will change

from the Select Tool to the crosshairs .

2. Left-click with the mouse on the canvas and without letting go, drag the cursor around the desired area.

3. Release the mouse. The Screenshot Settings window will open.

4. See steps 2-3 above.

5. When finished, click OK. If clipboard was chosen, you may now paste the image in the desired

application.

Tip: A screen shot may also be taken from selection by pressing the CTRL key while using the Select Tool

.

NOTE: When capturing a snapshot from selection, the captured image won’t necessarily include

everything as its displayed. This is because the snapshot corresponds with how the canvas is

printed, not how it’s rendered on-screen. For example, if the schedule has been scrolled to a

particular section of the network and a snapshot is taken from selection, the calendar strips won’t

actually show up, because their location when printed is at the top of the canvas. The same applies

for the holiday line and the resource profile. Additionally, elements like dialog windows (e.g. the

Resource Key) cannot be captured, as they only display on-screen.
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Notes

Screenshot Settings

Field Definition

Width (in

pixels)

Displays the size of the screenshot to be captured. By default, the size will match the size

of the canvas. It may be scaled, however, by adjusting the width (the height will adjust

proportionally).

Save To
The destination of the screenshot. Images saved to the clipboard for pasting are only

temporary.

Image

Format
The format of the image.

File Name For naming and choosing the destination.

Pathname Displays the destination chosen above.
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8) Troubleshooting

In this chapter, you’ll find information on how to resolve issues that haven’t been covered elsewhere in the

user guide.
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Error Reporting

In the event of an error, information can be gathered and sent to NetPoint staff to assist with support. This can

be done on demand through the Help menu by generating a log file or after a crash by opening a support

ticket.

This chapter includes details for the following:

1. Generating log files

2. Opening support tickets

3. Error Reporting Confidentiality
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Generating Log Files

Log files can be useful in the event that a ticket has been opened with NetPoint support, and a support team

member is requesting more information. Log files include general system information – such as the type of

processor, memory, and screen resolution; application information, such as the current version and

installation directory; and a list of recent actions taken. Together with the schedule, this information can

greatly assist NetPoint support in recreating any errors encountered. Once generated, the log file is stored in

MyDocuments\NetPointAppData as SupportLog.html.

NOTE: Only ONE log file can be stored at a time and will overwrite any pre-existing log file.

Steps

1. Click Help from the menu bar and choose Collect Information for NetPoint Support. A confirmation

will open.

2. To attach the log to a new message using your default email client, click Attach to New Email.

Otherwise, click Close.
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Opening Support Tickets

In the event that NetPoint terminates unexpectedly, the user may choose to open a support ticket. The ticket

will be opened by sending an error report in the background using their default email client.

By default, the report will include a screenshot of NetPoint at the time of the error, the NetPoint log file, an

XML file, a DMP file, and the project .nzp file for the schedule that caused the termination. Any of these files

can be removed via right-click, and other files may added in the same manner. The information sent to

NetPoint support will be kept strictly confidential and used solely for the purposes of repairing the error or

otherwise improving NetPoint. For more information, see Terms of Use.

Once submitted, NetPoint will reopen automatically, and the file recovery process will launch if applicable. For

more information, see Understanding File Recovery.

Steps

1. The NetPoint Helpdesk window will open automatically.

2. To view or modify included files, click What will be included?

a. To preview a file, select it in the list and scan the preview below.

b. To open a file, double-click it in the list.

c. To remove a file, right-click it in the list and click Delete Selected File(s).

d. To add a file, right-click on any item and choose Attach More File(s).

e. To export a ZIP of all files, click the Export button at the bottom and save it accordingly.

f. When finished, click Close.

3. To add a comment, click Add a comment.

a. Type in the text area provided.

4. When ready, click Open Ticket. A confirmation will open.

5. Click OK to complete the process.

6. Depending on your security, another confirmation may open. Click Allow.

NOTE: If a default email client is not found, the error report will be saved to MyDocuments\

NetPointAppData\CrashReports as a zip file, which can be emailed directly to support.

Notes

By default, the following files are included in the error report. Your privacy is taken very seriously; for more

information, see Terms of Use.

Field Definition

SupportLog.html

An HTML file that includes system information as well as a list of recent actions

taken. Once generated, the log file is stored in MyDocuments\NetPointAppData as

SupportLog.html. For more information, see Generating Log Files.

ProjectFile.nzp
The project folder and its contents, including the schedule and other supporting

files. All information will be kept strictly confidential and used solely for the purposes
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Field Definition

of repairing the error or otherwise improving NetPoint. For more information,

see Terms of Use.

crashdump.dmp A Windows file generated by dumping the memory at the time of the crash.

crashrpt.xml
An XML file that includes system information, such as the operating system, version

number, and memory usage.

screenshot0.jpg

A screenshot taken at the time of the error, just before NetPoint closes. NOTE: The

screenshot ONLY includes the NetPoint window; any other windows,

including the desktop, will be blacked out.
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Error Reporting Confidentiality

In consideration for providing PMA Technologies, LLC (“PMA TECH”) with files and or other requested

material or information (“CONFIDENTIAL INFORMATION”), PMA TECH agrees, except as required otherwise

by applicable law, court, governmental order, or to the extent reasonably necessary to prosecute or defend

PMA TECH from litigation related to the License Agreement, to hold such CONFIDENTIAL INFORMATION in

strict confidence and to use such CONFIDENTIAL INFORMATION only as it deems necessary to assist PMA

TECH with repairing or otherwise improving NetPoint or its other software products (“SOFTWARE”). Provider

of such CONFIDENTIAL INFORMATION represents that it owns or has authority to provide such

CONFIDENTIAL INFORMATION to PMA TECH for the purpose(s) provided herein, and such use by PMA

TECH shall not constitute an infringement of any party’s ownership or proprietary rights. The terms found

online under http://pmatechnologies.com/user_guide/troubleshooting/error-reporting/error-reporting-

confidentiality/ are the most up-to-date and in case of discrepancy supersede terms found printed.

Last updated: 06/28/15.
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Understanding File Recovery

NetPoint® makes use of a file recovery system to prevent the loss of data in the case of an unexpected

crash. This works by checking to see, every 30 seconds, if any covered unsaved changes have been made.

These include most mouse and keyboard inputs that relate to menus, the toolbar, and the canvas (some

actions and intermediate steps are not covered). If a covered unsaved change has been made, the state of

the document just prior to that change is stored in separate recovery file (identified with a .NREC extension).

For now, this means that the very last change will not make it into the recovery file. This also means that the

first change made to a document will never trigger the file recovery system.

When a schedule is properly closed, recovery files are normally deleted. Sometimes, however, a project may

retain its recovery file even if there are no unsaved changes. This is because when multiple schedules are

open, and only one of them has an unsaved change, all of them might be kept. Other times, a schedule may

be open during a crash, but its project folder won’t contain a recovery file. This means there were no covered

unsaved changes to be stored.

For new or unsaved projects, recovery files are stored in MyDocuments\NetPointRecovery. In the event of a

crash, if any recovery files existed for new or unsaved schedules, they will be opened automatically when

NetPoint® is launched. For existing projects (projects which have already been saved), recovery files are

stored in their corresponding project folders. The recovery files for existing projects will only open

automatically when the original project is opened. Each case is slightly different.

This section details instructions for the following:

1. Recovering new or unsaved projects

2. Recovering existing projects
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Recovering New or Unsaved Projects

Following an unexpected termination, if there were any new schedules that had not yet been saved, their

recovery files will open automatically when re-opening the application.

Steps

1.

To recover a new or

unsaved project, run the

NetPoint .exe. As usual, a

blank schedule will be

created. In addition, the

canvas will default to the first

recovered schedule, the rest

of the recovered schedules

will open behind it, and

the File(s) Recovered! and

Remaining File(s) windows

will open.

2.

In the File(s) Recovered!

window, click Review

File(s)….

NOTE: At this point,

NetPoint will go into a

read-only mode: the

toolbar, menu bar (except

for Window), and

keyboard/mouse input will

all become disabled.

3.

To view or switch to another

open file, click Window from

the menu bar and choose

accordingly. The Remaining

File(s) window will open and

close automatically when

switching between

recovered and non-

recovered schedules.
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4.

While viewing a recovered

schedule, the Replace

Original button in the

Remaining File(s) window

will be disabled.

a.

To keep the recovery file as

a new project, click the Save

As… button. The Save

Project As window will

open. Continue to step i.

b.

To discard the recovery file

without storing it as a new

project, click

the Delete button. Continue

to step 5.

i.

If storing it as a new project,

the Save Project As

window will open. Browse

for a desired location on the

left in which you want the

project to be saved and

select the folder from the list.

NOTE: To create a new

folder, click the New

Folder button. To edit or

delete a folder, right-click

and choose accordingly.
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ii.

With the name of the folder

selected, a list of existing

NetPoint projects will show

up on the right. Enter a

description next to Save

Project As. This will be the

name of the new project.

iii.

With a description entered,

click Save.

NOTE: The schedule itself

will be named

“NetPointFile.np4”. Upon

clicking Save, a folder will

be created using the

description entered and

the schedule file will be

automatically placed in it.

5.

If there is another unsaved

recovery file, NetPoint will

automatically switch focus to

it. Repeat steps 3-4 for each

file. When there are no more

recovery files to handle,

NetPoint will exit read-only

mode and the Remaining

File(s) window will close

automatically.
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Recovering Existing Projects

Recovered schedules for any projects that had already been saved will open upon relaunching the schedule

files from their project folders.

Steps

1.

To recover an existing project,

run the NetPoint .exe and

choose File > Open Project

from the menu bar.

2.

Browse for a project that was

open during a crash and click

Open.

3.

To review the file first, click

Review Recovery in the File

Recovered! window, and then

continue to step 4. Else, see

3a.

a.

To keep only the original file

without reviewing the recovery,

click Discard Recovery. The

original schedule will open.

Continue to step 5. Else, see

3b.

b.

To abort the operation, click

Cancel. The File

Recovered! window will open

again the next time the project

is opened. Continue to step 5.
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4.

If reviewing the file, both the

recovered version and the last

saved version will open, as

well as the Remaining File(s)

window. To view the original

file, click Window from the

menu bar and choose

accordingly.

NOTE: At this point,

NetPoint will go into a read-

only mode: the toolbar,

menu bar (except for

Window), and keyboard/

mouse input will all become

disabled.

a.

To keep only the recovery file,

click the Replace Original

button. Continue to step 5.

Else, see 4b.

b.

To keep both files, click the

Save As… button. The Save

Project As window will open.

Continue to step 4b.i. Else,

see 4c.

i.

If keeping both files, the Save

Project As window will open.

On the left, browse for a

desired location under which

you want the project to be

saved and select it in the list.

NOTE: To create a new

folder, click the New Folder

button. To edit or delete a

folder, right-click and

choose accordingly.
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ii.

With the name of the folder

selected, a list of existing

NetPoint projects will show up

on the right. Enter a

description next to Save

Project As. This will be the

name of the new project.

iii.

With a description entered,

click Save.

NOTE: The schedule itself

will be named

“NetPointFile.np4”. Upon

clicking Save, a folder will

be created using the

description entered and the

schedule file automatically

placed in it.

c.

To keep only the original file,

click the Delete Recovery

button. Continue to step 5.

5.

After all recovered schedules

have been handled, any

remaining open recovery

windows will close

automatically, signaling the

end of the file recovery

process.

NetPoint User Guide. © 2008-2015 PMA Technologies LLC.

Page 342 of 344



Version Compatibility

NetPoint schedules are not guaranteed to be backwards-compatible. That is, for example, a file created in a

more recent release of NetPoint will not necessarily be able to be opened in an older release of NetPoint.

Schedules created in NetPoint 4 and above will never open in NetPoint v3.0, as they have different file

extensions.

File Extensions

All schedules created in NetPoint 4 and above are given an .np4 extension. All schedules created in versions

prior to NetPoint 4 are given a .npt extension. Versions 4 and above can read both .np4 and .npt schedules;

however, NetPoint v3.0 cannot read .np4 files. If an attempt is made to open an older NetPoint file (.npt), it will

be converted all the same to a project folder. The original .npt file will continue to exist as a backup.
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Constraint Violations Due to Calendar Change

If the calendar of an activity is edited or a new calendar is assigned such that it elongates or reduces the

length (not duration) of an activity, then the activity’s dates will be adjusted accordingly. However, some

activities may have no-later-than (NLT) or no-earlier-than (NET) constraints that become violated due to the

new dates falling outside the constraint range.

After the calendar is changed, NetPoint automatically looks for activities that violate NLT or NET constraints. If

NetPoint finds violations, a window displays prompting input for a resolution. There are three options:

Maintaining Constraints

If this option is selected, NetPoint will automatically correct the violating constraints for the activity by moving

it so the finish date is the same as the NLT date. If the activity cannot be moved due insufficient float or drift or

due to an NET constraint restriction, then the NLT constraint will be silently removed.

Resetting Constraints

If this option is selected, then the violating constraints are automatically changed to the new start and finish

dates of the activity. This will correct any violations.

Removing Constraints

If this option is selected, the violating constraints will be silently removed.

For all options, a checkbox at the bottom may be clicked to display a list of the affected activities along with

the information about the constraint, the constraint type that has been fixed, and the constraint dates.

END OF USER GUIDE
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