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Using Help 
Documentation for the NetPoint Application is available via Help. The NetPoint FAQ periodically updates 
NetPoint help information. Please check regularly for the most current information. Additional documentation on 
specific, more advanced features may also be found under Help or by contacting PMA Technologies. 

 
System Requirements 
Virtual Memory 
A minimum of 1000MB of virtual memory (RAM) is needed. For plan development of 250 to 500 activities, a 
minimum of 2GB is recommended. For plans with more than 500 activities, 4GB is recommended. These levels 
of RAM allow you to maintain a seamless, instantaneous refresh of the active planning surface during a 
planning session. An under-resourced computer may cause a delay when the screen updates. 

Monitor Display 
The highest screen resolution setting is best for both projected images and your monitor. A minimum screen 
resolution setting of 1024x768 is required. 

Operating System 
You will need Windows XP, Service Pak 2, or a more recent operating system. 

Compatible External Programs  
Primavera 6.0, Microsoft Project 2007, Microsoft Excel. Synchro 

Hands-On Interactive Application 
The object-base nature of the NetPoint application is ideal for using a touch screen, hand-directed and voice 
recognition software to quickly move and modify the your plan or schedule. You can find NetPoint Best 
Practices at pmatechnologies.com for tips, room setup and product recommendations. 

 

Getting Started 
Creating a New Plan 

A new NetPoint plan will open in a letter-size window with the default calendar set at 6 months prior and 12 

months after the current date. The Schedule Attributes  will open automatically allowing you to set the 
Project Calendar. Be sure to include some buffer before Project Start and after Project Completion.   
Project Calendar –  set Calendar Starting Date and Calendar Ending Date to define the active planning 
surface.  A drop-down calendar option is available to set these dates by clicking on the black arrow next to the 
date box. Dates may be modified at any time during the planning process.  

Project Start and Project Completion – set Project Start and Project Completion dates for the plan by 
either entering them manually or by clicking on the the black arrow next to the date box for the drop-down 
calendar. You can also set them graphically by right clicking on the canvas and selecting the Set This Date As 
option. Once the Project Start and Project Completion dates are placed on the canvas they can be further 
edited by grabbing and moving the project start/finish flags on the active planning surface to the desired dates.   

Print Setup – establish the Print Setup which will determine the active planning surface for your plan. A 
NetPoint plan will print as displayed on-screen so select the paper size that will maximize the presentation of 
your plan. If the plan is cropped or skewed, adjust the page size in File > Print Setup until the plan is fully 
viewable on the canvas. Additional print capabilities such as plotting or tiling should also be considered.  
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Note: Longer timescales create a plan proportionally smaller and vice versa. Printing to Adobe PDF for a 
custom page size can be very helpful. Print Tiling allows maximum flexibility, up to 50 vertical and horizontal 
pages. Print Tiling is an independent feature set with each use.   

Opening an Existing Plan 
Existing plans in NetPoint open in the size last saved if networked to the associated printer. Otherwise, a plan 
opens in the default letter size, in which case a message box will open providing the planned Print Setup; adjust 
the settings as indicated in this message to open the existing plan. NOTE: If a plan opens cropped or without 
scroll bars, increase the page size until the full plan is in view.   

Resizing a Plan 
To view an As Print (similar to Print Preview) plan, exit Zoom and Stretch  commands and reset the text 
size by selecting Display>Text Size and setting the text to petite or small. This should prevent data clashing in 
your plan for the printed version..    

Use Zoom via the icon  or hold SHIFT+ARROW key (or roll mouse wheel).To exit Zoom, hold 
SHIFT+ENTER or select Default Zoom Factor in the Zoom/Stretch box. 

Use Stretch via the icon  or hold CTRL+ARROW key (or roll mouse wheel). To exit Stretch, hold 
CTRL+ENTER or select Default Stretch Factor in the Zoom/Stretch box.  
 

Working with NetPoint 
Excel Template for Activity Entry 
For simple entry of multiple activities, use the Excel Template for Activity Entry found in the NetPoint Transfer 
folder located in on your C drive. To enter your activities carefully follow the instructions found in the Excel 
template. Once the template is ready you can implement it by selecting File > Export/Import > Import from 
Excel.   

When importing activities Without Dates, you will be prompted to set the project calendar to accommodate 
imported activity dates. Note: If you accept the default setting, you will not have access to activities that fall 
outside of the calendar settings. The With Dates option sets the calendar for you; reset the calendar and 
Project Start and Completion flags once the import is complete. 

All activities import one grid per activity and are ready for modification and logic ties. The new plan automatically 
tiles pages to accommodate imported activities. After optimizing the plan and logic ties are in place, reset the 
page size and/or eliminate page tiling via File > Print Tiling. 

Placing Objects 
To place objects, use the selection tool  to select an object icon (e.g., milestone, benchmark, activity) and 
graphically estimate calendar placement by hovering the mouse (crosshairs) over the calendar area; the date 
will display next to the position of your mouse. Click the canvas when you have the desired location. When 
placing an activity, click and hold the activity while dragging it to the desired duration/end date.  

Modifying Objects 
Once an object is placed, graphically adjust the object date or grid placement by clicking and dragging to the 
desired location or date. To change the duration of an activity make sure it is selected and hover over the end 
node until a double arrow appears. Click and drag the end to the desired date or duration. You can also modify 
properties in the object’s property box by double clicking or right clicking the object and selecting Properties. To 
modify multiple objects, first select objects to be commonly modified on the canvas using SHIFT+click (for more 
advanced selection, use Edit > Find Multiple Activities), then select Edit > Set Properties for Selected 
Objects..   
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Finding Multiple Objects 
The Find Multiple Objects feature searches for objects with specific attributes in the plan as selected in the 
Multi-Activity property box, found in Edit > Find Multiple Activities. Select the desired attributes and click 
Add to List, then Select, Hide or Highlight objects in the list. Example: When resource leveling, select all 
activities relating to one resource, then select Highlight All to accentuate objects. To make changes to multiple 
activities (e.g., change color, create hammocks), select  Edit > Find Multiple Activities. 

Copying & Pasting Objects 
To copy objects within a plan, select and copy the object to a specific gridline as prompted by NetPoint. To copy 
objects from another plan, preset the calendar of the destination plan to accommodate the dates of the copied 

objects using the copy icon  or right click to find the copy option.. 

Linking Objects 
To link objects, use selection tool , hold SHIFT and select two objects to be linked, then select the link type. 
To select and link multiple objects, “box in” by dragging the cursor from an empty portion of the canvas to the 
items (that do not overlap on the timescale), then select Auto Link FS Chain . To modify link geometry, 
select the link, right click, and select Change Link To, then select new geometry. . Note: To select a link with 
a diagonal portion, click horizontal or vertical portion. 

 
Icons 

 Blank Page: Opens a new, blank NetPoint Plan with a default calendar set at  6 months prior to and  
12 months past the current start date 

  Open Folder:  Selects and opens existing files 

 Disk: Saves files with a default name (i.e. NetPoint1) or new name to a desired location 

 
Cut: Cuts selected object from the active planning surface. 

 Copy to Clipboard: Copies selected item(s) 

 Paste from Clipboard: Pastes copied object(s), including fully contained logic of an object. 

 
Print: Opens the Print Options window. 

 Undo: Undoes last action or up to 15 previous actions. 

   Object Select: Selects objects on of the NetPoint canvas. 

 

 V Link: Creates a vertical link between selected objects 

 H Link: Creates horizontal link between selected objects 

 H+V Link: Creates horizontal, then vertical link between selected objects 

 V+H Link: Creates vertical, then horizontal link between selected objects 

 VHV Link: Creates vertical, then horizontal, then vertical link between selected objects 

 HVH Link: Creates a horizontal, then vertical, then horizontal link between objects 

 VDV Link: Draws a vertical, then a diagonal link between selected objects. Note: To select a link with a 
diagonal quality, click horizontal or vertical portion. 
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 HDH Link: Draws a horizontal, then a diagonal link between selected activities, embeds, milestones, or 
benchmarks.  Note: To select a link with a diagonal quality, click the horizontal or vertical portion. 

 Delete Link: Deletes the link between selected activities 

 Calendar Activity: Inserts calendar day activities; includes nonworking days and holidays. Activity 
data will calculate all days into duration. 

 Workday Activity: Inserts an activity that reduces holidays and non-workday from the duration... Note: 
Start and end dates non-workdays as set by the project calendar are displayed in red.  

 Print: Opens the Print Options window. 

 
 

FS Chain: Creates finish to start relationships between all selected activities that do not overlap dates 
on the calendar.    

 Text Object: Inserts a text object on canvas where crosshairs are right clicked and the box is opened. 
Enter text using manual returns or ENTER to stack the text. Choose font, style, size, color, and effects. 
Move text graphically by clicking on Text Box and dragging to chosen location. You may move the text 
box by right clicking and dragging to a desired location.  

 
Start Milestone: Inserts Start-of-the-Day milestone on canvas where mouse crosshairs is right 
clicked. Opens Milestone Event Properties box to enter milestone description, date, size, and tail 
length. Also allows option to display and actualize milestone date as well as add a NLT constraint date. 

 
Finished Milestone: Inserts Finish-of-the-Day milestone on canvas where mouse crosshairs is right 
clicked. Opens Milestone Event Properties box to enter milestone description, date, size, and tail 
length. Also allows option to display and actualize milestone date as well as add a NET constraint date.   

 
Start Benchmark: Inserts Start-of-the-Day benchmark on canvas where mouse is clicked. Open 
Benchmark Properties box to enter benchmark description and modify displayed data. 

 
Finish Benchmark: Inserts Finish-of-the-Day benchmark on canvas where mouse is clicked. Open 
Benchmark Properties box to enter benchmark description and modify displayed data 

 
Start Embed Node: Inserts Start Embed on a successor activity where mouse is clicked. A Start 
Embed allows connection from the start embed (offset to start) to the start of a successor activity, 
displaying offset to the start in accordance with activity’s calendar or workday status. Once placed, the 
property box opens to allow modification of data. Note: For Start-to-start relationship - a Start Embed 
must be in predecessor activity and connect to the start of a successor activity. 

 
Finish Embed Node: Inserts a Finish Embed on a successor activity where mouse is clicked. A 
Finish Embed allows connection from the finish node of a predecessor activity to the finish embed of a 
successor activity (displaying offset to the finish in accordance with activity’s calendar or workday status). 
Once placed, the property box opens to allow modification of data. Note: For Finish-to-Finish relationship 
- a Finish Embed must be in successor activity and connect from the finish of a predecessor activity. 

 Information Object: Inserts information object on canvas where mouse is clicked. iObjects are stored 
and recalled in an absolute or full file path (See iObject Storage section). 

 Note Field: Opens notepad to create notes attached to canvas. Double click to view. Notes are 
represented by notepad icon and cannot be printed. 

 
 

Gestural Interface: Opens the Gestural Interface tool. This allows the user to use touch while 
working a schedule and greatly improve audience interaction and participation. 

 Zoom: Opens the Zoom/Stretch window to change display. Use scroll bars to view unseen canvas. 

 Logic Hold: Maintains logic relationships as the schedule is built. Deselect to work without the 
restraints of logic ties risking plan corruption. The default is Logic Hold On. 
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 Resource Limit: Displays Resource Limit overages. 

 Project Attributes:  Opens the Project Attributes window. 

 GPM: Automatically changes the planned dates to early dates. Save the baseline NetPoint plan prior to 
initiating changes in this mode. Click the canvas to initiate Push to Early Dates. 

 Help: Opens the NetPoint help website. 

 

 

Menu Descriptions 
FILE 
New (CTRL+N): Opens a new plan with a default calendar of 6 months prior and 12 months after current date. 

Open (CTRL+O): Opens existing NetPoint files.  

Close: Closes the current plan with the option of saving. 

Save (CTRL+S): Saves the open NetPoint plan using a default name or a name specified by the user. 

Save As: Saves the NetPoint plan with a different name other than the default. 

Print (CTRL+P): Opens printer property box to change printer, print size, number of copies, etc. 

Print Setup: Determines the print size. Note: The choice of page size will determine the permanent viewable 
area for print and display of the file.   

Print Tiling (1x1): Provides a custom print/canvas size feature that allows you to print plans larger than the set 
printing area by using multiple print pages distributed horizontally and vertically to maximum of 50H x 50W. 

Recent File: Opens the most recent NetPoint plan. 

Export/Import: Allows the export or import between MS Project Primavera 6.0, Microsoft Excel and Synchro.  
You may also export into an XML format for further data integration to xml supported programs. 

Insert Image Files: Adds an image to be viewed on the planning surface. 
Screen Capture: Has two options: 1) Create Image of Schedule - captures the entire schedule for copy and 
paste into another application or to be saved as a file or other format in pixel size, which can be changed in the 
initial image settings property box.  2) Set Quick Capture Parameters - allows a portion of the schedule to be 
copied, pasted or saved in another format by holding the CTRL key placing pointer at the corner of the area to 
be captured, right click the mouse, enclose the portion to be captured, keeping the CTRL key pressed, then 
release right click of mouse, then release the CTRL key. Image can be pasted in another application.   

Exit: Closes the NetPoint program. 

EDIT 
Undo (CTRL+Z): Reverses up to15 previous actions excluding Zoom and Stretch, Page Setup, and Print 
Setup. 

Cut (CTRL+X): Removes or cuts selected items or a group of items. To select one item, click on the item using 
the OBJECT SELECT key. To select multiple items, click on a blank area of the canvas and drag the items, or 
click on one of the items, then click on the other desired items while holding down the SHIFT key. To unselect 
these items, click on a blank part of the canvas. 

Copy (CTRL+C): Creates duplicates of selected items, including logic fully contained within the copied items. 
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Paste (CTRL+V): Inserts copied items from a NetPoint plan on same calendar dates on the gridline specified. 
Note: If pasting to another plan, the calendar must be preset to accommodate the pasted items’ timescale. 

Delete (DEL): Deletes selected items by clicking Edit > Delete or by pressing the DEL key. Select items to be 
deleted by clicking on the item or by clicking on multiple items while holding down the SHIFT key. 

Select All (CTRL+A): Selects all items in the calendar for changes, duplication or movement in the plan. 

Find an Activity (CTRL+F): Matches numbers and letters exactly as entered into the search line. A list of 
potential matches appears for selection; the selected activity is highlighted in a yellow box. 

Find Multiple Objects: Provides instructions for all Find Multiple Activities function, found in user manual 
for Find Multiple Activities. 

Properties (ALT+ENTER): Opens the property box of a selected item. 

VIEW 
Toolbar: Displays toolbar only when this option is checked. To relocate Toolbar, right click on the area 
surrounding the icons; drag to the window edge and release right click. 

Resource Key: Displays a key of resource(s) as a moveable object on the canvas. Note: The resource key 
will not print on the canvas; instead it prints in the right hand corner of the title block. 

DISPLAY 
Color: Provides a list of default NetPoint colors and the Custom Color Palette for custom color selection for 
noncritical activity bars, nodes, milestones, benchmarks and iObjects. Select object(s), choose from palette or 
Define Custom Color by clicking on Font > Color > Custom Color; click OK to apply selected color. 

Background Color: Allows user to select a canvas background color from list or create a custom color.   

Calendar Strip Color: Allows user to select a color from the basic color palette or define a custom color.   

Title Block Color: Allows user to select a color from the basic color palette or create a defined custom color.   

Text Size: Sets the default text size of all iObjects excluding information objects. Note: Text size can be 
increased for ease of display, but may clash with other data. Generally, petite text is adequate for print. 

Text Size for Calendar Strip: Sets calendar strip font size. 
Set Default for Text Objects and Note Field: Allows format of text boxes or Note Fields. 

Set Default Attributes for New Activities: Allows format of subsequently added activities. Make selection, 
check Apply to implement changes, and select OK to exit box.  

Restore Color: Restores entire plan back to full color if faded through Find Multiple Activities, etc. 

Highlight Zero-Gap Chain: Highlights any activity with at least one zero gap relationship. 

TOOLS 
Line Up Activities: Places selected activities on the same horizontal line.  
Auto Link FS Chain: Automatically links selected objects that do not overlap the timescale by SHIFT+click or  
by clicking on empty canvas and “boxing in” objects to be linked. 

Set Properties for Selected Activities: Demonstrates global settings for selected objects on the canvas. 
Options include Fade, Display Resource Profile, Change Resource Requirements, Actualize, Change 
Behavior or Logic Type, etc. Also, noncritical activity bar color can be selected. If activity is critical, node colors 
are changed by selecting Paint End Nodes Solid and Change Node Color. 

Resources: Resource instructions for Definition, Assignment, Limits, Key, and Display Statistics are 
found in user manual for Resources. 
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Set Password: Password needed to read prevents plan viewing entirely. Password needed to modify 
allows a plan to be opened and modified but does not allow changes to be saved. To change/remove 
password, select No in the first box, enter password, change settings, and resave plan. A red border displays 
when plan is password protected. 

Create Hammock: Allows selected activities to be grouped into a summary activity that will reflect the 
changes of member activity dates. Select member activities on canvas, then select Tools > Create Hammock; 
choose grid number for hammock placement. Double or right click the hammock to input properties – Name, ID 
Code, Filters, Display Features, etc. More options are available by right clicking the hammock. 

OPTIONS 
Alignment Grid: Allows user to Change Grid Spacing for custom grid sizes (limits are specified) to enhance 
presentation of plan and reduce clashing of data. Note: This may require increase of page size in print 
setup. Prompt Grid for Pasting allows user to paste selected object in specified grid area. Note: To view grid 
numbers, Show Grid Numbers option must be checked.  

Logic: Maintains relationship logic rules when active.  
Holiday Line: When checked, displays holidays (H) and non-work days (N) calculated into workday durations 
on a red line at top of plan. 

Safe Mode: Locks all objects to planned dates, allowing only vertical grid movement. To restore date flexibility, 
return to this menu and select Exit Safe Mode. 

Show Grid Numbers: Displays the horizontal grid number to assist when pasting selected objects. 

Show Old Data Dates: Graphically reveals all data dates and associated data. 

Display Floats for Actualized Objects: Toggle option that displays floats and drifts for actualized 
activities.  

Display Floats and Drifts As: Displays floats of actualized objects as 1) CPM - where all floats are zero and 
objects display in critical color; or 2) Forensic - to show GPM forensic float of the as-built condition when data 
was actualized; objects display in their historical color. Uncheck to hide Floats and Drifts.. 

Override Critical Color for Delays: Allows original/new color of delay activity to be revealed whether in the 
critical state of zero float or not. 

SCHEDULE PROPERTIES 
Schedule Attributes: Sets the plan timescale by defining start and end dates for the calendar. The default 
calendar is set 6 months prior and 12 months after the current date. By selecting Use Calendar Dates, the 
Project Start and Project Completion are set to match the calendar dates. The Project Start and Project 
Completion date flags are easily adjusted graphically by selecting and dragging to desired dates. The Project 
Title will display in the legend at the bottom of the plan. Project Start/End flags may be shown or hidden and 
the Critical Threshold may be set. The strip and sightline display options show grids on the canvas as 
selected. Project Resources and Project Filters are also defined through Schedule Attributes. Detailed 
instructions are found in user manual.  

Working Calendar: Defines holidays defined within the current country setting and allows custom addition or 
deletion of nonworking days from calendar. Type directly into date boxes or use drop-down arrows to use pop-
up calendar. Modify workweek by selecting Change Work Week. To change country calendars, select Change 
Country and modify as described above.   

 

WINDOW 
Cascade: Reveals current open files.  

Tile: Arranges separate, opened plans actively on one screen. 
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HELP 
About PMA NetPoint: Provides general information (e.g., copyright and the www.pmatechnolgies link). 
Show NetPoint User Guide: Links to user manual (updated regularly by PMA Technologies). 

NetPoint FAQ: Posts questions to NetPoint Customer Support. (FAQ at 
www.pmatechnologies.com/netpoint_support.htm) 

 

OPTIONS AVAILABLE ONLY THROUGH RIGHT CLICK ON EMPTY CANVAS 
Set This Date As: Places Project Start, Project Finish, Data Date, or New Data Date on empty canvas by 
clicking crosshairs pointer. 
Shade: Creates a highlighted area on canvas. Select Shade either horizontal or vertical, right click on chart at 
Y-position to begin shade, then select color from menu. Left click on chart at desired Y-position of shade. Shade 
position may be modified at anytime by right clicking in shade and selecting Switch to Shade-Resize Mode. 
Color can be changed at any time by right clicking in shade and selecting Shade > Change Color. Switch to 
Shade Resize Mode: Right click within shade to be resized. Select Switch to Shade-Resize Mode to display 
handles on shade borders; use handles to resize shade. After resizing, right click anywhere on chart and select 
Shade- > Remove Shade-Resize Mode. 

Display Statistics: Displays overall schedule data such as activity, link count, durations, etc. 

Set Current Date As Target: Allows user to set multiple target dates in a plan. Compare to current dates by 
right clicking on empty canvas  select Set Current Date as Target #... ; repeat for multiple targets. 

Compare Target Dates: Creates a list by right clicking on Empty Canvas > Compare Target Dates or 
creates printable report via File > Export/Import > Export to Excel > Targets. Note: The target data for any 
activity is highlighted yellow if the date or duration is different than the current information for that activity.  
Edit Title Box: Allows data entry directly into Title Box.   
Global Actualize: After data date is entered, allows pending selected activities to be actualized at current 
planned dates or Slid to Data Date by selecting pending activities. Update activities individually if planned dates 
do not match actual revised dates.   

Reset Custom Display to Default: Allows user to reset custom displayed data globally or groups of 
selected activities or links. 

 

iObject Storage 
iObjects are stored and recalled in an absolute or full file path, which means the complete file path is used for 
storage and retrieval of objects. The path may vary depending on how your system is set up and on what 
operating system you use. For example, if your user name is jsmith, running Vista, and you want to reference 
photo xyz.jpg on your desktop, the full or absolute path to open the file would be:  
C:\users\jsmith\desktop\xyz.jpg 
Note: This works if you are the only person using this iObject on your computer. However, a better practice is to 
create a standard folder just below the C:\ directory for all iObjects (e.g., C:\iobjects\). If you store all iObject files 
in one directory, it will be easier to move your plans from computer to computer. 
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Importing/Exporting to External Programs  

Basic and Critical Primavera 6.0 Differences  
Note:  This procedure assumes that Primavera P6, Java JDK or JRE, and Primavera Integration API have 
already been installed on the system. 

 
Exporting to Primavera 

 
Open the schedule in NetPoint for export. 

 

Choose Export/Import from the File menu, then 
select Export to External Program: 

 

 
 

Next choose Export to Primavera P6: 

 

Select options for P6 export. 

 

Log in (details below). 

 

Name the project (details below). 
 

 

Logging In 
The login name and password MUST be a valid P6 program login. In addition, administrator privileges are 
required to allow creation of global resources and global information.   

 
Naming the Project 
The project name will uniquely identify this schedule within P6. If the name is not unique, the transfer process 
will make the name unique by appending a numerical suffix of the form (-1, -2 ... -100). Although P6 allows 
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project names of up to 20 characters, the transfer process imposes a limit of 14 characters to allow the addition 
of suffixes to ensure unique project and resource node names. 

 
Project Resource Names 
A parent resource node for the project resources is created with a -P appended to the project name. All 
resources associated with the project are children of this node. 

 

Critical Differences in Data Transfer between Primavera and NetPoint for 
Filters, Resources, Constraints, and Hammocks 
Several scheduling concepts are implemented differently in P6 and NetPoint. In these cases, it is necessary to 
map between these implementations when transferring data between the programs. 

 
FILTERS 
Filter codes used in NetPoint are imported into P6 as Activity Codes. NetPoint allows multiple filter values for the 
same category to be associated with a given activity. P6 allows only one value per category per activity. To 
avoid conflicts when importing filters, the transfer process will only export filter categories that are NOT 
multi-valued. 

 
RESOURCES – DAILY OR TOTAL  
In NetPoint, each resource is defined as having "per day" or "per activity" allocation. It is therefore possible to 
have a single activity that is associated with both resources. In P6, the "per day" or "per activity" distinction 
occurs on an activity-by-activity basis. This means that NetPoint activities that have both resource allocations 
cannot be transferred without some loss of information.  

 
 

 
NetPoint offers several ways to handle the discrepancy: 

• Convert all resources to "per day" 

• Convert all resource to "per activity" 

• Attempt to match the NetPoint resource type: 

• If all resources associated with an activity are 
the same type, use that type. 

• If resource types are mixed, three sub options 
are available: 

o Treat all as "per activity" 

o Treat all as "per day" 

o Ask the user 
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CONSTRAINTS 
NetPoint supports only two constraint types: 

1. Start No Earlier Than (NET) 

2. Finish No Later Than (NLT) 

 
P6 supports nine constraint types: 

1. As Late As Possible 

2. Finish On 

3. Finish On Or After 

4. Finish On Or Before 

5. Mandatory Finish 

6. Mandatory Start 

7. Start On 

8. Start On Or After 

9. Start On Or Before 

 

Up to two constraints can be applied to a given P6 activity. If both are applied, one is considered Primary, the 
other Secondary. 

 

When exporting an activity with only one constraint from NetPoint to P6, it is exported as the Primary constraint. 
If both NET and NLT constraints are found, the NET constraint is always considered Primary and the 
NLT Secondary. 

 

When importing an activity from P6 to NetPoint, only Start On Or Before and Finish On Or After constraints 
are imported. ALL OTHER CONSTRAINT TYPES ARE IGNORED. 

 

Example: Consider the following NetPoint schedule fragment: 
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The information for the previous schedule would appear in P6 as follows: 

 

 
 
If only one constraint is applied to an activity, it is shown in the Primary Constraint Date column. If there are 
two constraints applied, the Secondary Constraint Date column is populated. If a start constraint date is used, 
an asterisk appears after the date in the Start column. If a finish constraint date is used, the asterisk appears in 
the Finish column. 

 

Detailed information about a constraint is shown under the Status tab of the Activity Details panel, as below: 

 

 
 
 
HAMMOCKS 
NetPoint Hammocks: 

• May contain ONLY activities 

• May NOT be linked to other objects 

• Consist of a list of contained activities, without regard to any of the relationships (links) between the 
activities. 

 

P6 Hammocks: 

• May contain milestones and other non-activity objects. 

• May be linked to other objects, including other hammocks 

• Are defined by all chains of objects that begin with an object linked SS (either as predecessor or 
successor) to start of the hammock and end with an object linked FF (either as a predecessor or 
successor). The hammock activity in P6 MUST have an activity type of Level of Effort (LOE). 

 

Consider the following NetPoint schedule example: 
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Each hammock contains five activities. In NetPoint, the start of hammock H_1 is the earlier start of any of the 
activities in the hammock (A_1, B_1, C_1, D_1, E_1). In P6, the start of the hammock is the earliest start of any 
activity at the beginning of a chain. In H_1, this would be A_1 and D_1. In H_2, this would be AA_2, DD_2 and 
EE_2. 

 

A NetPoint hammock translates to a P6 Level of Effort activity. For the NetPoint schedule shown above, this 
would translate as follows:  

 

 
 
Notice the predecessor and successor relationships of the hammocks. P6 hammocks contain chains of 
activities. The first activity in a chain is linked to the hammock via an SS relationship, while the last activity in a 
chain is linked via an FF relationship. Notice that hammock H_1 contains two chains, while H_2 contains three 
(these hammocks would be equal in NetPoint). 


